I know the password is correct, I can see the user getting mail, they still can not send. Does anyone have any ideas?

Code:
May  8 22:10:12 mail2 saslauthd[29643]: zmauth: authenticating against elected url 'https://mail2.dmrcom.com:7071/service/admin/soap/' ...
May  8 22:10:12 mail2 saslauthd[29643]: zmpost: url='https://mail2.dmrcom.com:7071/service/admin/soap/' returned buffer->data='<soap:Envelope xmlns:soap="http://www.w3.org/2003/05/soap-envelope"><soap:Header><context xmlns="urn:zimbra"/></soap:Header><soap:Body><soap:Fault><soap:Code><soap:Value>soap:Sender</soap:Value></soap:Code><soap:Reason><soap:Text>authentication failed for user@domain.com</soap:Text></soap:Reason><soap:Detail><Error xmlns="urn:zimbra"><Code>account.AUTH_FAILED</Code><Trace>btpool0-638:1241845812143:daa54dcea13de9d8</Trace></Error></soap:Detail></soap:Fault></soap:Body></soap:Envelope>', hti->error=''
May  8 22:10:12 mail2 saslauthd[29643]: auth_zimbra: user@domain.com auth failed: authentication failed for user@domain.com
My  8 22:10:12 mail2 saslauthd[29643]: zmauth: authenticating against elected url 'https://mail2.dmrcom.com:7071/service/admin/soap/' ...
May  8 22:10:12 mail2 saslauthd[29643]: zmpost: url='https://mail2.dmrcom.com:7071/service/admin/soap/' returned buffer->data='<soap:Envelope xmlns:soap="http://www.w3.org/2003/05/soap-envelope"><soap:Header><context xmlns="urn:zimbra"/></soap:Header><soap:Body><soap:Fault><soap:Code><soap:Value>soap:Sender</soap:Value></soap:Code><soap:Reason><soap:Text>authentication failed for user@domain.com</soap:Text></soap:Reason><soap:Detail><Error xmlns="urn:zimbra"><Code>account.AUTH_FAILED</Code><Trace>btpool0-638:1241845812143:daa54dcea13de9d8</Trace></Error></soap:Detail></soap:Fault></soap:Body></soap:Envelope>', hti->error=''
May  8 22:10:12 mail2 saslauthd[29643]: auth_zimbra: user@domain.com auth failed: authentication failed for user@domain.com
May  8 22:10:12 mail2 saslauthd[29643]: do_auth         : auth failure: [user=user@domain.com] [service=smtp] [realm=oasismedical.com] [mech=zimbra] [reason=Unknown]
May  8 22:10:12 mail2 postfix/smtpd[24729]: warning: SASL authentication failure: Password verification failed
May  8 22:10:12 mail2 postfix/smtpd[24729]: warning: unknown[32.133.47.251]: SASL PLAIN authentication failed: authentication failure
May  8 22:10:12 mail2 postfix/smtpd[24729]: lost connection after AUTH from unknown[32.133.47.251]
May  8 22:10:12 mail2 postfix/smtpd[24729]: disconnect from unknown[32.133.47.251]
ay  8 22:10:12 mail2 saslauthd[29643]: do_auth         : auth failure: [user=user@domain.com] [service=smtp] [realm=domain.com] [mech=zimbra] [reason=Unknown]
May  8 22:10:12 mail2 postfix/smtpd[24729]: warning: SASL authentication failure: Password verification failed