Results 1 to 5 of 5

Thread: ProxyServlet Basic Authentication Not Working

  1. #1
    jfavero is offline Project Contributor
    Join Date
    Jan 2007
    Posts
    31
    Rep Power
    8

    Default ProxyServlet Basic Authentication Not Working

    Here is the URL I am passing to the Proxy Servlet. I do not seem to see any Basic Authentication happening to my server:

    "/service/proxy?target=http://192.168.1.2:9000/Users/jfavero/Zimbra&user=jfavero&pass=jfavero&auth=basic"

  2. #2
    KevinH's Avatar
    KevinH is offline Expert Member
    Join Date
    Aug 2005
    Location
    San Mateo, CA
    Posts
    4,789
    Rep Power
    19

    Default

    try putting it in the url like http://USER:PASS@URL
    Looking for new beta users -> Co-Founder of Acompli. Previously worked at Zimbra (and Yahoo! & VMware) since 2005.

  3. #3
    JLee is offline Zimbra Employee
    Join Date
    Oct 2005
    Posts
    59
    Rep Power
    9

    Default

    Does your server at http://192.168.1.2:9000/Users/jfavero/Zimbra get any HTTP request at all? You might be suffering from lack of ACL to 192.168.1.2. Did you run zmzimletctl acl on your zimlet?

  4. #4
    jfavero is offline Project Contributor
    Join Date
    Jan 2007
    Posts
    31
    Rep Power
    8

    Default

    I am receiving the HTTP requests at my server I am running TCPMon in between to inspect the requests as they go through. There is no Authentication information being passed in. I have setup the allowDomains to be *. Is there something about the ACL that needs to be changed??

    PS ... I tried the USER:PASS suggestion ... that does not work either

  5. #5
    JLee is offline Zimbra Employee
    Join Date
    Oct 2005
    Posts
    59
    Rep Power
    9

    Default

    It could be that '?' and '&' are getting URL encoded somewhere. Can you show the relevant line in the tomcat access log for that request?

Thread Information

Users Browsing this Thread

There are currently 1 users browsing this thread. (0 members and 1 guests)

Similar Threads

  1. Basic Authentication
    By jfavero in forum Zimlets
    Replies: 1
    Last Post: 04-21-2010, 01:29 AM
  2. Does Zimbra support IMAP Secure Authentication?
    By zzzzsg in forum Administrators
    Replies: 6
    Last Post: 11-06-2009, 07:19 PM
  3. Authentication to external ldap stop working.
    By jahaj in forum Installation
    Replies: 3
    Last Post: 12-05-2006, 03:17 PM
  4. Basic Authentication access
    By francoisal in forum Administrators
    Replies: 3
    Last Post: 04-05-2006, 08:41 AM
  5. Remote calendar that requires basic authentication
    By Flyen in forum Administrators
    Replies: 5
    Last Post: 04-04-2006, 11:49 AM

Posting Permissions

  • You may not post new threads
  • You may not post replies
  • You may not post attachments
  • You may not edit your posts
  •