Page 3 of 3 FirstFirst 123
Results 21 to 30 of 30

Thread: Contact Collector Broken

  1. #21
    jholder's Avatar
    jholder is offline Former Zimbran
    Join Date
    Oct 2005
    Location
    Thatcher, AZ
    Posts
    5,606
    Rep Power
    20

    Default

    What am I thinking??

    Just undeploy and delete the thing.

    Then download it from gallery.zimbra.com and upload it using admin interface.


  2. #22
    syntaxerror is offline Member
    Join Date
    Jan 2007
    Posts
    13
    Rep Power
    8

    Default

    use admin interface to enable zimlet? I'm not on 4.5 yet.

    download from gallery.zimbra.com? Where is the download link?

    Could this be a reason for the error:
    Cost - Zimlet (free) requires Salesforce.com webservices API which may be an added cost. The Enterprise and Unlimited Edition of Salesforce.com already include full API support.
    -from Zimbra Gallery

  3. #23
    syntaxerror is offline Member
    Join Date
    Jan 2007
    Posts
    13
    Rep Power
    8

    Default

    Upgraded to 4.5.0 and the contact collector zimlet is now working properly!

  4. #24
    jholder's Avatar
    jholder is offline Former Zimbran
    Join Date
    Oct 2005
    Location
    Thatcher, AZ
    Posts
    5,606
    Rep Power
    20

    Default

    Great!
    Now upgrade to 4.5.1

  5. #25
    jtroxel is offline Member
    Join Date
    Jul 2006
    Posts
    13
    Rep Power
    8

    Default More issues with Collector

    On 4.5.1... I can't get this to work, either.

    Building the zimlet off of the SVN trunk, I get a javascript error:
    AjxDispatcher is not defined, collector.js line 76

    If I download from Gallery, I get the following on deployment:

    Zimlet: com_zimbra_collector
    []INFO: Undeploying on zdev3.razorstream.com
    [] INFO: Undeploy successful
    [] INFO: Deploying on zdev3.razorstream.com
    [] INFO: Deploy successful
    [] INFO: Enabling Zimlet com_zimbra_collector
    Error: Cannot enable Zimlet com_zimbra_collector
    [] INFO: Adding Zimlet com_zimbra_collector to COS default
    [] INFO: error loading zimlet com_zimbra_collector
    com.zimbra.cs.account.AccountServiceException: no such zimlet: com_zimbra_collector
    at com.zimbra.cs.account.AccountServiceException.NO_S UCH_ZIMLET(AccountServiceException.java:155)
    at com.zimbra.cs.zimlet.ZimletUtil.getZimletConfig(Zi mletUtil.java:176)
    at com.zimbra.cs.zimlet.ZimletUtil.activateZimlet(Zim letUtil.java:654)
    at com.zimbra.cs.zimlet.ZimletUtil.aclZimlet(ZimletUt il.java:776)
    at com.zimbra.cs.zimlet.ZimletUtil.dispatch(ZimletUti l.java:1399)
    at com.zimbra.cs.zimlet.ZimletUtil.main(ZimletUtil.ja va:1461)

    My script to [re]deploy zimlets, if you care, is
    #!/bin/sh
    if [ $# -ne 1 ]; then
    echo 1>&2 Usage: $0 zimlet
    exit 127
    fi

    ## Strip off extension if any
    zimlet=${1%%.*}

    echo "Zimlet: $zimlet"

    zmzimletctl undeploy $zimlet
    zmzimletctl deploy $zimlet.zip
    zmzimletctl enable $zimlet
    zmzimletctl acl $zimlet default grant

    Any help appreciated, as usual.

    - John

  6. #26
    jtroxel is offline Member
    Join Date
    Jul 2006
    Posts
    13
    Rep Power
    8

    Default ...Issue on Frank, too

    I also built from FRANK, and I get the same js error.

  7. #27
    raviproff is offline Member
    Join Date
    Aug 2007
    Location
    Chennai, India
    Posts
    10
    Rep Power
    7

    Angry

    I get same js error....

    JS Error:
    AjxDispatcher is not defined
    this._contactList = AjxDispatcher.run("GetContacts");

  8. #28
    farqhuarson is offline Starter Member
    Join Date
    Nov 2007
    Posts
    1
    Rep Power
    7

    Default

    Quote Originally Posted by raviproff View Post
    I get same js error....

    JS Error:
    AjxDispatcher is not defined
    this._contactList = AjxDispatcher.run("GetContacts");
    I also am getting the same JS error, has a solution for this problem been found?

  9. #29
    JoshuaPrismon is offline Zimlet Guru & Moderator
    Join Date
    Nov 2005
    Posts
    477
    Rep Power
    9

    Default

    Quote Originally Posted by farqhuarson View Post
    I also am getting the same JS error, has a solution for this problem been found?
    It almost sounds like a 5.0 bit of code made it back into 4.5 codebase. I don't think AjxDispatcher existed before then. Am I incorrect in thinking that.

  10. #30
    raviproff is offline Member
    Join Date
    Aug 2007
    Location
    Chennai, India
    Posts
    10
    Rep Power
    7

    Default

    Yes, you are correct. I'm using ZCS 5.x beta

Page 3 of 3 FirstFirst 123

Thread Information

Users Browsing this Thread

There are currently 1 users browsing this thread. (0 members and 1 guests)

Similar Threads

  1. Replies: 12
    Last Post: 06-13-2013, 08:55 AM
  2. Outlook Migration Wizard + Contact Groups
    By thegeekiator in forum Migration
    Replies: 4
    Last Post: 07-13-2007, 03:00 PM
  3. Replies: 1
    Last Post: 03-24-2007, 01:30 PM
  4. One user's Address Book broken in Contact List view
    By dowdle in forum Administrators
    Replies: 4
    Last Post: 02-06-2007, 12:58 AM
  5. Contact Display
    By tbullock in forum Users
    Replies: 1
    Last Post: 05-24-2006, 09:56 AM

Posting Permissions

  • You may not post new threads
  • You may not post replies
  • You may not post attachments
  • You may not edit your posts
  •