Results 1 to 4 of 4

Thread: [SOLVED] Contact Collector Zimlet fails to deploy

  1. #1
    gacain is offline Member
    Join Date
    Nov 2007
    Location
    Sacramento, CA
    Posts
    11
    Rep Power
    7

    Default [SOLVED] Contact Collector Zimlet fails to deploy

    Hi -

    Today I'm trying to deploy the "Contact Collector" zimlet. I've tried doing this both through the admin console and the CLI (Zimbra 6.0.5 - Ubuntu 64 NE). Each time it fails to deploy. There is an error in /opt/zimbra/log/mailbox.log:

    2010-04-13 16:02:35,382 INFO [Thread-295140] [] zimlet - deploy
    java.io.FileNotFoundException: zimlet description not found: com_zimbra_collector.xml
    at com.zimbra.cs.zimlet.ZimletFile.initZimletDescript ion(ZimletFile.java:250)
    at com.zimbra.cs.zimlet.ZimletFile.initialize(ZimletF ile.java:206)
    at com.zimbra.cs.zimlet.ZimletFile.<init>(ZimletFile. java:154)

    On opening the .zip file, I see that the xml file is indeed present.

    Any ideas about why this is happening and how I might fix it would be much appreciated.

    Greg
    If it's stupid and it works it's not stupid

  2. #2
    gacain is offline Member
    Join Date
    Nov 2007
    Location
    Sacramento, CA
    Posts
    11
    Rep Power
    7

    Default

    Never mind. I discovered the problem. For some reason the paths were packed in the zip file. I extracted and re-zipped them with out the paths. Problem solved.
    If it's stupid and it works it's not stupid

  3. #3
    Sir Bob is offline Active Member
    Join Date
    Apr 2009
    Location
    Calgary, Alberta
    Posts
    31
    Rep Power
    6

    Default

    Hi Gacain,

    I am having a similar problem, but am not quite understanding what you mean when you say "the paths were packed in the zip file". I have unzipped the file and see the different files associated with the zimlet, but am not quite sure where I would see the path.

    Could you please provide a little more info on this?
    Sir Bob

  4. #4
    gacain is offline Member
    Join Date
    Nov 2007
    Location
    Sacramento, CA
    Posts
    11
    Rep Power
    7

    Default

    Hi Sir Bob,

    I use an old version of Winzip to handle zip files. When you open a .zip archive with it, it shows the relative paths to which the files will unzip. All the other zimlets I've installed have no relative paths, but evidently whoever zipped this group of files included the paths in the archive information. Evidently Zimbra can't deal with that information. My solution was to open the zip file, extract the zipped files to my desktop, and create a new .zip file withOUT saving the relative path information. Then I deployed the zimlet using the new .zip file. Worked like a charm.

    If you need more information on this, please don't hesitate to contact me here or directly.

    Greg
    If it's stupid and it works it's not stupid

Thread Information

Users Browsing this Thread

There are currently 1 users browsing this thread. (0 members and 1 guests)

Similar Threads

  1. [SOLVED] Fails to deploy....
    By Chewie71 in forum Zimlets
    Replies: 4
    Last Post: 10-13-2009, 07:10 AM
  2. Contact Collector fails to deploy
    By mckoz in forum Zimlets
    Replies: 0
    Last Post: 02-11-2009, 11:30 AM
  3. xmbx_search Zimlet fails to deploy
    By ropana in forum Zimlets
    Replies: 7
    Last Post: 12-12-2008, 03:31 PM
  4. Address contact sync fails
    By sleepkreep in forum CalDAV / CardDAV / iSync
    Replies: 0
    Last Post: 09-08-2008, 09:20 AM
  5. [SOLVED] All Zimlet Deploy Fails Zimbra 4.5.10
    By cantormath in forum Installation
    Replies: 7
    Last Post: 12-22-2007, 07:38 PM

Posting Permissions

  • You may not post new threads
  • You may not post replies
  • You may not post attachments
  • You may not edit your posts
  •