Results 1 to 3 of 3

Thread: Unsupported major.minor version 49.0

  1. #1
    mbenattar is offline New Member
    Join Date
    Feb 2010
    Posts
    3
    Rep Power
    5

    Default Unsupported major.minor version 49.0

    i have tried to install a zimlet manually (the windows installer somehow didn't worked out for me - it didn't worked as an hta file, and renamed to htm it kind of freezed after "deploying zimlet..")

    followed the next steps:
    1. running Zimbra Desktop

    2. saved zimlet zips into C:\Documents and Settings\Benattar1\Local Settings\Application Data\Zimbra\zdesktop\zimlets

    3. Run:
    C:\Documents and Settings\Benattar1\Local Settings\Application Data\Zimbra\zdesktop>java -cp jetty\lib\log4j-1.2.8.jar;jetty\common\lib\commons-httpclient-3.0.jar;jetty\common\lib\mail.jar;jetty\common\lib \commons-logging.jar;jetty\common\lib\commons-codec-1.3.jar;jetty\common\lib\json.jar;jetty\common\lib \dom4j-1.5.jar;jetty\common\lib\zimbracommon.jar;jetty\we bapps\service\WEB-INF\lib\zimbrastor
    e.jar -Dzimbra.config=conf\localconfig.xml com.zimbra.cs.zimlet.ZimletUtil deploy zimlets\ZimbraNotifier.zip

    ------> result is:

    Exception in thread "main" java.lang.UnsupportedClassVersionError: com/zimbra/cs/zimlet/ZimletUtil (Unsupported major.minor version 49.0)
    at java.lang.ClassLoader.defineClass0(Native Method)
    at java.lang.ClassLoader.defineClass(Unknown Source)
    at java.security.SecureClassLoader.defineClass(Unknow n Source)
    at java.net.URLClassLoader.defineClass(Unknown Source)
    at java.net.URLClassLoader.access$100(Unknown Source)
    at java.net.URLClassLoader$1.run(Unknown Source)
    at java.security.AccessController.doPrivileged(Native Method)
    at java.net.URLClassLoader.findClass(Unknown Source)
    at java.lang.ClassLoader.loadClass(Unknown Source)
    at sun.misc.Launcher$AppClassLoader.loadClass(Unknown Source)
    at java.lang.ClassLoader.loadClass(Unknown Source)
    at java.lang.ClassLoader.loadClassInternal(Unknown Source)

    Any idea

  2. #2
    sposetti is offline Former Zimbran
    Join Date
    Nov 2009
    Posts
    105
    Rep Power
    5

    Default

    Confirm which version of Java you are running:

    From cmd prompt, run "java -version".

    And confirm, you are running Zimbra Desktop 1.0?

    Also, a wiki page on deploying zimlets to Zimbra Desktop:

    ZCS 6.0:Zimlet Developers Guideev Environment Setup - Zimbra :: Wiki

  3. #3
    mbenattar is offline New Member
    Join Date
    Feb 2010
    Posts
    3
    Rep Power
    5

    Default

    Hi sposetti,

    I can confirm that i am runing Zimbra desktop, 1.0.4, build 1833.
    Following the wiki's advise, I have turned on the logs.

    i have unsuccessfully tried to install manually the asterisk zimlet (which should provide me with Skype IM capabilities no?) on 2 of my stations:

    1. my desktop: was the one that output the above message
    runing Win 2k SP4
    but is now experimenting some issues - so let's forget that


    2. my LT:
    -> seems i've successfully completed the manual installation, but i can't see any change on my zd... (i have stopped and started the service)
    runing win XP SP3
    java -version returns:
    java version "1.6.0_13"
    Java(TM) SE Runtime Environment (build 1.6.0_13-b03)
    Java HotSpot(TM) Client VM (build 11.3-b02, mixed mode, sharing)

    Additionally, note that i have tried to debug the zimlet windowsinstaller hta file and it is a pain (e.g. users like me don't have a Yahoo entry in their registry, it's only "Zimbra desktop bla bla...", and so on and so forth), now the ZDesktop

    any clue?

Thread Information

Users Browsing this Thread

There are currently 1 users browsing this thread. (0 members and 1 guests)

Similar Threads

  1. Unsupported Addin - iTunes
    By vandehey in forum Zimbra Connector for Outlook
    Replies: 10
    Last Post: 06-01-2010, 03:05 PM
  2. Replies: 2
    Last Post: 12-15-2008, 02:18 PM
  3. unsupported !!
    By egrueda in forum Installation
    Replies: 1
    Last Post: 11-01-2007, 07:33 AM
  4. Unsupported Character errors?
    By Vladimir in forum Zimbra Mobile
    Replies: 9
    Last Post: 08-29-2007, 02:58 PM
  5. Replies: 6
    Last Post: 02-23-2007, 07:35 AM

Posting Permissions

  • You may not post new threads
  • You may not post replies
  • You may not post attachments
  • You may not edit your posts
  •