Results 1 to 5 of 5

Thread: [SOLVED] Zimlets broken

  1. #1
    LaFong is offline Advanced Member
    Join Date
    Nov 2008
    Location
    Denver, CO
    Posts
    221
    Rep Power
    6

    Angry [SOLVED] Zimlets broken

    I'm considering whether to implement Zimbra at our new company. The Zimlets seem a bit flaky though. I installed several, and most wouldn't work. I found a thread that mentioned the Sales Force zimlet had to be configured, or it would break others (!). I undeployed it, and the others now work. However, I haven't been able to get the Travel agent one to work. I can bring up the prefs, but none of the other Travel agent menu items do anything. I can find no errors in the logs. In other threads, it seems zimlets are often broken, esp. in v5.x. I'm using the latest, zcs-5.0.10_GA_2638. Since v5 has been out since February, it's troubling that items like this haven't been fixed by now. Am I missing something?

    I also had to do a full reinstall, because changing the connection URL to redirect using zmtlsctl still does not work. Again, troubling.

    It is a very nice web GUI though.

  2. #2
    LaFong is offline Advanced Member
    Join Date
    Nov 2008
    Location
    Denver, CO
    Posts
    221
    Rep Power
    6

    Default Re: Zimlets broken

    Well, the Travel agent works as expected on testzimbra site, no surprise. On my site, in the Firefox javascript console, I get this error:

    Error: this._appCtxt is undefined
    Source File: https://192.168.1.222/service/zimlet...gz?language=en
    Line: 5553

  3. #3
    LaFong is offline Advanced Member
    Join Date
    Nov 2008
    Location
    Denver, CO
    Posts
    221
    Rep Power
    6

    Default Re: Zimlets broken

    More from the javascript debugger:

    showSideStepDlg()(undefined, undefined, undefined, undefined, undefined)

    this error seems to refer to undefined personal settings:
    this.flightPage = new TravelAgentFlightFindView(this.tabView,this._appCt xt, this,homeOptions, workOptions, workZip, homeZip);

  4. #4
    LaFong is offline Advanced Member
    Join Date
    Nov 2008
    Location
    Denver, CO
    Posts
    221
    Rep Power
    6

    Default FIXED - Travel agent

    Well, I got it working. I had to undeploy the Travel agent I downloaded from Zimbra (I didn't realize it was in the zimlet-extras folder before). I had to manually delete the com_zimbra_travelagent folder from opt/zimbra/jetty/webapps/service/zimlet/. I redeployed the one from the extras folder, it works.

  5. #5
    mmorse's Avatar
    mmorse is offline Moderator
    Join Date
    May 2006
    Location
    USA
    Posts
    6,242
    Rep Power
    21

    Default

    Yes a few of them need to be updated in the Gallery (as you can see by your zimlet-extras/experimental folders not everything is on the site either) we're also planning a gallery revamp so stay tuned.

Thread Information

Users Browsing this Thread

There are currently 1 users browsing this thread. (0 members and 1 guests)

Similar Threads

  1. unable to use zimlets
    By ras in forum Zimlets
    Replies: 3
    Last Post: 04-03-2009, 05:46 AM
  2. Replies: 1
    Last Post: 04-07-2008, 08:58 AM
  3. Zimlets Webinar: July 24th
    By GregA in forum Webinars
    Replies: 12
    Last Post: 09-12-2007, 09:24 PM
  4. where are my zimlets ?
    By santo in forum Zimlets
    Replies: 21
    Last Post: 06-05-2007, 07:30 AM
  5. Graphs and Zimlets not displaying?
    By nadia007 in forum Installation
    Replies: 13
    Last Post: 11-24-2006, 07:51 AM

Posting Permissions

  • You may not post new threads
  • You may not post replies
  • You may not post attachments
  • You may not edit your posts
  •