Page 2 of 2 FirstFirst 12
Results 11 to 16 of 16

Thread: Zimlets

  1. #11
    outdated is offline Junior Member
    Join Date
    Feb 2006
    Posts
    9
    Rep Power
    9

    Default

    I'm having some problems using the proxy servlet.

    I added the config_template.xml to my test zimlet, re-deployed it, and but got a 403 forbidden error. I also tried using zmzimletctl configure config_template.xml, thinking the deploy may not have refreshed the allowed domains from the zip file, but no luck either.

    Is there someplace I can view the allowed domains? per zimlet?

    Thanks,
    Edwardo

  2. #12
    KevinH's Avatar
    KevinH is offline Expert Member
    Join Date
    Aug 2005
    Location
    San Mateo, CA
    Posts
    4,789
    Rep Power
    18

    Default

    You can see them in ldap(zmprov to get the COS info). You need to also restart tomcat when you change XML properties as we cache the LDAP info.
    Looking for new beta users -> Co-Founder of Acompli. Previously worked at Zimbra (and Yahoo! & VMware) since 2005.

  3. #13
    outdated is offline Junior Member
    Join Date
    Feb 2006
    Posts
    9
    Rep Power
    9

    Default

    Thanks. I do see the target domain I added when using "zmprov gc <cos>".

    Oddly though, this morning the proxy does work for me. I didn't do a restart, at least not this time (I had restarted Zimbra previously but still had problems). The only thing that was different was I had to log back in (no authentication token error returned by the Proxy).

    If I can reproduce it, I'll let you know.

  4. #14
    KevinH's Avatar
    KevinH is offline Expert Member
    Join Date
    Aug 2005
    Location
    San Mateo, CA
    Posts
    4,789
    Rep Power
    18

    Default

    *this morning*.... The cache is short lived like on the order of 20min. So overnight it refreshed itself. The restart forces this so it's instant.
    Looking for new beta users -> Co-Founder of Acompli. Previously worked at Zimbra (and Yahoo! & VMware) since 2005.

  5. #15
    outdated is offline Junior Member
    Join Date
    Feb 2006
    Posts
    9
    Rep Power
    9

    Default

    Still having a few issues.

    After deploying my updated zimlet with the allowedDomain, it eventually showed up in zmprov.
    Code:
    $ zmzimletctl deploy com_zimbra_url2.zip
    $ tomcat restart
    $ zmprov gc default
    ...
    zimbraProxyAllowedDomains:  *.news.com
    ...
    But I'm still getting a 403 error for the new domain.
    firefox: http://<host>/service/proxy?target=http://www.news.com

    After more testing, here's an exception that may be related. I tried disabling a bundled zimlet and got:

    Code:
    $ zmzimletctl disable com_zimbra_url.zip
    [] INFO: Disabling Zimlet com_zimbra_url.zip
    Error: Cannot enable Zimlet com_zimbra_url.zip: [LDAP: error code 32 - No Such Object]
    The same happens for enabling.

    Does this indicate a problem with the LDAP component?

  6. #16
    marcmac is offline Expert Member
    Join Date
    Sep 2005
    Posts
    2,103
    Rep Power
    13

    Default

    drop the .zip from the disable (or undeploy) command:
    zmzimletctl deploy com_foo_bar.zip
    zmzimletctl undeploy com_foo_bar

Page 2 of 2 FirstFirst 12

Thread Information

Users Browsing this Thread

There are currently 1 users browsing this thread. (0 members and 1 guests)

Similar Threads

  1. Zimlets Webinar: July 24th
    By GregA in forum Webinars
    Replies: 12
    Last Post: 09-12-2007, 09:24 PM
  2. where are my zimlets ?
    By santo in forum Zimlets
    Replies: 21
    Last Post: 06-05-2007, 07:30 AM
  3. Can't Deploy Zimlets after upgrade to 4.5.5
    By ajsp in forum Installation
    Replies: 2
    Last Post: 05-17-2007, 07:17 AM
  4. Graphs and Zimlets not displaying?
    By nadia007 in forum Installation
    Replies: 13
    Last Post: 11-24-2006, 07:51 AM
  5. No zimlets displayed in 3.2 M1/M2
    By pepijn in forum Administrators
    Replies: 2
    Last Post: 07-28-2006, 06:32 AM

Posting Permissions

  • You may not post new threads
  • You may not post replies
  • You may not post attachments
  • You may not edit your posts
  •