Results 1 to 3 of 3

Thread: Proxy service & allowedDomains

  1. #1
    riogd is offline Senior Member
    Join Date
    Apr 2006
    Posts
    50
    Rep Power
    9

    Default Proxy service & allowedDomains

    I am trying to test a zimlet I have just made and am running into 403 errors on /service/proxy?
    First of all I made a testing COS called ztesting, the only one where I am enabling the Zimlet, for testing purposes.
    My config_template.xml has:
    Code:
    		<property name="allowedDomains">*.mydomain.com, *.zimbra.com</property>
    (although I believe it may not be read as I can't access the other global properties as described in this other thread)
    And I have modifed this testing COS like this:
    Code:
    zimbra@myhost:~/log$ zmprov mc ztesting zimbraProxyAllowedDomains "*.mydomain.com, *.zimbra.com"
    Just in case, I even restarted zimbra after making those changes and I am still getting a 403 error.
    Code:
    xx.xx.xx.xx - - [05/Sep/2007:19:28:35 -0700] "POST /service/proxy?target=https://targeturl HTTP/1.1" 403 964 "https://mydomain.com/zimbra/mail" "Mozilla/5.0 (X11; U; Linux i686; en-US; rv:1.8.1.6) Gecko/20070725 Firefox/2.0.0.6"
    This is of course shown in Firebug as well.

    To help assure that this wasn't just poor coding on my part, I installed ArunaURL, and it is getting the same errors on it's proxy requests.

    Can anyone tell where I have erred or is there any more information I can provide to help figure that out ?

    Cheers,

    RioGD

  2. #2
    riogd is offline Senior Member
    Join Date
    Apr 2006
    Posts
    50
    Rep Power
    9

    Default

    I believe I have found the problem, and it may be a bug. As reported elsewhere, the config_template only is applied to the default COS. Thus the only way to make Zimlets work under non-default COS's, that I have found, is to manually:
    Code:
    zmprov mc <non-default-COS> zimbraProxyAllowedDomains "*.domain.com"
    Now the rather large problem, and what makes this seem even more like a bug, is that although the config isn't applied to non-default COS's, re-deploying the Zimlet wipes out the zimbraProxyAllowedDomains for all non-default COS's. So each time you redeploy the Zimlet you have to go and make that manual change. This is why I was constantly getting 403's, my manual settings kept getting wiped without my knowing it.

    If it can automatically wipe my manual settings, it would be nice if it could automatically apply the supplied config settings I want to begin with so I don't need to do it manually I suspect this may also be why I couldn't access the global settings from within the js code, the config_template is probably not accessible from non-default COS's. Time to test that theory now.

    Cheers,

    RioGD

  3. #3
    JoshuaPrismon is offline Zimlet Guru & Moderator
    Join Date
    Nov 2005
    Posts
    477
    Rep Power
    9

    Default

    Quote Originally Posted by riogd View Post
    I believe I have found the problem, and it may be a bug. As reported elsewhere, the config_template only is applied to the default COS. Thus the only way to make Zimlets work under non-default COS's, that I have found, is to manually:
    Code:
    zmprov mc <non-default-COS> zimbraProxyAllowedDomains "*.domain.com"
    Now the rather large problem, and what makes this seem even more like a bug, is that although the config isn't applied to non-default COS's, re-deploying the Zimlet wipes out the zimbraProxyAllowedDomains for all non-default COS's. So each time you redeploy the Zimlet you have to go and make that manual change. This is why I was constantly getting 403's, my manual settings kept getting wiped without my knowing it.

    If it can automatically wipe my manual settings, it would be nice if it could automatically apply the supplied config settings I want to begin with so I don't need to do it manually I suspect this may also be why I couldn't access the global settings from within the js code, the config_template is probably not accessible from non-default COS's. Time to test that theory now.

    Cheers,

    RioGD
    Please let us know, that's a interesting tidbit.

Thread Information

Users Browsing this Thread

There are currently 1 users browsing this thread. (0 members and 1 guests)

Similar Threads

  1. Zimbra Proxy
    By danny.sierra@omtech.net in forum Administrators
    Replies: 1
    Last Post: 08-10-2007, 05:21 AM
  2. imap proxy enable/disable
    By kmuralidharan in forum Administrators
    Replies: 0
    Last Post: 07-23-2007, 03:31 AM
  3. Webmail + postfix proxy
    By kechols in forum Administrators
    Replies: 2
    Last Post: 06-18-2007, 05:25 AM
  4. Zimlet 403 via Proxy Help
    By blakekrone in forum Zimlets
    Replies: 3
    Last Post: 12-08-2006, 10:45 AM
  5. How to make Zimbra use HTTP Proxy on outgoing requests?
    By martinm_76 in forum Installation
    Replies: 2
    Last Post: 09-03-2006, 09:13 AM

Posting Permissions

  • You may not post new threads
  • You may not post replies
  • You may not post attachments
  • You may not edit your posts
  •