From this link:
Zimbra - Product Editions
it says that apparently one cannot use J2ME in combination with versions that have domain level administration and/or domain level branding.

Is this an error ??
If not what is the reason for this?

Regards