Page 6 of 8 FirstFirst ... 45678 LastLast
Results 51 to 60 of 77

Thread: Zimbra and Joomla Project

  1. #51
    brained is offline Loyal Member
    Join Date
    Dec 2005
    Posts
    94
    Rep Power
    9

    Default

    Preauth works. No Joomla LDAP auth, no account creation.

  2. #52
    richardcwgate's Avatar
    richardcwgate is offline Project Contributor
    Join Date
    Nov 2007
    Posts
    34
    Rep Power
    7

    Default

    Quote Originally Posted by brained View Post
    Preauth works. No Joomla LDAP auth, no account creation.
    Is it ok if we take one problem at a time and start off with the "no account creation" problem?

    I assume you means that you are using my Joomla plugin for creating a Zimbra account and that it is configured via the Joomla Admin pages. When you register a Joomla User do you get an error displayed at the top of the page?
    ----------------------------------------------
    Having signatures is a sign of having signatures.

  3. #53
    brained is offline Loyal Member
    Join Date
    Dec 2005
    Posts
    94
    Rep Power
    9

    Default

    No error messages displayed from Joomla. The account is successfully created in Joomla and is usable immediately after activation.

    Simultaneously the above quoted error appears in the zimbra.log.

    The servers' FQHN is zimbra.chromedcomputing.com.
    The accounts being created are for a virtual domain clean-wire.net.
    I've tried the LDAP config with both set as dc and the error is the same regardless.

  4. #54
    richardcwgate's Avatar
    richardcwgate is offline Project Contributor
    Join Date
    Nov 2007
    Posts
    34
    Rep Power
    7

    Default

    Brian

    Looking at "the above quoted error" I cannot see an error only two sucessfully completed authorisation requests. Is there an error that I have missed?

    Sorry to keep asking but are you using my Zimbra account creation plug-in? Is it enabled and what parameters are being used (excluding passwords).
    ----------------------------------------------
    Having signatures is a sign of having signatures.

  5. #55
    richardcwgate's Avatar
    richardcwgate is offline Project Contributor
    Join Date
    Nov 2007
    Posts
    34
    Rep Power
    7

    Default

    Brian, If you would like to contact me directly, please use the contact us e-mail address on All Our EMail - Home
    Last edited by richardcwgate; 05-13-2008 at 06:40 AM.
    ----------------------------------------------
    Having signatures is a sign of having signatures.

  6. #56
    dljordaneku is offline Elite Member
    Join Date
    Sep 2007
    Location
    Richmond, Ky
    Posts
    281
    Rep Power
    7

    Default

    Ok. I got it to where I didn't have to create everyones account in Joomla first but just authentic against the Zimbra LDAP. Here are the settings I used.




    Host servername
    Port 389
    LDAP V3 Yes
    Negotiate TLS No
    Follow referrals N
    Authorization Method Bind and Search
    Base DN ou=people,dc=domain,dc=domain,dc=domain
    Search String uid=[search]
    Users DN

    Connect username
    Connect password

    Map: Full Name displayName
    Map: E-mail mail
    Map: User ID uid


    dj

  7. #57
    richardcwgate's Avatar
    richardcwgate is offline Project Contributor
    Join Date
    Nov 2007
    Posts
    34
    Rep Power
    7

    Default

    Try using...

    Base DN - dc=servername,dc=com (or what ever you use)
    Search String - leave blank
    Users DN - uid=[username],ou=people,dc=servername,dc=com (or what ever you use)
    ----------------------------------------------
    Having signatures is a sign of having signatures.

  8. #58
    dljordaneku is offline Elite Member
    Join Date
    Sep 2007
    Location
    Richmond, Ky
    Posts
    281
    Rep Power
    7

    Default

    I guess what I am saying is that I got it to work as I want it to. I don't have to create any users in the Joomla Users manager. People can just log in with their Zimbra username and Password and it works fine.

    dj

  9. #59
    richardcwgate's Avatar
    richardcwgate is offline Project Contributor
    Join Date
    Nov 2007
    Posts
    34
    Rep Power
    7

    Default

    Quote Originally Posted by dljordaneku View Post
    I guess what I am saying is that I got it to work as I want it to. I don't have to create any users in the Joomla Users manager. People can just log in with their Zimbra username and Password and it works fine.

    dj
    I see what is happening now, you are using "Authorization Method Bind and Search" and I was using "Authorization Method - Bind Directly as User". You are correct, in your method Joomla is able to get the users e-mail address via LDAP from Zimbra so I has enough information to work as a Joomla "Registered" user, removing the need to create a Joomla user.
    ----------------------------------------------
    Having signatures is a sign of having signatures.

  10. #60
    iway is offline Partner (VAR/HSP)
    Join Date
    May 2008
    Posts
    432
    Rep Power
    7

    Default

    Hi!
    Authentication works for us now, but only for users who's domain is in the ou?people,dc=domain1,dc=com line.

    Users with domain2.com or domain3.com can not authenticate.

    This seems to be a problem from the BASE DN line.

    Any ideas how I can search in multiple domains?

    Thanks

    Chris

Page 6 of 8 FirstFirst ... 45678 LastLast

Thread Information

Users Browsing this Thread

There are currently 1 users browsing this thread. (0 members and 1 guests)

Posting Permissions

  • You may not post new threads
  • You may not post replies
  • You may not post attachments
  • You may not edit your posts
  •