Results 1 to 5 of 5

Thread: Self signed Certificate problem with Windows Phone 7

  1. #1
    Iom
    Iom is offline Member
    Join Date
    Sep 2011
    Posts
    12
    Rep Power
    3

    Default Self signed Certificate problem with Windows Phone 7

    Hi all

    I need to sync some mobile phone to zimbra accounts. I have no problem with Android, Iphone, Blackberry, ...

    But with Windows Phone 7, I can't do anything.

    My server has self signed certificates, and the client can't buy other certs...
    When I configure account in Windows Phone, i have the error (approximatively translated): "the server's cert has problem. Contact your tech support . Error code : 80072F0D"

    If I unckeck "Use SSL connexion", my phone can't find the server.

    Any idea to enable sync with self signed cert?

  2. #2
    phoenix is online now Zimbra Consultant & Moderator
    Join Date
    Sep 2005
    Location
    Vannes, France
    Posts
    23,586
    Rep Power
    57

    Default

    This is a question for Microsoft not Zimbra, you need to import the certificate into your phone: +"windows mobile 7" +"import certificate" - Yahoo! Search Results
    Regards


    Bill


    Acompli: A new adventure for Co-Founder KevinH.

  3. #3
    Iom
    Iom is offline Member
    Join Date
    Sep 2011
    Posts
    12
    Rep Power
    3

    Default

    Ok.

    I've imported the cert from /opt/zimbra/ssl/ca/ca.pem into my phone. Is it the good one?

    It doesn't work anyway but I will look on MS forums...

  4. #4
    bhwong is offline Outstanding Member
    Join Date
    Feb 2009
    Location
    Singapore
    Posts
    503
    Rep Power
    7

    Default

    How do I export Zimbra Certificate from the Admin Console? I can only see Import Certificate.

    Quote Originally Posted by phoenix View Post
    This is a question for Microsoft not Zimbra, you need to import the certificate into your phone: +"windows mobile 7" +"import certificate" - Yahoo! Search Results
    I found the solution here but can anyone tell me that this is safe?

    Error with self-signed certificate: Unable to sync Windows Phone | Techyv.com

  5. #5
    bhwong is offline Outstanding Member
    Join Date
    Feb 2009
    Location
    Singapore
    Posts
    503
    Rep Power
    7

    Default

    The problem is solved:

    1. You need to go to: /opt/zimbra/ssl/zimbra/ca directory and you need to copy the ca.pem file to a safe location.
    2. You need to use this codes and run on the file you copied:
    $ openssl x509 -in ca.pem -inform PEM -out MyCertificatecrtcer -outform DER
    3. Now, you may need to copy the new MyCertificatecrt.cer file to your Windows Phone.
    4. With the use of your phone’s File Manager, you can now click on the MyCertificate.crt file and you should receive a message that it was successfully imported to your device.
    5. Lastly, you need to enable SSL in ActiveSync on your phone.

    Taken from: Error with self-signed certificate: Unable to sync Windows Phone | Techyv.com

Thread Information

Users Browsing this Thread

There are currently 1 users browsing this thread. (0 members and 1 guests)

Similar Threads

  1. Problem Zimbra Desktop 2.0.1 Windows 2000
    By antonello74 in forum Installation Help
    Replies: 0
    Last Post: 02-23-2011, 01:41 AM
  2. Replies: 59
    Last Post: 12-05-2008, 10:33 AM
  3. Certificate problem
    By phoenix in forum General Questions
    Replies: 17
    Last Post: 04-19-2007, 11:22 AM
  4. Replies: 6
    Last Post: 04-06-2007, 08:32 PM

Posting Permissions

  • You may not post new threads
  • You may not post replies
  • You may not post attachments
  • You may not edit your posts
  •