There is an issue with the E52/E72 which I am aware of and is being fixed in 6.0.6 with the sync on these Nokia's. That is to do with sending mail.

However earlier today the people using the E72 suddenly stopped being able to Sync. I found this in the log and it doesn't look right but I don't know enough to be sure this is the problem area:
Code:
2010-03-24 08:23:25,809 WARN  [btpool0-0://rafflesenergy.com:3000/Microsoft-Server-ActiveSync?User=fc&DeviceId=IMEI355239033365789&DeviceType=NokiaEmail&Cmd=FolderSync] [name=fc;mid=7;ip=119.234.38.173;Cmd=FolderSync;DeviceID=IMEI355239033365789;] sync - SyncState: client stuck on item=0; skip and end itemized mode
2010-03-24 08:23:25,809 DEBUG [btpool0-0://rafflesenergy.com:3000/Microsoft-Server-ActiveSync?User=fc&DeviceId=IMEI355239033365789&DeviceType=NokiaEmail&Cmd=FolderSync] [name=fc;mid=7;ip=119.234.38.173;Cmd=FolderSync;DeviceID=IMEI355239033365789;] sync - SyncState (class=Folder): last sync reverted; version=1; modseq=635; filter=0; cutoff=-1; clientsize=9/9
2010-03-24 08:23:25,868 DEBUG [btpool0-0://rafflesenergy.com:3000/Microsoft-Server-ActiveSync?User=fc&DeviceId=IMEI355239033365789&DeviceType=NokiaEmail&Cmd=FolderSync] [name=fc;mid=7;ip=119.234.38.173;Cmd=FolderSync;DeviceID=IMEI355239033365789;] sync - SyncState: statesaved; insync; version=2; modseq=2922; filter=0; cutoff=-1; clientsize=9
2010-03-24 08:23:25,869 DEBUG [btpool0-0://rafflesenergy.com:3000/Microsoft-Server-ActiveSync?User=fc&DeviceId=IMEI355239033365789&DeviceType=NokiaEmail&Cmd=FolderSync] [name=fc;mid=7;ip=119.234.38.173;Cmd=FolderSync;DeviceID=IMEI355239033365789;] sync -

Any opinions?