Page 2 of 2 FirstFirst 12
Results 11 to 19 of 19

Thread: Activesync doesn't work

  1. #11
    Ced91 is offline Active Member
    Join Date
    Jan 2008
    Posts
    33
    Rep Power
    7

    Default

    We have a valid license and a support case is open..? Case 00018974.
    Is it a reason to not post here????
    I don't undertand...
    I've indicated all the ways the webmail is running fine.
    My first post indicate: "Webmail access work from internet and lan and mobile access too."
    This will indicate that the mobile access from internet explorer on the HTC work.
    Ok I've not mention in the first post if all the test was made with 3G, sorry. But I give you the information after.

    Could you answer to :
    "I have tried the mode mixed and both: in this two mode the webmail authentication is made under HTTPS from inside and outside? This will indicate that the outlook connector must have the parameter to secure connection enable? This will indicate too that I have to teach all the PC with the certificate...
    My conclusion is that I have to set the HTTPS mode only.... and reconfigure all the PC...


    I have to ask to the provider to open the 443 port monday and close the 85."

    Thanks Klug and the other for your support,

    Ced.

  2. #12
    Klug's Avatar
    Klug is offline Moderator
    Join Date
    Mar 2006
    Location
    Beaucaire, France
    Posts
    2,292
    Rep Power
    13

    Default

    Quote Originally Posted by Ced91 View Post
    We have a valid license and a support case is open..? Case 00018974.
    Is it a reason to not post here????
    No it's not of course 8)

    Quote Originally Posted by Ced91 View Post
    I've indicated all the ways the webmail is running fine.
    My first post indicate: "Webmail access work from internet and lan and mobile access too."
    This will indicate that the mobile access from internet explorer on the HTC work.
    Switching to French - sorry for others.

    La question n'était pas de savoir si le webmail fonctionne mais de savoir si depuis le HTC on peut avoir accès au webmail lorsqu'on est en 3G (donc savoir si le HTC arrive à se connecter sur le port 85 en http).

    Surtout qu'on ne peut pas se connecter en webmail en AJAX depuis un HTC (mais en HTML si, comme je le disais).

    Quote Originally Posted by Ced91 View Post
    Could you answer to :
    "I have tried the mode mixed and both: in this two mode the webmail authentication is made under HTTPS from inside and outside? This will indicate that the outlook connector must have the parameter to secure connection enable? This will indicate too that I have to teach all the PC with the certificate...
    For the Zimbra server, there's no difference between "inside" and "outside".

    "both" should enable http and https (and you can use the one you want.

    "mixed" is different : if you connect to the webmail using http, you should be redirected to https to login then back to http.

    Quote Originally Posted by Ced91 View Post
    My conclusion is that I have to set the HTTPS mode only.... and reconfigure all the PC...
    As long as we don't know where the problem is (it seems to be ActiveSync on the HTC but not sure), I'm not sure switching to https is a needed.

    Quote Originally Posted by Ced91 View Post
    I have to ask to the provider to open the 443 port monday and close the 85."
    Just an additional thought : if you're using an ISA server as firewall, you might have to define special rules to get ActiveSync working.
    Last edited by Klug; 01-19-2008 at 07:23 AM.

  3. #13
    Ced91 is offline Active Member
    Join Date
    Jan 2008
    Posts
    33
    Rep Power
    7

    Default

    Klug,

    I resume:

    The webmail access (port 85) in 3G Mode work from internet explorer on the HTC, the mobile profile on the authentication window too. For AJAX I was knowing that this was only for computer with web brother enable and not for PDA.

    Activesync doesn't work on the 85 port.

    The server mode mixed and both do the same authentication with HTTPS. I've tested it today. (zmtlsctl and next zmcontrol stop/start before the tests). Perhaps is there a bug?

    If this two mode are using HTTPS for authentication, my only best way is to use a single port with full HTTPS or perhaps return to the default port 80?

    In all case I have to parameter the PC...


    Regards,

    Ced.

  4. #14
    Klug's Avatar
    Klug is offline Moderator
    Join Date
    Mar 2006
    Location
    Beaucaire, France
    Posts
    2,292
    Rep Power
    13

    Default

    John, you were wrong (well at least Google says it 8)) : it's not possible to change the ActiveSync port on the smartphone, it's "hardcoded".

    There are tons of people wishing they could change it, some even think there's a registry key (on the device) but no one knows/found it.

    While you can change the port on the server-side, you're stuck device-side.

    So Cédric, you were right and you'll need to use port 80 or 443 if you web Zimbra Mobile.

    You can either change your whole setup or maybe get another public IP and link port 80 on this new IP to 85 internaly.

    If you use "both" (on 85 for http and 443 for mobile), how does the ZCO react ?

  5. #15
    Ced91 is offline Active Member
    Join Date
    Jan 2008
    Posts
    33
    Rep Power
    7

    Default

    I've tried today the both mode.

    Doesn't work with WM6. Windows Mobile doesn't accept automaticaly the certificate and doesn't autorize activesync communication. Yes I've installed the ca.der certificate on the HTC, but WM6 under Internet explorer ask always to validate the use of a non verify certificate and activesync doesn't connect with the same problem in my opinion.

    Now I tried to modify the HTTP port of the server to the standard 80 and got an error:
    >zmprov ms "servername" zimbraMailPort 80
    ERROR: service.INVALID_REQUEST (invalid request: port 993 conflict between zimbraImapSSLBindPort and zimbraImapSSLProxyBindPort on server "servername"

    So I'm realy blocked now...

    Ced.

  6. #16
    mmorse's Avatar
    mmorse is offline Moderator
    Join Date
    May 2006
    Location
    USA
    Posts
    6,242
    Rep Power
    20

    Default

    Run this command all on one line (type the whole thing before hitting enter):
    zmprov -l ms server.domain.com zimbraPop3BindPort 110 zimbraPop3SSLBindPort 995 zimbraPop3ProxyBindPort 7110 zimbraPop3SSLProxyBindPort 7995 zimbraImapBindPort 143 zimbraImapSSLBindPort 993 zimbraImapProxyBindPort 7143 zimbraImapSSLProxyBindPort 7993
    Followed by a zmcontrol stop/start then try your modification of zimbraMailPort.

  7. #17
    mmorse's Avatar
    mmorse is offline Moderator
    Join Date
    May 2006
    Location
    USA
    Posts
    6,242
    Rep Power
    20

    Default

    Note those are the defaults (if you use different put that in) as well as placing a 7 in front of any of the proxy related ports so you stop getting a conflict. (I assume this is a single server install without a need for the IMAP/POP proxy.)

  8. #18
    Ced91 is offline Active Member
    Join Date
    Jan 2008
    Posts
    33
    Rep Power
    7

    Default

    Ok, thanks mmorse, this is ok for the server ports changes.
    I will try tomorrow for the Mobile access, since I have to change all the outlook connectors configurations on all the pc's before....

  9. #19
    Ced91 is offline Active Member
    Join Date
    Jan 2008
    Posts
    33
    Rep Power
    7

    Default

    Hi,

    All it's ok now with the defaults ports.
    But It's doesn't give me a configuration to use the HTTPS mode and use the certificate generate by the server. WM6 doesn't autorize to use, without confirmation, a non verificable certificate.

    Thanks for all,

    Ced.

Page 2 of 2 FirstFirst 12

Thread Information

Users Browsing this Thread

There are currently 1 users browsing this thread. (0 members and 1 guests)

Similar Threads

  1. Sync with Palm Treo 700w with ActiveSync
    By jonnyRo in forum Zimbra Mobile
    Replies: 5
    Last Post: 01-05-2007, 04:39 PM
  2. ActiveSync Scheduling Error
    By bted in forum Zimbra Mobile
    Replies: 3
    Last Post: 11-09-2006, 09:00 PM
  3. Replies: 42
    Last Post: 08-11-2006, 09:50 AM
  4. HELP- Making Zimbra work. after installation
    By hifriend1 in forum Installation
    Replies: 7
    Last Post: 04-05-2006, 06:43 AM

Posting Permissions

  • You may not post new threads
  • You may not post replies
  • You may not post attachments
  • You may not edit your posts
  •