Results 1 to 10 of 10

Thread: E61i and zimbra mobile Secure Connection Issue

  1. #1
    betatester is offline Junior Member
    Join Date
    Aug 2007
    Posts
    6
    Rep Power
    7

    Default E61i and zimbra mobile Secure Connection Issue

    Hi,

    I installed zimbra network-edition trial-version and created some accounts for testing. I have successfully configured it and everything is working ( no rocket-science) thanx to zimbra install methods.

    I am syncing my user zimbra to my E61i, currently on wifi, and it sync fine on plan-text ( insecure ) mode, I am using mail-for-exchange 1.6, the newest on my phone.

    The problem is when I try using secure-connection the phone doesnt seem to find the server. I tested the secure connection with outlook and it works fine.

    anyone has any clue.

    The server has no-firewall running and its an opensuse 10 box, with zimbra 4.5.6

    Any help would be appreciated.

  2. #2
    phoenix is offline Zimbra Consultant & Moderator
    Join Date
    Sep 2005
    Location
    Vannes, France
    Posts
    23,201
    Rep Power
    56

    Default

    Welcome to the forums.

    Have you followed the instructions on the wiki?
    Regards


    Bill


    Acompli: A new adventure for Co-Founder KevinH.

  3. #3
    betatester is offline Junior Member
    Join Date
    Aug 2007
    Posts
    6
    Rep Power
    7

    Default betatester

    Yeah, everything sync absolutely flawlessly to E61i when I do check the secure-connection to no. everything I mean the callender, the pushmail function, the contacts even.

    As soon as I revert back to secure mode , there is nothing " could not connect to server"

  4. #4
    phoenix is offline Zimbra Consultant & Moderator
    Join Date
    Sep 2005
    Location
    Vannes, France
    Posts
    23,201
    Rep Power
    56

    Default

    More, rather obvious, questions but what mode is running (https or mixed) and what port did you change the phone to?
    Regards


    Bill


    Acompli: A new adventure for Co-Founder KevinH.

  5. #5
    hannes is offline Member
    Join Date
    Apr 2007
    Location
    Germany
    Posts
    10
    Rep Power
    7

    Default

    I had a very similar problem with my E61i at first. I soon discovered that the actual problem was the used SSL-Certificate of the server. Especially if you use a self-created one, you need to import the certificate into the phone.
    Everything worked well for me after I did so.

  6. #6
    betatester is offline Junior Member
    Join Date
    Aug 2007
    Posts
    6
    Rep Power
    7

    Default beta tester

    Quote Originally Posted by phoenix View Post
    More, rather obvious, questions but what mode is running (https or mixed) and what port did you change the phone to?
    Well if by mode you mean the phone it has only two
    1: secure connection ( yes )
    2: secure connection ( no)

    If you mean a ZCS mode thats altogether something I havent checked at all, for me the client works on mail server, and the admin-panel on https://myailserver.com:7071/

    The SSL Certificate works in my outlook on the laptop for both IMAP, and SMTP access, with all the usuall messages that come with the selfsigned cert.

    I have downloaded the certificate in my E61i, as that was something I thought was required, as pointed out in wiki.

    Any clue what might be my mistake. I am sure its something to do with configurations.

    regards and thanks

  7. #7
    betatester is offline Junior Member
    Join Date
    Aug 2007
    Posts
    6
    Rep Power
    7

    Default

    Quote Originally Posted by hannes View Post
    I had a very similar problem with my E61i at first. I soon discovered that the actual problem was the used SSL-Certificate of the server. Especially if you use a self-created one, you need to import the certificate into the phone.
    Everything worked well for me after I did so.
    Ok what ports are you using? and are you using Imap IDLE or mailforexchange? because IMAP in E61i does give me certificate errors, whereas mailforexchange simply doesnt connect.

    I do have a selfsigned cert offcourse at this point in time.

  8. #8
    betatester is offline Junior Member
    Join Date
    Aug 2007
    Posts
    6
    Rep Power
    7

    Default betatester

    What if I am running ZCS in "both" mode???? . mailforexchange now gives me
    a message saying

    Untrusted Certificate recieved from server contact you administrator.

    Atleast the no-connection message is gone.

    I have downloaded and save my certificate in .der format in my nokia E61i, is there a way to force mailforexchange to use it??

  9. #9
    hannes is offline Member
    Join Date
    Apr 2007
    Location
    Germany
    Posts
    10
    Rep Power
    7

    Default

    If you have already downloaded the certificate on your E61, you just need to "execute" the file on the phone. Mailforexchange will use the certificate after it got imported automatically.

  10. #10
    betatester is offline Junior Member
    Join Date
    Aug 2007
    Posts
    6
    Rep Power
    7

    Default betatester

    "execute" where do I do that in the phone. all I see is saved certificate and edit trust settings. I have already edited trust settings to use the certificate on Internet and cert-check..

    Any Ideas about E61i may be I am missing something?

Thread Information

Users Browsing this Thread

There are currently 1 users browsing this thread. (0 members and 1 guests)

Posting Permissions

  • You may not post new threads
  • You may not post replies
  • You may not post attachments
  • You may not edit your posts
  •