Page 1 of 2 12 LastLast
Results 1 to 10 of 11

Thread: ZCS Connector Upgrade Problems

  1. #1
    gotwalt's Avatar
    gotwalt is offline Junior Member
    Join Date
    Jun 2007
    Location
    Harrisburg, PA
    Posts
    6
    Rep Power
    8

    Default ZCS Connector Upgrade Problems

    I realized that I'm running ZCS Connector 4.0.4 and decided to upgrade to 4.5.5 (what we're running on our server), but the installer requires the original installer (ZimbraOlkConnector-4.0.4_GA_456_4.0.290.msi) in order to complete. If I don't supply it, it fails the upgrade. I don't have the old installer of course - that was months ago...is there a way around this? I can't remove it in Add/Remove Programs for the same reason.
    Last edited by gotwalt; 06-06-2007 at 10:31 AM. Reason: inaccurate title

  2. #2
    alee is offline Former Zimbran
    Join Date
    Apr 2007
    Location
    San Jose
    Posts
    406
    Rep Power
    8

    Default "Zimbra" profile

    i remember that there was an issue way back that the uninstaller was looking for a profile called "Zimbra" to remove and it would give you an error if it wasn't there. if you don't have this profile, just create one (doesn't need to be configured properly) and then try to uninstall.

  3. #3
    gotwalt's Avatar
    gotwalt is offline Junior Member
    Join Date
    Jun 2007
    Location
    Harrisburg, PA
    Posts
    6
    Rep Power
    8

    Default The "Zimbra" profile suggestion

    Didn't work...thanks for the fast response, though. Any other ideas?

  4. #4
    sam
    sam is offline Zimbra Employee
    Join Date
    Aug 2005
    Posts
    821
    Rep Power
    11

    Default

    We've seen this issue rarely and haven't found the root cause. In most cases when you install an msi, windows keeps a local version of the msi for uninstallation. It seems as though your local version doesn't exist.

    Exactly how did you install the 4.0.1 connector? Did you install it from a network share? Did you run it as a local administrator?
    Sam Khavari

    :: :: [ Zimbra ] :: :: [ Bugzilla ] :: :: [ Product Portal ] :: :: [ Wiki ] :: :: [ Downloads ] :: :: [ . ] ::

  5. #5
    gotwalt's Avatar
    gotwalt is offline Junior Member
    Join Date
    Jun 2007
    Location
    Harrisburg, PA
    Posts
    6
    Rep Power
    8

    Default 4.0.1 Installation

    Honestly, it's been a while, but I'm on a machine joined to a domain, and my account is a local administrator. Wildcards: we changed domains since I installed the plugin and I've rebuilt my Zimbra profile a couple of times. It was likely installed directly off of my desktop folder, but there is the possibility it came from a network share.

  6. #6
    mmorse's Avatar
    mmorse is offline Moderator
    Join Date
    May 2006
    Location
    USA
    Posts
    6,242
    Rep Power
    21

    Default

    It might still be in an archive file repository...There are archives-you could possibly open a support request to download/get the file ZimbraOlkConnector-4.0.4_GA_456_4.0.290.msi

    And worst case senario (if it's really that crucial:
    You could install the zcs network edition 4.0.4 on another machine and browse to the tomcat/zimbra/downloads folder. However, it will probably have a different sub-version # instead of .290, but it might be close enought to work. *cross fingers*

    Seems like a lot for one outlook connector; but hey, we each have varying levels of 'free' time.

  7. #7
    gotwalt's Avatar
    gotwalt is offline Junior Member
    Join Date
    Jun 2007
    Location
    Harrisburg, PA
    Posts
    6
    Rep Power
    8

    Default

    Yeah - downloading 4.04 and testing that out completely exceeds the available effort I've got. This is a product I'm paying for, and upgrading the client's a pretty normal thing to want to do...

  8. #8
    mmorse's Avatar
    mmorse is offline Moderator
    Join Date
    May 2006
    Location
    USA
    Posts
    6,242
    Rep Power
    21

    Default

    I figured as much-perhaps a zimbra employee with access to an archive might come along and send it to you or pm you a link...or the use the MS cleanup utility
    Last edited by mmorse; 12-23-2007 at 12:52 AM.

  9. #9
    phoenix is offline Zimbra Consultant & Moderator
    Join Date
    Sep 2005
    Location
    Vannes, France
    Posts
    23,581
    Rep Power
    57

    Default

    Quote Originally Posted by gotwalt View Post
    Yeah - downloading 4.04 and testing that out completely exceeds the available effort I've got. This is a product I'm paying for, and upgrading the client's a pretty normal thing to want to do...
    Try installing the Microsoft installer clean up utility and see if you can get rid of it using that.
    Regards


    Bill


    Acompli: A new adventure for Co-Founder KevinH.

  10. #10
    gotwalt's Avatar
    gotwalt is offline Junior Member
    Join Date
    Jun 2007
    Location
    Harrisburg, PA
    Posts
    6
    Rep Power
    8

    Default Success!

    Hey - thanks, the Install Cleanup utility worked. It removed it from the list of installed apps, but outlook still ran with the old connector after removing it. I thought it didn't work, but on a whim decided to try running the 4.5.5 installer, and it worked right away.

    Thanks everyone for your help.

Page 1 of 2 12 LastLast

Thread Information

Users Browsing this Thread

There are currently 1 users browsing this thread. (0 members and 1 guests)

Similar Threads

  1. Problems installing ZCS connector for Outlook
    By Millburn357 in forum Zimbra Connector for Outlook
    Replies: 18
    Last Post: 11-25-2009, 10:07 AM
  2. Trouble Sending mail - All Messages deferred!
    By SiteDiscovery in forum Administrators
    Replies: 7
    Last Post: 09-03-2009, 04:52 AM
  3. iSync Connector / Apple Address Book Problems
    By jrosen in forum CalDAV / CardDAV / iSync
    Replies: 11
    Last Post: 04-16-2007, 03:40 PM
  4. Network Edition restore problems??
    By jdell in forum Administrators
    Replies: 0
    Last Post: 10-25-2006, 05:00 PM
  5. ZCS 3.2 Beta Available
    By KevinH in forum Announcements
    Replies: 31
    Last Post: 07-07-2006, 03:46 PM

Posting Permissions

  • You may not post new threads
  • You may not post replies
  • You may not post attachments
  • You may not edit your posts
  •