Page 1 of 3 123 LastLast
Results 1 to 10 of 22

Thread: [SOLVED] Tasks sync fails

  1. #1
    quietas is offline Elite Member
    Join Date
    Aug 2007
    Location
    Anchorage, AK
    Posts
    376
    Rep Power
    7

    Default [SOLVED] Tasks sync fails

    I've set up a user on Win 7 with Outlook 2010, both are 32bit. I'm using ZCS 7.0.1 still with the 7.1 ZCO (7.0.1 ZCO crashes).

    I'm trying to figure out why I am having sync errors. In the Zimbra Send/Receive Progress I get a sync task that is in progress, says "Total 37.62kb transferred, processing folder 'Tasks'. It stalls there for a few minutes, then gets marked Failed, and then repeats.

    Any idea what it is failing to sync? The user is currently on WinXP, Office 2010, ZCO 7.1 and working fine as far as I can tell.
    Culley
    Mail | Dell 2950III | 2x Quad Core 5420 | 8gb RAM | 6x 146gb SAS RAID 0+1 | Red Hat 5.3 | Zimbra 6.0.10 Network Edition
    Test | VMware ESXi Whitebox | Phenom II Black 3.2ghz | 12gb RAM | 6x 1tb SATA RAID 0+1 | CentOS 5.4 | FOSS, Not in use now

  2. #2
    quietas is offline Elite Member
    Join Date
    Aug 2007
    Location
    Anchorage, AK
    Posts
    376
    Rep Power
    7

    Default

    I deleted the Windows mail profile, recreated the Outlook setup, and also updated ZCO and ZCS to the current 7.1.x whatever. I still have it hanging at syncing with the processing Tasks message. I also tried deleting only the .idm file to let it reindex, but no luck there either.

    Any ideas?
    Last edited by quietas; 06-01-2011 at 10:10 AM.
    Culley
    Mail | Dell 2950III | 2x Quad Core 5420 | 8gb RAM | 6x 146gb SAS RAID 0+1 | Red Hat 5.3 | Zimbra 6.0.10 Network Edition
    Test | VMware ESXi Whitebox | Phenom II Black 3.2ghz | 12gb RAM | 6x 1tb SATA RAID 0+1 | CentOS 5.4 | FOSS, Not in use now

  3. #3
    quietas is offline Elite Member
    Join Date
    Aug 2007
    Location
    Anchorage, AK
    Posts
    376
    Rep Power
    7

    Default

    Under further examination I think it is the To-Do list that is having the issue. For some reason the To-Do list has far more entries than the Tasks list. Any idea how to get these to sync?
    Culley
    Mail | Dell 2950III | 2x Quad Core 5420 | 8gb RAM | 6x 146gb SAS RAID 0+1 | Red Hat 5.3 | Zimbra 6.0.10 Network Edition
    Test | VMware ESXi Whitebox | Phenom II Black 3.2ghz | 12gb RAM | 6x 1tb SATA RAID 0+1 | CentOS 5.4 | FOSS, Not in use now

  4. #4
    quietas is offline Elite Member
    Join Date
    Aug 2007
    Location
    Anchorage, AK
    Posts
    376
    Rep Power
    7

    Default

    As an update, this user is also using WinXP/Outlook 2010 and hasn't been able to sync or download any mail.
    Culley
    Mail | Dell 2950III | 2x Quad Core 5420 | 8gb RAM | 6x 146gb SAS RAID 0+1 | Red Hat 5.3 | Zimbra 6.0.10 Network Edition
    Test | VMware ESXi Whitebox | Phenom II Black 3.2ghz | 12gb RAM | 6x 1tb SATA RAID 0+1 | CentOS 5.4 | FOSS, Not in use now

  5. #5
    fsiegel is offline Zimbra Employee
    Join Date
    Sep 2006
    Posts
    1,334
    Rep Power
    10

    Default

    We may have a bug in this area for certain tasks. If it's the same issue, one thing you can do is enable zco logging (just logging and http, not verbose), and do a sync. Then look in the log for "got unexpected exception". If you find it, go about 60 or 70 lines above that, and look for "GetTaskResponse", and send me the part of the log from GetTaskResponse to the error.

    Or you can look at the xml for GetTaskResponse, and you could see which task is causing the problem, and then delete it. If this is the issue, you might first do a show original on it, and post the .ics here, so I can see what is causing the exception.

    This may or may not be the issue, but it's worth a try.

  6. #6
    quietas is offline Elite Member
    Join Date
    Aug 2007
    Location
    Anchorage, AK
    Posts
    376
    Rep Power
    7

    Default

    I ended up putting in a support ticket. The solution was to delete the profile and all the .idb/.zdb/.pst files. It did it again yesterday, I'll look through the previous logs and see what it was doing.
    Culley
    Mail | Dell 2950III | 2x Quad Core 5420 | 8gb RAM | 6x 146gb SAS RAID 0+1 | Red Hat 5.3 | Zimbra 6.0.10 Network Edition
    Test | VMware ESXi Whitebox | Phenom II Black 3.2ghz | 12gb RAM | 6x 1tb SATA RAID 0+1 | CentOS 5.4 | FOSS, Not in use now

  7. #7
    fsiegel is offline Zimbra Employee
    Join Date
    Sep 2006
    Posts
    1,334
    Rep Power
    10

    Default

    What was the support case number?

  8. #8
    quietas is offline Elite Member
    Join Date
    Aug 2007
    Location
    Anchorage, AK
    Posts
    376
    Rep Power
    7

    Default

    00070127 is the ticket number. I have narrowed the sync issue to something corrupted in the tasks for sure. I went into the user account via the ZCS web client and saw that some completed tasks would not display. I stepped back with the advanced search and deleted completed tasks one month at a time. I found May 2010 to be the offending month. I was able to delete tasks from that time period and the tasks will now display in ZCS web correctly, but I suspect there is an issue still because ZCO still will not sync. It gets further, 230 something kb, but it will not finish completely.

    Along with this we have noticed that mail folders have not sync'd past folders starting with T also. This would make since if TA in tasks comes before the rest of T through Z.
    Culley
    Mail | Dell 2950III | 2x Quad Core 5420 | 8gb RAM | 6x 146gb SAS RAID 0+1 | Red Hat 5.3 | Zimbra 6.0.10 Network Edition
    Test | VMware ESXi Whitebox | Phenom II Black 3.2ghz | 12gb RAM | 6x 1tb SATA RAID 0+1 | CentOS 5.4 | FOSS, Not in use now

  9. #9
    fsiegel is offline Zimbra Employee
    Join Date
    Sep 2006
    Posts
    1,334
    Rep Power
    10

    Default

    I believe the problem is a recurring task called Budget Planning Schedule. We seem to crash while syncing recurring tasks. I have filed a bug on that, bug 60779. We are investigating.

    If you save that task off somewhere, and then get rid of it, I suspect all your syncing problems will go away.

    How did you create that task, as the web client doesn't allow you to create recurring tasks. Was it imported from an .ics?

  10. #10
    quietas is offline Elite Member
    Join Date
    Aug 2007
    Location
    Anchorage, AK
    Posts
    376
    Rep Power
    7

    Default

    I'll ask and find out. That task is the only one with an attachment I have noticed as well.
    Culley
    Mail | Dell 2950III | 2x Quad Core 5420 | 8gb RAM | 6x 146gb SAS RAID 0+1 | Red Hat 5.3 | Zimbra 6.0.10 Network Edition
    Test | VMware ESXi Whitebox | Phenom II Black 3.2ghz | 12gb RAM | 6x 1tb SATA RAID 0+1 | CentOS 5.4 | FOSS, Not in use now

Page 1 of 3 123 LastLast

Thread Information

Users Browsing this Thread

There are currently 1 users browsing this thread. (0 members and 1 guests)

Similar Threads

  1. tasks sync with windows mobile
    By jayel in forum Zimbra Mobile
    Replies: 7
    Last Post: 06-07-2009, 04:50 AM
  2. Replies: 13
    Last Post: 11-20-2008, 12:42 PM
  3. Tasks Breaking Sync
    By knabe in forum Zimbra Mobile
    Replies: 8
    Last Post: 08-19-2008, 03:34 PM
  4. Hangs on "Loading" screen
    By gbr in forum General Questions
    Replies: 16
    Last Post: 06-19-2008, 01:01 PM
  5. Zimbra Mobile fails with Java Exception
    By JasonChase in forum Zimbra Mobile
    Replies: 7
    Last Post: 01-21-2008, 07:25 PM

Posting Permissions

  • You may not post new threads
  • You may not post replies
  • You may not post attachments
  • You may not edit your posts
  •