Results 1 to 4 of 4

Thread: ZCO 7.1 causes Outlook 2010 Outbox problem

  1. #1
    james654 is offline New Member
    Join Date
    May 2011
    Posts
    3
    Rep Power
    3

    Default ZCO 7.1 causes Outlook 2010 Outbox problem

    Server:
    Intel Q6600, 4GB RAM
    zcs-NETWORK-7.1.0_GA_3140.UBUNTU8_64.20110329135528

    Clients:
    Intel i5 2500, 8GB RAM
    Windows 7 Professional 64-bit
    Microsoft Outlook 2010 32-bit
    ZimbraConnectorOLK_7.1.0.6314_x86

    Situation:
    A user with the above client configuration chooses not to send email immediately from Outlook. Sometimes he may view or edit email in his Outbox before issuing a 'Send and Receive'

    Issue:
    After the user views the Outbox or edits an email in the Outbox, Outlook marks all items in the Outbox such that they do not get sent after a 'Send and Receive'

    I have spent 2 weeks investigating and tracing these events on the client and the server.

    There are no error messages from Outlook, nothing in server log files. I have established that Outlook makes no communications with the Zimbra Server upon these events [rather, non-events].

    Offending emails in the Outbox will be sent if the user moves them to the Drafts folder, opens them, clicks 'Send' and 'Sends and Receives' without opening the Outbox.

    I have established that this issue is resolved if I disable the 'Zimbra Sharing Addin' via File->Options->Addins in Outlook 2010.

    I tried this after finding a very useful site at:
    Outlook: After viewing Microsoft Outlook's Outbox, e-mail won't send

    I therefore suggest that ZCO 7.1.0.6314 'Zimbra Sharing Addin' has a 'bug' or, at least, that it is doing something which it 'shouldn't' or not doing something which it should and, I would dearly like to see this fixed so that I can re-enable the Addin and once again use its somewhat essential functionality such as, well, managing shared resources or adding/editing Personas properly and so that my business client no longer thinks that his Zimbra server is just an expensive toy.

    I have already raised this issue with Zimbra Support Portal but to my dismay they do not want to know because my Starter Edition licence does not grant such support.

    Please will someone from the Zimbra Team kindly look into this.

    I still am an avid Zimbra fan and I much prefer you to Microsoft Exchange!

    Thank you.

    18 MAY 2011
    If it helps someone from the Zimbra Team...
    I can add that the user does not experience this issue with Outlook 2007 and the latest ZCO 6 running on his notebook.
    I might also make a wild guess that its something to do with the 'Social Networking' functions of ZCO 7.1 'Sharing Addin' marking the Outbox items as read when Outbox is viewed?

    18 MAY 2011
    Have just found bugzilla.zimbra.com site and submitted there.
    Last edited by james654; 05-17-2011 at 06:25 PM.

  2. #2
    dave_kempe is offline Partner (VAR/HSP)
    Join Date
    Sep 2005
    Location
    Sydney, Australia
    Posts
    291
    Rep Power
    9

    Default

    You should be able to lodge a support case as well as the bugzilla entry btw.
    Frankly it sounds like a corner case, and I would train the user to not edit or mess with items in the outbox. Its not designed for that.
    Reminds me of people who insist on filing messages in the trash (that they want to keep for later!)
    http://www.solutionsfirst.com.au/hosting/zimbra/
    Australia's premier Zimbra Hosting Partner
    Resellers wanted!

  3. #3
    james654 is offline New Member
    Join Date
    May 2011
    Posts
    3
    Rep Power
    3

    Default

    Thanks for your comments dave_kempe.

    Yes, like you, my initial opinion was that it would be preferable if the user did not edit emails residing in his Outbox however, the user happens to be the MD who authorises my invoices and he does not want to change a practice which he has employed to good effect, for 15 years within Outlook, without previous issue. He's a highly regarded professional in his field and he finds this practice essential for vetting sensitive or critical information before hitting that 'Send' button. I have sympathy with him... I often wish that I was so disciplined as to make one final proof read before opening my mouth, as it were, and i'd like to just add the following...

    Having looked into the matter more deeply I really think that it's an issue which needs rectifying. Outlook, for example provides, and to the best of my recollection always has provided, the option to 'not immediately send emails' and subsequently does not bar a user from viewing the Outbox. Assuming that it is the ZCO in question [if it has any relevance at all ZCO 6 builds do not do this on Outlook 2007]... 3rd party software should not be marking items in the Outlook Outbox as 'read' just because the Outbox is browsed [ or marked as 'don't send' or whatever the offending flag change is... the exact detail is beyond my realm ] Other 3rd party vendors have revised their plugins with fixes which address this matter... iTunes for one. I believe it to be some matter which is overlooked when programming using MS .NET Framework? I also had another user who had this issue when simply and inadvertantly clicking on the Outbox folder while an email was in the process of being sent.

    Again thanks for responding, but, for the sake of having this treated with the attention which I feel it warrants, I beg to publicly disagree with you, this is not a corner case and most definitely is not akin to 'filing' messages in the Trash.

    Anyway, Zimbra have yet to confrim that it is a bug with the ZCO in question, I need their expert analysis and I await their considered response.

  4. #4
    james654 is offline New Member
    Join Date
    May 2011
    Posts
    3
    Rep Power
    3

    Default

    For anyone interested... looks like Zimbra have fixed this bug:
    Bug 60058 - Emails in Outbox not sent after browsing Outbox

    and I guess that the corresponding fixed build:
    ZimbraConnectorOLK_7.1.1.6324_x86.msi will be released in due course.

Thread Information

Users Browsing this Thread

There are currently 1 users browsing this thread. (0 members and 1 guests)

Similar Threads

  1. Replies: 7
    Last Post: 02-13-2013, 02:36 AM
  2. Outlook 2010 Sent Folder problem
    By dbkelly in forum Zimbra Connector for Outlook
    Replies: 3
    Last Post: 04-29-2011, 03:35 PM
  3. Outlook 2010 (32bit) not syncing
    By rayb2001 in forum Zimbra Connector for Outlook
    Replies: 0
    Last Post: 10-27-2010, 11:19 AM
  4. problem with outlook connector - attachments
    By galezer in forum Zimbra Connector for Outlook
    Replies: 1
    Last Post: 03-11-2008, 04:06 PM
  5. [SOLVED] Upgraded to 5.0 OSS - Sendmail Problem
    By Chewie71 in forum Installation
    Replies: 11
    Last Post: 12-28-2007, 07:07 PM

Posting Permissions

  • You may not post new threads
  • You may not post replies
  • You may not post attachments
  • You may not edit your posts
  •