First of all, I'm not really a windows and office 2007 user, but to test Zimbra I borrowed a Windows Machine with office 2007 and wanted to install ZCO 6.0.8 but it complains "ZCO requires Outlook 2007 SP2 or later. Please upgrade." so I installed office 2007 SP2, Outlook shows "(12.0.6416.1000) SP2 MSO" as version string after the upgrade but still, ZCO installier shows me the same error.
Any ideas what I'm doing wrong?

and While I'm already asking, will ZCO 6.0.8 only work with 2007 SP2 or will it also work with 2003 ?