Results 1 to 3 of 3

Thread: ZCO zdb numbering limitation?

  1. #1
    btsang is offline Active Member
    Join Date
    Jul 2007
    Posts
    33
    Rep Power
    8

    Default ZCO zdb numbering limitation?

    I am using ZCO 5.0.22 and used to open 6 other user's mailbox without any issue and/or error. Although for any closing and re-added a mailbox, it will select a higher number for the zdb (eg. Zimbra2.zdb, Zimbra3.zdb etc).

    However, this morning, when I try to add another user's mailbox, which has been assigned a 2 digit number (ie. Zimbra10.zdb). Since then, I've been keep on getting unknown sync error in Zimbra Send/Recive Progress screen, and nothing is being sync on it.

    I've tried to closing some other mailbox which used to work and add it back, of course it got a higher number (Zimbra11.zdb), and now this mailbox also got the same error. Have tried a few mailbox which ended up on the same situation and was the same.

    The one I didn't closed still works. Any once I closed all the one have issue, which all has number higher than 9, there is no more sync error. Once added it back (which got another higher number), error comes back.

    As for that user's mailbox, I've also added to my other workstation which works completely fine. However, this workstation only have single digit zdb number. Hence, seems like it's not the mailbox account issue.

    I've also tried to repair ZCO, and the result is the same. Thus, I am wondering if there is any limitation of the zdb numbering which causes issue? If so, how can I set it back to use a lower number? I tried to remove all the zdb file from Zimbra3.zdb and up, but when open the user's mailbox, it still keep on assigning higher number. Seems like it's caching the assigned number somewhere.

    Anyone has experience on this, and any advice?

    Thanks.

  2. #2
    fsiegel is offline Zimbra Employee
    Join Date
    Sep 2006
    Posts
    1,334
    Rep Power
    10

    Default

    I don't know of any limitation, and I just tried this, albeit with a test server with very little data. But I got up to user4(user8)12.zdb, with no issues. To get back to the lower number, you'd probably have to create a new primary profile.

    But I don't think this is your problem. If you have a sync problem, enable logging, do a short run, and send the log file.

  3. #3
    fsiegel is offline Zimbra Employee
    Join Date
    Sep 2006
    Posts
    1,334
    Rep Power
    10

    Default

    FWIW, the number is controlled by an internal MAPI property 0x6654, the delegate service count. You can't really get to it to change it.

Thread Information

Users Browsing this Thread

There are currently 1 users browsing this thread. (0 members and 1 guests)

Similar Threads

  1. [SOLVED] ZCO questions
    By tiger2000 in forum Zimbra Connector for Outlook
    Replies: 4
    Last Post: 11-27-2009, 02:36 AM
  2. ZCO against which Zimbra server: compatibility?
    By rm2008 in forum Zimbra Connector for Outlook
    Replies: 3
    Last Post: 06-15-2009, 08:27 AM
  3. ZCO adding new profile when upgrading
    By chh in forum Zimbra Connector for Outlook
    Replies: 2
    Last Post: 09-28-2007, 03:29 AM
  4. ZCO fails after upgrade to 4.5
    By awbecker in forum Zimbra Connector for Outlook
    Replies: 29
    Last Post: 04-21-2007, 12:57 AM
  5. Mixing and matching ZCO versions with ZCS versions?
    By vshah in forum Zimbra Connector for Outlook
    Replies: 3
    Last Post: 12-21-2006, 05:45 AM

Posting Permissions

  • You may not post new threads
  • You may not post replies
  • You may not post attachments
  • You may not edit your posts
  •