Results 1 to 10 of 10

Thread: Folders Sync Problem

  1. #1
    rilv is offline Intermediate Member
    Join Date
    Oct 2009
    Posts
    15
    Rep Power
    5

    Default Folders Sync Problem

    Hello,

    I am evaluating the latest version of ZCS Network 6.0.2 with Outlook Connector.

    When I create folders or subfolders in Outlook not always they are syncrhonized with Zimbra Server. I don't have any idea why it happens and can not catch any regular pattern of that behavour.

    Could you assist, please?

    Cheers,
    rilv

  2. #2
    fsiegel is offline Zimbra Employee
    Join Date
    Sep 2006
    Posts
    1,334
    Rep Power
    10

    Default

    Well this is a pretty general question. The best thing to do is to enable ZCO logging (just logging and http logging, nothing else), try to reproduce the problem, and send the log. To enable logging, use zcologctl.exe

  3. #3
    rilv is offline Intermediate Member
    Join Date
    Oct 2009
    Posts
    15
    Rep Power
    5

    Default

    Hi,

    Thank you for your reply. I tried to create a few folders in outlook named folder1, folder2, folder3, folder4, etc.,

    When I logged into Zimbra's web interface I saw only "folder1".

    The relevant logs are attached to this message.

    Thanks!
    rilv.
    Attached Files Attached Files

  4. #4
    fsiegel is offline Zimbra Employee
    Join Date
    Sep 2006
    Posts
    1,334
    Rep Power
    10

    Default

    From the log, I'm pretty sure I can tell what you're doing. You are trying to create 6 folders. You create folder1 under the inbox. Then you create folder2 under folder1 (folder1 is the parent), then folder3 under folder2, etc. until you get to folder6. Then you sync, but the only one we recognize is folder1.

    That is because we need to know the parent folder when you create a folder. So when you create folder1, the parent is Inbox. But when you create folder2, the parent is folder1, but you haven't synced that yet, so the parent if MAPI_E_NOT_FOUND, which will cause the server to give a mail.NO_SUCH_MSG error.

    So if you really want to do this, you should create folder1 under the inbox and sync (Send/Receive). Then create folder2 under folder1 and sync. Then folder3 under folder2, etc., syncing every time.

    Then you will get the results you expect.

  5. #5
    rilv is offline Intermediate Member
    Join Date
    Oct 2009
    Posts
    15
    Rep Power
    5

    Default

    Your are 100% right. You described exactly what I did. However, no error message popped up
    and I had no way to know that something was done in a "wrong way".
    Other mail systems (Exchange/IMAP based) don't have this problem. You can create as many
    folders as you want and they are syncrhonized right away.

    Don't you classify such behavour as a bug?

    Thank you very much for your assistance,
    rilv.
    Last edited by rilv; 11-06-2009 at 01:47 AM.

  6. #6
    fsiegel is offline Zimbra Employee
    Join Date
    Sep 2006
    Posts
    1,334
    Rep Power
    10

    Default

    Yeah, this seems like a bug. If you do this with the web client, you don't get any grief, so I guess you're right. At the very least, we should put out an error message, but it's true -- seems like a bug.

  7. #7
    rilv is offline Intermediate Member
    Join Date
    Oct 2009
    Posts
    15
    Rep Power
    5

    Default

    Thank you for the confirmation. How much time will it take to fix that bug?
    I really want to deploy the system in my company.

  8. #8
    fsiegel is offline Zimbra Employee
    Join Date
    Sep 2006
    Posts
    1,334
    Rep Power
    10

    Default

    I don't know -- I'll file it, but I'm not sure how critical it is. Is this really a showstopper? We've been around for a long time, and this is the first I've header heard of this.

    In the meantime, why not just sync every time? It seems like an edge case -- creating a bunch of hierarchical folders in one shot.

  9. #9
    fsiegel is offline Zimbra Employee
    Join Date
    Sep 2006
    Posts
    1,334
    Rep Power
    10

    Default

    Filed bug 42502. If it's not too hard to fix, we'll get it in 6.0.3.

  10. #10
    fsiegel is offline Zimbra Employee
    Join Date
    Sep 2006
    Posts
    1,334
    Rep Power
    10

    Default

    Bug 42502 fixed. The fix will be out in 5.0.21 and 6.0.4. Note that 6.0.4 is what 6.0.3 used to be, so it will be coming out when 6.0.3 was originally going to come out. 6.0.3 will be a quick patch release that will be out very soon.

Thread Information

Users Browsing this Thread

There are currently 1 users browsing this thread. (0 members and 1 guests)

Similar Threads

  1. IMAP Folders Dont Sync?
    By BigBirdy in forum Administrators
    Replies: 0
    Last Post: 09-22-2009, 07:08 PM
  2. Hangs on "Loading" screen
    By gbr in forum General Questions
    Replies: 16
    Last Post: 06-19-2008, 01:01 PM
  3. Problem to sync EXDATE in iCal with SOAP request
    By JackyQiu in forum Developers
    Replies: 1
    Last Post: 12-07-2006, 01:21 PM
  4. Z-Mobile & Motorola Q - sync issues
    By dwill in forum Zimbra Mobile
    Replies: 0
    Last Post: 11-17-2006, 09:34 AM
  5. Clock sync problem
    By dmarsden in forum Administrators
    Replies: 5
    Last Post: 04-06-2006, 02:00 PM

Posting Permissions

  • You may not post new threads
  • You may not post replies
  • You may not post attachments
  • You may not edit your posts
  •