We haven't upgraded and experienced the problem yet, but it appears that the 5.0.16 server's implementation of RFE 23215 - Eliminate blobs for appointments where possible causes potentially serious problems for any previously deployed ZCO versions < 5.0.16. See http://bugzilla.zimbra.com/show_bug.cgi?id=36534, http://bugzilla.zimbra.com/show_bug.cgi?id=35600

Is my concern warranted? Do we need to get all our Outlook users up to 5.0.16 on the desktop before upgrading the server?