Results 1 to 4 of 4

Thread: [SOLVED] Blackberry User name

  1. #1
    fang0654 is offline Intermediate Member
    Join Date
    May 2009
    Posts
    16
    Rep Power
    6

    Default [SOLVED] Blackberry User name

    I currently have Zimbra 5.0.16 NE installed, and have had a BES working with it almost flawlessly for the past 2 weeks. I found out yesterday that I had mispelled a users name (pretty badly), and even after fixing it in his account profile on the Zimbra Admin console, it is still showing up in the "From" fields for any emails he sends out from his Blackberry. I am trying to find a way to change the From field, which also corresponds with the "Name" field in BES. I decided to use myself as a guinea pig, and have been trying to change my name from "Daniel Lawson" (as I have originally set it up), to "Dan Lawson". I have changed all of the entries in the GAL, and zmprov gives this for my account:

    # name id
    email: <redacted to hide from bots>
    firstName: Daniel
    fullName: Dan Lawson
    lastName: Lawson
    objectClass: organizationalPerson
    objectClass: zimbraAccount
    objectClass: amavisAccount
    zimbraId: d01c9a6d-2901-42ec-a26d-7ae646d52e0e

    I went and deleted my BES account, left it for 20 minutes, wiped my blackberry, and then went to add myself again. In the GAL I was listed as "Dan Lawson". Before I activated the account the BES had me named "Dan Lawson". Once I activated, it went back to "Daniel Lawson".

    How do I change this name? Do I need to go as far as deleting the mailbox in Zimbra and recreating it?

    Any help would be very much appreciated.

  2. #2
    eugener is offline Zimbra Employee
    Join Date
    Dec 2008
    Posts
    187
    Rep Power
    6

    Default

    Please try to resynd GAL on BES machine:

    - remove affected user from BB manager
    - resync GAL. (type zcologctl.exe in command prompt and hit 'Force GAL Sync' button, also please give some time for sync to complete in case of big GAL. BB manager as well as BB controller have to be running at the time of the sync).
    - re-add the same user in BB manager

  3. #3
    fang0654 is offline Intermediate Member
    Join Date
    May 2009
    Posts
    16
    Rep Power
    6

    Default

    I just tried that, no change.


    When I find the user in the GAL, it is listed as Dan Lawson.

    In the BES, it is listed as Dan Lawson while initializing.

    While in the process of activation, it is listed as Dan Lawson, with "Running".

    Once activation is complete, it goes back to Daniel Lawson.

  4. #4
    fang0654 is offline Intermediate Member
    Join Date
    May 2009
    Posts
    16
    Rep Power
    6

    Talking Figured it out!

    After lots of testing and troubleshooting (and about a dozen blackberry wipes), I figured out the solution. For anyone who runs into this down the road, here is what you do:

    Delete user from BES.

    Make changes to Users name (First and/or Last) in Zimbra Admin Console.

    Change the e-mail address to a different domain (or a different address in the same domain). Do not add the user's original email address as an alias. DURING THIS PART THE MAILBOX WILL REJECT ANY MAIL COMING TO IT.

    Log onto BES machine, open up Outlook, Go to Tools, then go to Address Book.

    Delete user from Global Address List. Close Outlook

    Go to Start -> Run and type in zcologctl and press enter.

    Click on Force GAL Resync

    Wait a couple of minutes, click Ok, and reboot server.

    When it comes back up, go through the usual steps of provisioning a new user with the new E-mail address. If you don't see the user right away in the GAL, wait a couple of minutes, and it'll populate back.

    On the phone side of things, just wipe it and when you are ready, reactivate it.

    After phone is activated, then go back into Zimbra Admin console and return address back to original settings.

    BES will still have old e-mail address listed, but anything coming to and from BlackBerry will be using correct address.

    Hope this saves someone else lots of hair pulling.
    Last edited by fang0654; 06-28-2009 at 07:58 PM. Reason: Was actually more difficult than I originally posted.

Thread Information

Users Browsing this Thread

There are currently 1 users browsing this thread. (0 members and 1 guests)

Similar Threads

  1. Replies: 21
    Last Post: 02-04-2010, 10:06 AM
  2. [SOLVED] Zimbra logwatch.
    By nishith in forum Administrators
    Replies: 5
    Last Post: 06-10-2009, 04:42 PM
  3. [SOLVED] Outlook no longer updating
    By jeremy.pratt in forum Zimbra Connector for BlackBerry
    Replies: 10
    Last Post: 05-30-2008, 03:22 PM
  4. Post instsallation problems
    By Assaf in forum Installation
    Replies: 14
    Last Post: 01-29-2007, 11:38 AM
  5. Services stopped working
    By lilwong in forum Administrators
    Replies: 4
    Last Post: 08-15-2006, 09:19 AM

Posting Permissions

  • You may not post new threads
  • You may not post replies
  • You may not post attachments
  • You may not edit your posts
  •