I filed a support case (00033467) on this and wait for a call but thougt I'd pose the problem here to see if someone has had similar probs;

It's a long chain of events:

1. We run BES as a local account on the win server to prevent policy pushes (specifically with Outlook/Exchange) from mucking the config
2. The password on the server aged out and we had to change the password to keep the local security minions happy.
3. This seemed to break with the Mail profiles for BES. The BES kept working but starting the BB Manager brought up the mail profile config wizard.
4. I was going to remake the BBServer and BBManager mail profiles on the BES today to start to correct the problem apparently caused by the password change but rebooted the box first to attempt to have it correct itself.
5. Upon reboot none of the BES services started because they each needed the new password since they run local.
6. I changed each of the passwords on the services and they started fine but the BES would not pass email to/from the server.
7. I remade the BBServer and BBmanager profiles and restarted the box but mail would not flow
8. I stopped the services and checked the profiles with outlook, they seemed fine as I could get the GAL from outlook
9. I restarted the services but mail still will not flow.

I've seen some event log entries sayin users on the BES not starting and one that makes me suspect a registry problem.

Below is the registry event:

The description for Event ID ( 50091 ) in Source ( BlackBerry Controller ) cannot be found. The local computer may not have the necessary registry information or message DLL files to display messages from a remote computer. You may be able to use the /AUXSOURCE= flag to retrieve this description; see Help and Support for details. The following information is part of the event: Stopping BlackBerry Agent Controller.


Anybody had a similar experience.