Page 1 of 2 12 LastLast
Results 1 to 10 of 11

Thread: Guide

  1. #1
    didster is offline Active Member
    Join Date
    May 2007
    Posts
    31
    Rep Power
    8

    Default Guide

    Hi,

    Is there an absoulte total pratts guide to getting the blackberry connector working? I have read the release notes many times, and am still having problems with a few things.

    For one, the release notes say "Note: Before continuing, make sure that you have completed setting up MAPI/CDO, BES, and Outlook". I don't understand how I am suppose to do that giving I am installing BES for exchange and I don't have exchange. I have installed CDO, and that worked. I installed BES and that seemd to work, altough the final dialog relating to exchange settings I just pressed OK on.

    I have also installed Outlook 2007. I can only get 2007 here, not 2003. Again, I don't know what I am suppose to be "setting up" because when starting outlook, its asking for exchange server details.

    When trying to install the ZCO connector I get "can't replace MAPI32.dll". I have stopped the blackberry controller service, but it still does the same. In fact, I have killed everything running on the machine and it's still saying the same thing.

    If anyone has any pointers, that would be great.

    Thanks a lot.

  2. #2
    alee is offline Former Zimbran
    Join Date
    Apr 2007
    Location
    San Jose
    Posts
    406
    Rep Power
    8

    Default

    Quote Originally Posted by didster View Post
    Hi,

    Is there an absoulte total pratts guide to getting the blackberry connector working? I have read the release notes many times, and am still having problems with a few things.

    For one, the release notes say "Note: Before continuing, make sure that you have completed setting up MAPI/CDO, BES, and Outlook". I don't understand how I am suppose to do that giving I am installing BES for exchange and I don't have exchange. I have installed CDO, and that worked. I installed BES and that seemd to work, altough the final dialog relating to exchange settings I just pressed OK on.

    I have also installed Outlook 2007. I can only get 2007 here, not 2003. Again, I don't know what I am suppose to be "setting up" because when starting outlook, its asking for exchange server details.

    When trying to install the ZCO connector I get "can't replace MAPI32.dll". I have stopped the blackberry controller service, but it still does the same. In fact, I have killed everything running on the machine and it's still saying the same thing.

    If anyone has any pointers, that would be great.

    Thanks a lot.
    Once you set up MAPI/CDO, BES and then Outlook. You need to install ZCB and not start Outlook. we have a bug regarding the mapi32.dll error (Bug 21924 - BB: Installer fails with no error msg if mapi32.dll is in use). if you get there is error, this means that there is another MAPI aware application running. This could be a desktop search application or it could be the profile creation app (rundll32.exe). It might not be obvious which application you might need to shut down. I believe if you download process explorer from Windows Sysinternals: Documentation, downloads and additional resources, then you can figure out who is using which DLL.

    After ZCB is installed, then you need to recreate the BlackBerryManager and BlackBerryServer profiles to point to the admin account on the ZCS that you want to connect to. At this point, you can open up Outlook against these servers if you like. Remember that OLK 2007 isn't officially supported as of yet to work with ZCB.

    The current ZCB documentation is supposed to be the "complete" guide to setting up ZCB. If you throughly read this document and are having problems (like the mapi32.dll issue), feel free to file bugs against the documentation so we can update it to be clearer for future ZCB admins.

    Please let me know if you have any more issues and I'll try to help

    Thanks
    --Tony

  3. #3
    didster is offline Active Member
    Join Date
    May 2007
    Posts
    31
    Rep Power
    8

    Default

    Hi,

    Many thanks for the reply.

    Still no joy though. Using process explorer shows there is nothing that has mapi32.dll loaded. Although there is a olmapi32.dll. See attached.

    I still get the mapi32.dll error though [after I have closed process explorer of course]

    Attached is also a capture of everything thats running on the machine [which is Windows 2003 server by the way]

    There is also a full installer log attached

    Thanks
    Attached Images Attached Images
    Attached Files Attached Files

  4. #4
    alee is offline Former Zimbran
    Join Date
    Apr 2007
    Location
    San Jose
    Posts
    406
    Rep Power
    8

    Default

    Quote Originally Posted by didster View Post
    Hi,

    Many thanks for the reply.

    Still no joy though. Using process explorer shows there is nothing that has mapi32.dll loaded. Although there is a olmapi32.dll. See attached.

    I still get the mapi32.dll error though [after I have closed process explorer of course]

    Attached is also a capture of everything thats running on the machine [which is Windows 2003 server by the way]

    There is also a full installer log attached

    Thanks
    the dll that you are finding in process explorer is actually not the DLL that we are interested in.
    can you verify that mapi32.dll is in the location: C:\Program Files\Common Files\SYSTEM\MSMAPI\1033\mapi32.dll and C:\WINDOWS\system32\mapi32.dll? it needs to be in the first directory and it should be in the second directory if you have successfully installed the CDO/MAPI libraries.
    have you tried to reboot the system to see if this file becomes "unlocked"?
    i wonder if this is the first hiccup with OLK 2007.

  5. #5
    didster is offline Active Member
    Join Date
    May 2007
    Posts
    31
    Rep Power
    8

    Default

    Hi,

    Thanks again for the help.

    I have checked them two DLLs and I DONT have both. I have a map32.dll in C:\windows\system, but I have a MSmapi32.dll in C:\program files\common files\system\msmapi\1033 - no mapi32.dll

    For refrence, there is no MSMAPI32.dll in C:\windows\system32.

    The install log seems to complain it can't overwrite the one in system32.

    I have rebooted many times

    Thanks
    Attached Images Attached Images

  6. #6
    alee is offline Former Zimbran
    Join Date
    Apr 2007
    Location
    San Jose
    Posts
    406
    Rep Power
    8

    Default

    Quote Originally Posted by didster View Post
    Hi,

    Thanks again for the help.

    I have checked them two DLLs and I DONT have both. I have a map32.dll in C:\windows\system, but I have a MSmapi32.dll in C:\program files\common files\system\msmapi\1033 - no mapi32.dll

    For refrence, there is no MSMAPI32.dll in C:\windows\system32.

    The install log seems to complain it can't overwrite the one in system32.

    I have rebooted many times

    Thanks
    so the mapi32.dll in the \windows\system32 directory is good.
    no mapi32.dll in the 1033 directory is bad. i'm 100% confident that this is an Olk 2k7 issue since Olk 2k3 installs will put the correct DLL there.
    can you search your system for mapi32.dll and only mapi32.dll files on your system.

  7. #7
    didster is offline Active Member
    Join Date
    May 2007
    Posts
    31
    Rep Power
    8

    Default

    Quote Originally Posted by alee View Post
    so the mapi32.dll in the \windows\system32 directory is good.
    no mapi32.dll in the 1033 directory is bad. i'm 100% confident that this is an Olk 2k7 issue since Olk 2k3 installs will put the correct DLL there.
    can you search your system for mapi32.dll and only mapi32.dll files on your system.
    I only have one mapi32.dll in C:\windows\system32

    For refrence, I have a msmapi32.dll in C:\program files\common files\system and an olmapi32.dll in C:\program files\microosft office\office12

    I guess I'm stuffed then

  8. #8
    alee is offline Former Zimbran
    Join Date
    Apr 2007
    Location
    San Jose
    Posts
    406
    Rep Power
    8

    Default

    Quote Originally Posted by didster View Post
    I only have one mapi32.dll in C:\windows\system32

    For refrence, I have a msmapi32.dll in C:\program files\common files\system and an olmapi32.dll in C:\program files\microosft office\office12

    I guess I'm stuffed then
    what is the size and the version number of the dll?
    our ZCB installer has been customized for OL2k3 but its possible that we could get something to work for you and OL2k7

  9. #9
    didster is offline Active Member
    Join Date
    May 2007
    Posts
    31
    Rep Power
    8

    Default

    Quote Originally Posted by alee View Post
    what is the size and the version number of the dll?
    our ZCB installer has been customized for OL2k3 but its possible that we could get something to work for you and OL2k7
    The size is 115,200 bytes [on disk size is 118,784 bytes].

    The version is 1.0.2536.0

    The description is "Extended MAPI 1.0 for Windows NT"

    What confuses me is the nature of the original error I am getting though - can't replace this DLL. Looking in the log it shows it's trying to overwrite the DLL in C:\windows\system32 but can't - it's not even looking in the C:\program files\common files\... directory [i.e. the one where the DLL is missing].

    Getting something going with 2007 would be great. We just can't get 2003 here any more. Everyone just says "buy 2007, and install 2003 from an CD you already have using the 2007 licence key and it will work". But it doesn't. We only have outlook 2003 as part of office 2003, which won't accept a standalone office 2007 product key . I'm sure if someone came and looked we would be fine if we just installed the outlook component of office 2003 and brought a standalone office 2007 license, but the evils of product activation mean this isn't possible.

    Many thanks

  10. #10
    alee is offline Former Zimbran
    Join Date
    Apr 2007
    Location
    San Jose
    Posts
    406
    Rep Power
    8

    Default

    Quote Originally Posted by didster View Post
    The size is 115,200 bytes [on disk size is 118,784 bytes].

    The version is 1.0.2536.0

    The description is "Extended MAPI 1.0 for Windows NT"

    What confuses me is the nature of the original error I am getting though - can't replace this DLL. Looking in the log it shows it's trying to overwrite the DLL in C:\windows\system32 but can't - it's not even looking in the C:\program files\common files\... directory [i.e. the one where the DLL is missing].

    Getting something going with 2007 would be great. We just can't get 2003 here any more. Everyone just says "buy 2007, and install 2003 from an CD you already have using the 2007 licence key and it will work". But it doesn't. We only have outlook 2003 as part of office 2003, which won't accept a standalone office 2007 product key . I'm sure if someone came and looked we would be fine if we just installed the outlook component of office 2003 and brought a standalone office 2007 license, but the evils of product activation mean this isn't possible.

    Many thanks
    ironically, the version of mapi32.dll that is in \windows\system32 is actually the one that we are trying to copy over there. it looks like OLK2k3 puts it in the ..\..\1033 folder but OLK2k7 already has it in \windows\system32
    what strikes me as odd is that the installation of MAPI/CDO didn't write over that file. so it seems you are running into a OLK2k7 specifc installation issue.

    the best thing that we can do at this point is for me to get you to run the ZCO installer (as opposed to ZCB) and add some manual steps required to get it working with BES (registry keys and such).

    let me talk to a couple of people and get back to you via email.
    please PM with your email address

    thanks
    --Tony

Page 1 of 2 12 LastLast

Thread Information

Users Browsing this Thread

There are currently 1 users browsing this thread. (0 members and 1 guests)

Similar Threads

  1. Zimbra pt_BR User Guide
    By hlribeiro in forum I18N/L10N - Translations
    Replies: 7
    Last Post: 03-29-2012, 12:13 PM
  2. [SOLVED] User Guide for Zimbra
    By russgalleywood in forum Users
    Replies: 34
    Last Post: 09-09-2008, 12:49 PM
  3. ZCS Connector for BlackBerry Guide
    By jbareMACS in forum Zimbra Connector for BlackBerry
    Replies: 6
    Last Post: 01-10-2008, 03:07 PM
  4. FC4 working - suggest update quick start guide
    By interoperate in forum Installation
    Replies: 9
    Last Post: 10-27-2005, 03:31 PM

Posting Permissions

  • You may not post new threads
  • You may not post replies
  • You may not post attachments
  • You may not edit your posts
  •