Results 1 to 4 of 4

Thread: zmmailbox -> post failed, over 10485760 byte limit

  1. #1
    pete irvine is offline Active Member
    Join Date
    May 2011
    Location
    Wellington
    Posts
    47
    Rep Power
    4

    Smile zmmailbox -> post failed, over 10485760 byte limit - NOW SOLVED see posts

    Anyway to get this limit lifted to a reasonable number like 5GB. Have 4 mailboxes to import over 2GB.
    Will look into it myself and post solution when I find it
    Last edited by pete irvine; 05-26-2011 at 07:04 PM. Reason: Solved

  2. #2
    pete irvine is offline Active Member
    Join Date
    May 2011
    Location
    Wellington
    Posts
    47
    Rep Power
    4

    Default

    Tried the "curl" import.
    What a pain.
    Curl is not in the path on appliance 6.0.13.406 so had to use :
    sudo find / -name curl -print|more to locate it
    rephrased command line with full path to curl...
    sudo /path/curl -k -u admin:PASSWORD --data-binary @/path/to/USER-account.tgz "https://MAILSTORE-FQDN:7071/service/home/USER@DOMAIN/?fmt=tgz&resolve=skip"
    and got the response
    curl option --data-binary out of memory.
    Now shutting down domain controller and firewall VM's so can allocate all the memory on the box to the mail server for the duration of the import....
    Maybe an import facility that worked would be a valuable addition to zimbra - perhaps a documented one would be even better.
    Will advise results.

  3. #3
    pete irvine is offline Active Member
    Join Date
    May 2011
    Location
    Wellington
    Posts
    47
    Rep Power
    4

    Red face curl fails again - form too large

    Is there a way to import the tgz files that does not send it via the webserver - perhaps a perl script that sends it straight to the database ???
    The import failed again after consuming 6.8GB of RAM for a 1.9GB file !
    Yet again hitting a limit on the webserver get error :
    form too large 1984502028&gt 200000
    Going back to searching for the answer will post results
    Last edited by pete irvine; 05-25-2011 at 03:40 PM. Reason: More Info

  4. #4
    pete irvine is offline Active Member
    Join Date
    May 2011
    Location
    Wellington
    Posts
    47
    Rep Power
    4

    Smile SOLVED IT - 1.9 and 5.6 GB tgz imported !

    I allocated 12GB of RAM and 3 vCPU's and used :
    zmmailbox to import.
    Also updated php.ini -> not sure if it was nessesary but was part of what I did :
    Settings changed :
    memory_limit=64M (Defaults to 8M)
    post_max_size=8196M (Default is 2M ?)
    upload_max_file_size=8196M (Default is 2M ?)

    If I do this again I'll try without PHP.INI changes above - can someone test this perhaps ?

    NOTE: In the appliance zmmailbox is not in the path {/opt/zimbra/bin/zmmailbox}
    The full line is :
    sudo /opt/zimbra/bin/zmmailbox -z -m user@domain pru "//?fmt=tgz&resolve=skip" {path to tgz file}.

    NOTE: Appliance does not have room in /tmp for large files so I created a directory /opt/zimbra/tmp, chown vmware:vmware and chmod 777 then used ftp to move the file into this dir.

    I hope this helps someone...........
    Last edited by pete irvine; 05-26-2011 at 07:03 PM. Reason: More Info

Thread Information

Users Browsing this Thread

There are currently 1 users browsing this thread. (0 members and 1 guests)

Similar Threads

  1. Replies: 7
    Last Post: 02-13-2013, 02:36 AM
  2. Install Zimbra 6.0.8 x64 on Debian Lenny Fail
    By Titi974 in forum Installation
    Replies: 6
    Last Post: 10-21-2010, 05:47 AM
  3. Problem with Mail Server - Need help!
    By joeleo in forum Installation
    Replies: 2
    Last Post: 03-04-2008, 12:03 PM
  4. My Zimbra server down ... please help :)
    By frankb in forum Administrators
    Replies: 2
    Last Post: 12-12-2007, 11:29 AM
  5. Upgrade: 4.5.5 -> 4.5.6 failed, LDAP/slapd issues
    By Daimyo in forum Installation
    Replies: 7
    Last Post: 08-04-2007, 09:23 PM

Posting Permissions

  • You may not post new threads
  • You may not post replies
  • You may not post attachments
  • You may not edit your posts
  •