Results 1 to 4 of 4

Thread: Filtering issues

  1. #1
    Skip_Reed's Avatar
    Skip_Reed is offline Junior Member
    Join Date
    Mar 2007
    Location
    Cleveland OH USA
    Posts
    7
    Rep Power
    8

    Default Filtering issues

    Slightly Frustrated with filtering as it exists.

    Issue A: I find no support for IF (X or Y or Z) and A It can be worked around by selective use of the "Do Not Process" checkbox but it's hard to explain to "Normal Users"

    Issue B: Trying to filter all mail from Yahoo.com, Gmail.com & Juno.com as well as 4 or 5 other email addresses into 1 folder. Set up as "Any Condition" I tried "Contains" and "Matches Pattern" They work if I separate the conditions out (e.g. - IF Matches Pattern @gmail.com) but not if I combine them all into 1 filter. Is this just "The Way It Is" or is there something I should be looking at and if so what??

    Just to make sure I'm saying this right:

    Filter ID Personal
    Any Condition
    Matches Pattern or CONTAINS @yahoo.com
    MP or C @gmail.com
    MP or C @juno.com
    M Exact somebody@sbcgobal.net
    M Exact somebodyelse@netscape.net

    File into Folder Personal

    Does NOT work but if I separate them the Match Exact works in one case but not in another. Myaddress@yahoo.com does NOT filter but MyBrother@netscape.net DID. "Pattern" and "Contains" does not yet work either. I presume that is my mis-understanding but ..... Not being all that familiar with Zimbra I'm not sure how to set headers to full but I hope somebody has some hints or can give me the URL to the manual page I missed or .....

    Thanks
    bcr

  2. #2
    jholder's Avatar
    jholder is offline Former Zimbran
    Join Date
    Oct 2005
    Location
    Thatcher, AZ
    Posts
    5,606
    Rep Power
    20

    Default

    Do you have the "Do not process additional rules" Checked?

    If not, the please file a bug in a our bugzilla so that we can take a look at it.

    Welcome to the Zimbra Forums!!!
    We hope you enjoy!

    -john

  3. #3
    Skip_Reed's Avatar
    Skip_Reed is offline Junior Member
    Join Date
    Mar 2007
    Location
    Cleveland OH USA
    Posts
    7
    Rep Power
    8

    Default

    That's part of the frustration. I have tried it with and without the Don't Look checkbox. Currently the Match exactly that does work is the last check in a group check as defined in the first post. The 2 that MEx do not work are solo checks. All 3 of them *have* the "Do Not Process" box checked.

    Another filter I have which works correctly is a set of 4 "From Contains" Exact@address.ext which *has* the Do NOT Process box checked. However I have another rule which is set up identically and IS working that does NOT have the DNP box check. Hence my confusion.

    I was under the impression that that box was for the current rule which would allow (as I mentioned above) passing a rule result on to the next rule check. I'm an old and loyal Pegasus user if that tells you what I like in the way of how the rules should work ;-) I "assumed" that once a message had been moved to another folder, no further processing was POSSIBLE. I had been using it to "Leave message in Inbox" without explicitly saying that. You are telling me that is an incorrect inference?

    I presume you need further information to file a bug. If you could tell me how to extract what you need I'll be happy to forward it.

    Thanks

  4. #4
    Skip_Reed's Avatar
    Skip_Reed is offline Junior Member
    Join Date
    Mar 2007
    Location
    Cleveland OH USA
    Posts
    7
    Rep Power
    8

    Default

    Per suggestion bug filled:
    http://bugzilla.zimbra.com/show_bug.cgi?id=15723

    Thanks again

Thread Information

Users Browsing this Thread

There are currently 1 users browsing this thread. (0 members and 1 guests)

Similar Threads

  1. Couple of Issues with Web Client
    By soxfan in forum Users
    Replies: 9
    Last Post: 09-13-2008, 01:58 PM
  2. Exchange 2003 Migration Issues
    By JordanPWilliams in forum Migration
    Replies: 10
    Last Post: 07-27-2007, 10:51 AM
  3. Disabling Spam Filtering
    By plan9 in forum Administrators
    Replies: 1
    Last Post: 10-25-2006, 07:10 PM
  4. Zimbra 3.2 issues
    By kowell in forum Developers
    Replies: 1
    Last Post: 07-05-2006, 06:51 PM

Posting Permissions

  • You may not post new threads
  • You may not post replies
  • You may not post attachments
  • You may not edit your posts
  •