Results 1 to 6 of 6

Thread: Briefcase error 404

  1. #1
    gomer23 is offline Member
    Join Date
    Jan 2013
    Posts
    12
    Rep Power
    2

    Default Briefcase error 404

    Last week after we updated from Zimbra version 7.2.1 to 7.2.2 running on Ubuntu 10.04, we noticed that our Briefcase shares were no longer working. When I try to go to a public briefcase share, inside of our network I get the error: HTTP Error 404: no such item. The briefcase shares DO however work in the HTML web client. We are getting this 404 error in the Ajax client in firefox, chrome and IE8-9.

    Here are the 2 URLs I see from Ajax and HTML:
    Ajax: https:// zimbra.mydomain.com/service/user/sharedfolderaccount@mydomain.com/Shared%20Folder/subfolder/file.jpg?ver=1
    HTML: https:// zimbra.mydomain.com/home/myuser@mydomain.com/sharedfolder/subfolder/file.jpg?auth=co

    Now in those 2 URLs I am logged in as myself, Eric, trying to access a share on that larue account.

    I cloned this machine and tried to upgrade it to 8.0.2 and still the same error occured. Then I setup a new server with Ubuntu 12.04 and installed a clean 8.0.2 and setup 2 test users and we also got the 404 error.

    What are a few things I can look at to resolve this issue.

    Update:

    I started a fresh Ubuntu 10.04 box and installed Zimbra 7.1.0 and the briefcase worked fine. I updated to 7.2.0 and the briefcase still worked. I then updated 7.2.1 and the briefcase shares still worked. But going up to 7.2.2 broke the briefcase shares.

    Thank You.
    Last edited by gomer23; 01-08-2013 at 02:12 PM.

  2. #2
    crmanski is offline New Member
    Join Date
    Jun 2008
    Location
    Connecticut, USA
    Posts
    3
    Rep Power
    7

    Default

    I upgraded to 7.2.2 yesterday on my 10.04 box and now shared briefcases are randomly giving me this error as well. If I switch from Advanced client to HTML the briefcase works. Not good.

  3. #3
    gomer23 is offline Member
    Join Date
    Jan 2013
    Posts
    12
    Rep Power
    2

    Default

    Quote Originally Posted by crmanski View Post
    I upgraded to 7.2.2 yesterday on my 10.04 box and now shared briefcases are randomly giving me this error as well. If I switch from Advanced client to HTML the briefcase works. Not good.
    I actually found a "fix" for this on Monday after spending the better part of my day creating VMware boxes and installing updates to Zimbra.

    What I found was if the briefcase share is under another folder, like briefcase then the share doesn't work. I had to share folders on the root of the briefcase folder structure. This was consistent with 7.2.2 and 8.0.2. Now subfolders in these shares worked fine. So if I create a sure on the list of folders in the briefcase (not a subfolder) the share works and and folders I place under it I can browser to and files work fine.

    IF you have existing shares that broke with the upgrade to 7.2.2 you can move the share to the root list and they will start working, no need to reshare them to anyone again. So we had a share called Marketing that was a subfolder of the default Briefcase folder. I clicked and dragged it up to the "folder" heading so Marketing was not a subfolder of Briefcase any more and the share continued to work like it did before the 7.2.2 upgrade.

  4. #4
    crmanski is offline New Member
    Join Date
    Jun 2008
    Location
    Connecticut, USA
    Posts
    3
    Rep Power
    7

    Default

    Quote Originally Posted by gomer23 View Post
    I actually found a "fix" for this on Monday after spending the better part of my day creating VMware boxes and installing updates to Zimbra.

    What I found was if the briefcase share is under another folder, like briefcase then the share doesn't work. I had to share folders on the root of the briefcase folder structure. This was consistent with 7.2.2 and 8.0.2. Now subfolders in these shares worked fine. So if I create a sure on the list of folders in the briefcase (not a subfolder) the share works and and folders I place under it I can browser to and files work fine.

    IF you have existing shares that broke with the upgrade to 7.2.2 you can move the share to the root list and they will start working, no need to reshare them to anyone again. So we had a share called Marketing that was a subfolder of the default Briefcase folder. I clicked and dragged it up to the "folder" heading so Marketing was not a subfolder of Briefcase any more and the share continued to work like it did before the 7.2.2 upgrade.
    Thanks! That worked perfectly.

  5. #5
    federico.bertola's Avatar
    federico.bertola is online now Special Member
    Join Date
    Jul 2006
    Location
    Verona, Italy
    Posts
    153
    Rep Power
    8

    Default

    Is there an open bug report about this issue?
    Federico Bertola
    CTO @ StudioStorti

  6. #6
    le_gache's Avatar
    le_gache is offline Member
    Join Date
    Jun 2010
    Location
    France - Brittany - Auray
    Posts
    10
    Rep Power
    5

    Default

    Yes, there is an open bug : https://bugzilla.zimbra.com/show_bug.cgi?id=79145 with a "fix" which doesn't work for me...
    The more you fail... The more you succeed...
    -----------------------------------------------------------------------------
    ZCS 8.0.3 OSE CentOS 6.4 64 bits on Hyper-V
    Z-Push 2.0.7 - Zimbra Backend 55 CentOS 6.4 64 bits on Hyper-V

Thread Information

Users Browsing this Thread

There are currently 1 users browsing this thread. (0 members and 1 guests)

Similar Threads

  1. Zimbra Briefcase i18n filenames error
    By adamhatak in forum Administrators
    Replies: 12
    Last Post: 02-09-2012, 01:09 AM
  2. Zdesktop 7beta1 Briefcase error
    By drdre in forum Error Reports
    Replies: 0
    Last Post: 02-25-2011, 08:45 AM
  3. Error uploading to Briefcase
    By pybe in forum Error Reports
    Replies: 3
    Last Post: 05-04-2010, 05:08 AM
  4. ERror while sharing Task list and Briefcase
    By drdre in forum General Questions
    Replies: 5
    Last Post: 03-27-2009, 01:39 PM
  5. Briefcase sharing gives HTTP ERROR: 501
    By hjmangalam in forum Administrators
    Replies: 3
    Last Post: 03-14-2008, 02:08 PM

Posting Permissions

  • You may not post new threads
  • You may not post replies
  • You may not post attachments
  • You may not edit your posts
  •