Results 1 to 3 of 3

Thread: Autocomplete from address book is only based on text before @ symbol?

  1. #1
    batfastad is offline Elite Member
    Join Date
    Aug 2007
    Location
    London, UK
    Posts
    295
    Rep Power
    7

    Default Autocomplete from address book is only based on text before @ symbol?

    Hi everyone

    We've been using the Zimbra AJAX UI in anger for the past few weeks and despite running into a few things that already have bugs filed, there's one thing I've been finding a bit irritating.

    It might just be me, but when typing into the To/CC/BCC boxes, it seems like the auto-complete list is only based on the text that comes before the @ symbol.
    So if I start typing a domain name: oursuppliersdomain.com then I get no matches

    Is that correct?
    Are there any plans to change that behaviour?
    That behaviour is not what I was expecting from these particular auto-complete boxes and I expect other users would find that too.

    Also the auto-complete seems to include contacts that have been moved to trash. Is that correct?
    Even when I've removed those contacts from the trash, they still appear in the auto-complete list

    Any comments/suggestions/existing bug reports?

    Cheers, B

  2. #2
    soxfan is offline Moderator
    Join Date
    Mar 2006
    Location
    Massachusetts
    Posts
    965
    Rep Power
    10

    Default

    There have definitely been some auto-complete changes / issues with the 6.0.x releases.

    It might just be me, but when typing into the To/CC/BCC boxes, it seems like the auto-complete list is only based on the text that comes before the @ symbol.
    So if I start typing a domain name: oursuppliersdomain.com then I get no matches

    Is that correct?
    Are there any plans to change that behaviour?
    That behaviour is not what I was expecting from these particular auto-complete boxes and I expect other users would find that too.
    I've actually never tried auto-completing off of the domain name, but just tested and at least with 6.0.6.1 it appears you are correct; it doesn't look to anything past the "@" symbol. Not sure if this is the desired behavior or not. You should check bugzilla and file a bug/RFE if you don't find anything.

    Also the auto-complete seems to include contacts that have been moved to trash. Is that correct?
    Even when I've removed those contacts from the trash, they still appear in the auto-complete list
    Can't find the exact bug but I believe there were some issues with deleted contacts still showing up in the auto-complete results. I think it was fixed in 6.0.6, but this release had a bunch of auto-complete issues of its own. So, if you are going to upgrade go to 6.0.6.1 or wait until 6.0.7 is released is another week or so (5/31 hopefully).

  3. #3
    batfastad is offline Elite Member
    Join Date
    Aug 2007
    Location
    London, UK
    Posts
    295
    Rep Power
    7

    Default

    Ok fair enough, just wanted to check that our installation wasn't messed up.
    I had to do a disaster recovery after our upgrade to 6.0.6 failed thanks to a bug when upgrading a server using LDAPS, and there were a few strange issues going on for a few days after that disaster recovery.

    I'll probably upgrade to 6.0.7 when it lands.

    EDIT: nothing in Bugzilla that describes what I'm seeing so I'll wait for 6.0.7 to see what's been fixed before reporting any new bugs

    Cheers, B
    Last edited by batfastad; 05-26-2010 at 07:50 AM.
    My Zimbra Bugs Wishlist: 16411, 24567, 35676, 36430, 37770, 41872, 43733, 44384, 46383, 47759
    And a way to associate mailto: handlers with a Zimbra Prism webapp

Thread Information

Users Browsing this Thread

There are currently 1 users browsing this thread. (0 members and 1 guests)

Similar Threads

  1. address book sync broken
    By drdrem in forum Error Reports
    Replies: 4
    Last Post: 03-04-2009, 06:55 AM
  2. Address Book Text Highlighting
    By j1m in forum Administrators
    Replies: 8
    Last Post: 04-16-2008, 02:46 AM
  3. Replies: 6
    Last Post: 09-26-2007, 12:38 PM
  4. [SOLVED] Zimbra not syncing properly with Address Book and iCal
    By Colin Day in forum CalDAV / CardDAV / iSync
    Replies: 4
    Last Post: 07-13-2007, 08:52 AM

Posting Permissions

  • You may not post new threads
  • You may not post replies
  • You may not post attachments
  • You may not edit your posts
  •