Results 1 to 6 of 6

Thread: [SOLVED] Segment Fault!!!

  1. #1
    marisu is offline Loyal Member
    Join Date
    Aug 2008
    Posts
    87
    Rep Power
    6

    Angry [SOLVED] Segment Fault!!!

    Environment: zimbra602 OSS.
    Muti-server, three servers,one master ldap,two replica ldap servers.
    OS:linux redhas as5.3.

    My mail server down one after another . All three servers log file seems as follows:

    Apr 21 08:05:03 mail1 kernel: zmlocalconfig[17083]: segfault at ffffffffff57800c rip 0000000000445145 rsp 00007fff98cac9f0 error 4
    Apr 21 08:05:03 mail1 kernel: sh[17084]: segfault at ffffffffff57800c rip 0000000000445145 rsp 00007ffff73880d0 error 4
    Apr 21 08:05:03 mail1 kernel: zmprov[17085]: segfault at ffffffffff57800c rip 0000000000445145 rsp 00007fffa1070dc0 error 4
    Apr 21 08:05:03 mail1 kernel: zmprov[17086]: segfault at ffffffffff57800c rip 0000000000445145 rsp 00007fffb49a9700 error 4

    SOME HELP?
    Ask Forever...

  2. #2
    uxbod's Avatar
    uxbod is offline Moderator
    Join Date
    Nov 2006
    Location
    UK
    Posts
    8,017
    Rep Power
    24

    Default

    Any errors in the Zimbra log files ?

  3. #3
    marisu is offline Loyal Member
    Join Date
    Aug 2008
    Posts
    87
    Rep Power
    6

    Default Nothing useful Information in my zimbra log!

    Nothing useful in my zimbra log. I send/receive mail successfully. But cannot ssh from remote. My log file increasing fast(/var/log/message). Before this,my ldap database(slapadd) crushed, because i interupt the slapadd command by "Ctrl + C". But i recovered it successfully. Does this caused segfault? confused !
    Ask Forever...

  4. #4
    uxbod's Avatar
    uxbod is offline Moderator
    Join Date
    Nov 2006
    Location
    UK
    Posts
    8,017
    Rep Power
    24

    Default

    Uh what were you running a slapadd for ? I guess that could well have caused LDAP to panic.

  5. #5
    marisu is offline Loyal Member
    Join Date
    Aug 2008
    Posts
    87
    Rep Power
    6

    Default Add accounts by slapadd.

    I used the command "slapadd" to add lots of accounts(more than 500,000) into ldap databases(in order to cost less time , i quit to use zmprov ), when system processing , i found that i forget to shutdown the ldap process, so i interrupt the command by "Ctrl + C", and then "ldap stop", but the system alert slapadd database crushed. I tried my best to restore this. At last , i found lots of segfault in /var/log/message file . I want to ensure that all the segfault info was caused by my operate to slapadd ? And how could i modify this ? Thanks a lot for youre reply!
    Ask Forever...

  6. #6
    marisu is offline Loyal Member
    Join Date
    Aug 2008
    Posts
    87
    Rep Power
    6

    Default finally reason

    The redhat as5.3 has not matched with the server!
    Ask Forever...

Thread Information

Users Browsing this Thread

There are currently 1 users browsing this thread. (0 members and 1 guests)

Similar Threads

  1. Replies: 1
    Last Post: 06-20-2010, 03:31 AM
  2. Soap fault
    By Nutz in forum Zimbra Connector for Outlook
    Replies: 3
    Last Post: 03-24-2008, 02:02 AM
  3. [SOLVED] Attached wav file causes SOAP Fault
    By dstoliker in forum Administrators
    Replies: 5
    Last Post: 12-04-2007, 09:08 AM
  4. Replies: 3
    Last Post: 08-22-2007, 11:08 PM

Posting Permissions

  • You may not post new threads
  • You may not post replies
  • You may not post attachments
  • You may not edit your posts
  •