Okay, the earlier suggestion of opting for "automatically download pictures in HTML email" was right on. The problem was that that option was not available in the preferences section when in the "standard" version of Zimbra. When I entered the "advanced" version and went to preferences, there it was. In fact, checking that box solved the issue whether in the advanced or standard. So, this annoyance is no more. Thanks for all the help!