Hi guys!

I have an account(interop@mydomain.com) configured to forward messages to another account(teste1@mydomain.com)

If someone sends a message from mydomain.com to interop@mydomain.com the message is forwarded to teste1@mydomain.com, as expected. However, if someone tries to send an e-mail from another domain the forwarding just doesn't happen.

Take a look:

######## from testemail@mydomain.com to interop@mydomain.com



/opt/zimbra/log/mailbox.log
Code:
2009-11-19 16:49:11,921 INFO  [btpool0-742://email.mydomain.com/service/soap/NoOpRequest] [name=ouvidoria@mydomain.com;mid=1554;ip=10.2.10.135;ua=ZimbraWebClient - IE6 (Win)/6.0.2_GA_1912.RHEL5_64;] soap - NoOpRequest
2009-11-19 16:49:11,940 INFO  [btpool0-742://email.mydomain.com/service/soap/NoOpRequest] [name=rvt@mydomain.com;mid=1793;ip=10.31.10.85;ua=ZimbraWebClient - FF3.0 (Win)/6.0.2_GA_1912.RHEL5_64;] soap - NoOpRequest

2009-11-19 16:49:12,702 INFO  [btpool0-742://email.mydomain.com/service/soap/SendMsgRequest] [name=testemail@mydomain.com;aname=interop@mydomain.com;mid=1526;ip=10.2.3.157;ua=ZimbraWebClient - IE7 (Win)/6.0.2_GA_1912.RHEL5_64;] soap - SendMsgRequest
2009-11-19 16:49:12,702 INFO  [btpool0-742://email.mydomain.com/service/soap/SendMsgRequest] [name=testemail@mydomain.com;aname=interop@mydomain.com;mid=1526;ip=10.2.3.157;ua=ZimbraWebClient - IE7 (Win)/6.0.2_GA_1912.RHEL5_64;] misc - delegated access: doc=SendMsg, delegating account=interop@mydomain.com, authenticated account=testemail@mydomain.com, target account=testemail@mydomain.com
2009-11-19 16:49:12,817 INFO  [btpool0-742://email.mydomain.com/service/soap/SendMsgRequest] [name=testemail@mydomain.com;aname=interop@mydomain.com;mid=1526;ip=10.2.3.157;ua=ZimbraWebClient - IE7 (Win)/6.0.2_GA_1912.RHEL5_64;] mailop - Adding Message: id=484, Message-ID=<1993843506.2577.1258656552704.JavaMail.root@email.mydomain.com>, parentId=-1, folderId=5, folderName=Sent.
2009-11-19 16:49:12,829 INFO  [btpool0-742://email.mydomain.com/service/soap/SendMsgRequest] [name=testemail@mydomain.com;aname=interop@mydomain.com;mid=1526;ip=10.2.3.157;ua=ZimbraWebClient - IE7 (Win)/6.0.2_GA_1912.RHEL5_64;] smtp - Sending message to MTA at email.mydomain.com, port 25: Message-ID=<1993843506.2577.1258656552704.JavaMail.root@email.mydomain.com>, replyType=r
2009-11-19 16:49:12,870 INFO  [btpool0-742://email.mydomain.com/service/soap/SendMsgRequest] [name=testemail@mydomain.com;aname=interop@mydomain.com;mid=1526;ip=10.2.3.157;ua=ZimbraWebClient - IE7 (Win)/6.0.2_GA_1912.RHEL5_64;] mailbox - Deferred Indexing: submitted 1 items in 10ms (100.00/sec). (0 items failed to index).  IndexDeferredCount now at 1 NumNotSubmitted= 0
2009-11-19 16:49:12,904 INFO  [LmtpServer-2321] [ip=10.2.3.100;] lmtp - Delivering message: size=1108 bytes, nrcpts=2, sender=testemail@mydomain.com, msgid=<1993843506.2577.1258656552704.JavaMail.root@email.mydomain.com>
2009-11-19 16:49:12,904 INFO  [LmtpServer-2321] [ip=10.2.3.100;] lmtp - accepted and discarded message for interop@mydomain.com: local delivery is disabled
2009-11-19 16:49:12,904 INFO  [LmtpServer-2321] [name=teste1@mydomain.com;mid=2387;ip=10.2.3.100;] mailop - Adding Message: id=5465, Message-ID=<1993843506.2577.1258656552704.JavaMail.root@email.mydomain.com>, parentId=-1, folderId=2, folderName=Inbox.
2009-11-19 16:49:12,931 INFO  [LmtpServer-2321] [] ProtocolHandler - Handler exiting normally

2009-11-19 16:49:13,320 INFO  [btpool0-742://email.mydomain.com/service/soap/NoOpRequest] [name=lff@mydomain.com;mid=1233;ip=10.2.250.81;ua=ZimbraWebClient - SAF3 (Win)/6.0.2_GA_1912.RHEL5_64;] soap - NoOpRequest
2009-11-19 16:49:13,377 INFO  [btpool0-742://email.mydomain.com/service/soap/NoOpRequest] [name=awn@mydomain.com;mid=280;ip=10.2.19.82;ua=ZimbraWebClient - FF3.0 (Win)/6.0.2_GA_1912.RHEL5_64;] soap - NoOpRequest
2009-11-19 16:49:13,642 INFO  [btpool0-736://localhost/service/soap/AuthRequest] [name=avq@mydomain.com;oip=10.25.10.239;ua=zclient/6.0.2_GA_1912.RHEL5_64;] index - Initialized Index for mailbox 524 directory: LuceneIndex at com.zimbra.cs.index.Z23FSDirectory@/opt/zimbra/index/0/524/index/0 Analyzer=com.zimbra.cs.index.ZimbraAnalyzer@ffce2f2
2009-11-19 16:49:13,642 INFO  [btpool0-736://localhost/service/soap/AuthRequest] [name=avq@mydomain.com;oip=10.25.10.239;ua=zclient/6.0.2_GA_1912.RHEL5_64;] cache - initializing folder and tag caches for mailbox 524
2009-11-19 16:49:13,666 INFO  [btpool0-736://localhost/service/soap/AuthRequest] [name=avq@mydomain.com;oip=10.25.10.239;ua=zclient/6.0.2_GA_1912.RHEL5_64;] mbxmgr - Mailbox 524 account c302bfd4-0c8d-4b92-8f4d-d1264960e611 LOADED




/var/log/zimbra.log
Code:
Nov 19 16:49:12 email postfix/smtpd[22556]: connect from email.mydomain.com[10.2.3.100]
Nov 19 16:49:12 email postfix/smtpd[22556]: CF3687B44540: client=email.mydomain.com[10.2.3.100]
Nov 19 16:49:12 email postfix/cleanup[22742]: CF3687B44540: message-id=<1993843506.2577.1258656552704.JavaMail.root@email.mydomain.com>
Nov 19 16:49:12 email postfix/qmgr[32497]: CF3687B44540: from=<testemail@mydomain.com>, size=1108, nrcpt=2 (queue active)
Nov 19 16:49:12 email postfix/smtpd[22556]: disconnect from email.mydomain.com[10.2.3.100]
Nov 19 16:49:12 email postfix/lmtp[6909]: CF3687B44540: to=<interop@mydomain.com>, relay=email.mydomain.com[10.2.3.100]:7025, delay=0.08, delays=0.01/0/0/0.07, dsn=2.1.5, status=sent (250 2.1.5 Delivery OK)
Nov 19 16:49:12 email postfix/lmtp[6909]: CF3687B44540: to=<teste1@mydomain.com>, orig_to=<interop@mydomain.com>, relay=email.mydomain.com[10.2.3.100]:7025, delay=0.08, delays=0.01/0/0/0.07, dsn=2.1.5, status=sent (250 2.1.5 Delivery OK)
Nov 19 16:49:12 email postfix/qmgr[32497]: CF3687B44540: removed
greping the by ID

Code:
[root@email ~]# grep CF3687B44540:  /var/log/zimbra.log
Nov 19 16:49:12 email postfix/smtpd[22556]: CF3687B44540: client=email.mydomain.com[10.2.3.100]
Nov 19 16:49:12 email postfix/cleanup[22742]: CF3687B44540: message-id=<1993843506.2577.1258656552704.JavaMail.root@email.mydomain.com>
Nov 19 16:49:12 email postfix/qmgr[32497]: CF3687B44540: from=<testemail@mydomain.com>, size=1108, nrcpt=2 (queue active)
Nov 19 16:49:12 email postfix/lmtp[6909]: CF3687B44540: to=<interop@mydomain.com>, relay=email.mydomain.com[10.2.3.100]:7025, delay=0.08, delays=0.01/0/0/0.07, dsn=2.1.5, status=sent (250 2.1.5 Delivery OK)
Nov 19 16:49:12 email postfix/lmtp[6909]: CF3687B44540: to=<teste1@mydomain.com>, orig_to=<interop@mydomain.com>, relay=email.mydomain.com[10.2.3.100]:7025, delay=0.08, delays=0.01/0/0/0.07, dsn=2.1.5, status=sent (250 2.1.5 Delivery OK)
Nov 19 16:49:12 email postfix/qmgr[32497]: CF3687B44540: removed
[root@email ~]#





Now see what happen(actually, doesn't happen) when I send an e-mail from gmail, for instance, to the same account:


######## from nospamplease@gmail.com to interop@mydomain.com


/opt/zimbra/log/mailbox.log
Code:
2009-11-19 17:13:28,363 INFO  [btpool0-752://email.mydomain.com/service/soap/NoOpRequest] [name=roj@mydomain.com;mid=2488;ip=10.37.10.229;ua=ZimbraWebClient - IE7 (Win)/6.0.2_GA_1912.RHEL5_64;] soap - NoOpRequest
2009-11-19 17:13:28,486 INFO  [LmtpServer-2379] [ip=192.168.1.201;] lmtp - Delivering message: size=1944 bytes, nrcpts=1, sender=nospamplease@gmail.com, msgid=
2009-11-19 17:13:28,486 INFO  [LmtpServer-2379] [ip=192.168.1.201;] lmtp - accepted and discarded message for interop@mydomain.com: local delivery is disabled
2009-11-19 17:13:28,486 INFO  [LmtpServer-2379] [] ProtocolHandler - Handler exiting normally
2009-11-19 17:13:28,880 INFO  [LmtpServer-2380] [ip=192.168.1.201;] index - Initialized Index for mailbox 450 directory: LuceneIndex at com.zimbra.cs.index.Z23FSDirectory@/opt/zimbra/index/0/450/index/0 Analyzer=com.zimbra.cs.index.ZimbraAnalyzer@ffce2f2
2009-11-19 17:13:28,880 INFO  [LmtpServer-2380] [ip=192.168.1.201;] cache - initializing folder and tag caches for mailbox 450

2009-11-19 17:13:29,025 INFO  [LmtpServer-2380] [ip=192.168.1.201;] mbxmgr - Mailbox 450 account 4828488b-7a10-4c02-b655-3e324bf28011 LOADED
2009-11-19 17:13:29,027 INFO  [LmtpServer-2380] [ip=192.168.1.201;] lmtp - Delivering message: size=2858 bytes, nrcpts=1, sender=contato@movieexpress.com.br, msgid=<a794b164dd01e484f4a38d127a27c32e@www.movieexpress.com.br>
2009-11-19 17:13:29,028 INFO  [LmtpServer-2380] [name=iiz@mydomain.com;mid=450;ip=192.168.1.201;] mailop - Adding Message: id=7660, Message-ID=<a794b164dd01e484f4a38d127a27c32e@www.movieexpress.com.br>, parentId=-1, folderId=2, folderName=Inbox.
2009-11-19 17:13:29,082 INFO  [LmtpServer-2380] [] ProtocolHandler - Handler exiting normally
2009-11-19 17:13:29,156 INFO  [LmtpServer-2381] [ip=192.168.1.201;] lmtp - Delivering message: size=3331 bytes, nrcpts=1, sender=caars@7lan.net, msgid=<a0e2f2459d333c57e9e6b6aba8b27929@mkt.7lan.net>
2009-11-19 17:13:29,157 INFO  [LmtpServer-2381] [name=ezd@mydomain.com;mid=1803;ip=192.168.1.201;] mailop - Adding Message: id=23127, Message-ID=<a0e2f2459d333c57e9e6b6aba8b27929@mkt.7lan.net>, parentId=-1, folderId=2, folderName=Inbox.
2009-11-19 17:13:29,167 INFO  [LmtpServer-2381] [] ProtocolHandler - Handler exiting normally



/var/log/zimbra.log
it's empty by this time


I know I checked "do not keep local copy" or something, but anyway it's not forwarding to teste1.


any ideas??


thank you

rgds