Results 1 to 3 of 3

Thread: Using Special Characters in Zimbra Mail Filters

  1. #1
    sena@kei.com is offline Starter Member
    Join Date
    Mar 2009
    Posts
    2
    Rep Power
    6

    Default Using Special Characters in Zimbra Mail Filters

    Current Zimbra setup is Zimbra NE 5.0.18 running on Ubuntu 6.06 LTS. When I try to setup two different mail filters, I run into some bugs:

    1. Trying to wildcard filter anything with [Info] in the subject line. When I set up the mail filter to Subject Matches Wildcard Condition [Info]*, the filter doesn't work. E-mail's with [Info] in the subject don't get acted upon. Are special characters allowed to be filtered in this way (specifically '[' or ']')?

    2. When I try to setup a spam mail filter using the given example of \*\*\**\*\*\* as a Subject Matches Wildcard Condition, I can't save the filter since Zimbra errors out with the message that '\' is not a valid character.

  2. #2
    phoenix is offline Zimbra Consultant & Moderator
    Join Date
    Sep 2005
    Location
    Vannes, France
    Posts
    23,485
    Rep Power
    56

    Default

    Quote Originally Posted by sena@kei.com View Post
    1. Trying to wildcard filter anything with [Info] in the subject line. When I set up the mail filter to Subject Matches Wildcard Condition [Info]*, the filter doesn't work. E-mail's with [Info] in the subject don't get acted upon. Are special characters allowed to be filtered in this way (specifically '[' or ']')?
    You would create a filter for 'Contains [Info]' and not a wildcard.

    Quote Originally Posted by sena@kei.com View Post
    2. When I try to setup a spam mail filter using the given example of \*\*\**\*\*\* as a Subject Matches Wildcard Condition, I can't save the filter since Zimbra errors out with the message that '\' is not a valid character.
    You do not (and should not) filter spam with these filters, the correct place for improving the anti-spam would be in as/av system itself.
    Regards


    Bill


    Acompli: A new adventure for Co-Founder KevinH.

  3. #3
    ewilen's Avatar
    ewilen is offline Moderator
    Join Date
    Jun 2008
    Location
    Berkeley, CA
    Posts
    1,474
    Rep Power
    9

    Default

    The backslash is fixed in 6.0.

    Bug 35908 – double quote and backslash not supported in filter values

    Whether to use filters for spam strikes me as a philosophical question. End users are dependent on admins to modify the AS system, so IMO filters are an okay tool for them to use if they're smart about it.

Thread Information

Users Browsing this Thread

There are currently 1 users browsing this thread. (0 members and 1 guests)

Similar Threads

  1. Replies: 7
    Last Post: 02-03-2011, 07:01 AM
  2. postfix relay=none status=bounced for local mails
    By vdd in forum Administrators
    Replies: 1
    Last Post: 08-06-2009, 08:05 AM
  3. Replies: 2
    Last Post: 02-12-2008, 11:55 AM
  4. [SOLVED] Upgraded to 5.0 OSS - Sendmail Problem
    By Chewie71 in forum Installation
    Replies: 11
    Last Post: 12-28-2007, 07:07 PM
  5. Mail logs
    By Rick Baker in forum Installation
    Replies: 8
    Last Post: 01-17-2006, 04:33 PM

Posting Permissions

  • You may not post new threads
  • You may not post replies
  • You may not post attachments
  • You may not edit your posts
  •