Results 1 to 9 of 9

Thread: Help verifying possible bug

  1. #1
    cjstone is offline Intermediate Member
    Join Date
    Jul 2006
    Posts
    23
    Rep Power
    8

    Default Help verifying possible bug

    I've found something odd going on on our own server that I can recreate on the Zimbra demo server (Live demos of Zimbra's open source email and group calendar software).

    The issue is described exactly in this bug, which was fixed in 4.5.4:

    Bug 17048 – Calendar Notifications shows Incorrect day for recurring appointments

    However, I'm still seeing it on our 5.06 as well as on Zimbra's demo server, so think maybe it's been re-introduced somehow.

    I've sent this into support, but they've still not verified it. I've recreated it from two different machines (Mac & Windows FF).

    I've done exactly this to recreate:

    1. Open the calendar
    2. Double-click on a Monday (say, 9/8) to create a new appointment
    3. Fill with a subject (say, test1) and click More Details
    4. In the detailed set up window, change the date to a Friday, (e.g. 9/12)
    5. Set the appointment to repeat every week
    6. Add yourself as an attendee and save.
    7. Examine the invitation email, and you should see something like:

    Recurrence : Every Monday. No end date. Effective Sep 12, 2008.

    Note that it reads every "Monday", while the actual appontments are on Friday.

    Am I the only one who sees this?

    Thanks,

    --Chris

  2. #2
    p24t is offline Moderator
    Join Date
    Mar 2007
    Location
    Austin
    Posts
    441
    Rep Power
    8

    Default

    Able to repro on 5.0.6.

    From the outgoing appointment email:

    Time: 10:00:00 AM - 11:00:00 AM GMT -06:00 US/Canada Central
    Recurrence : Every Monday. No end date. Effective Sep 5, 2008.
    ( 05 Sep 2008 is a Friday )

  3. #3
    cjstone is offline Intermediate Member
    Join Date
    Jul 2006
    Posts
    23
    Rep Power
    8

    Default

    Quote Originally Posted by p24t View Post
    Able to repro on 5.0.6.

    From the outgoing appointment email:



    ( 05 Sep 2008 is a Friday )

    Great, thanks! I pointed Zimbra support to this thread, so hopefully it'll get into the bug db again and get fixed soon. It's causing a bit of confusion for our users here.

    --Chris

  4. #4
    kenh248 is offline Intermediate Member
    Join Date
    May 2007
    Location
    Tacoma, WA
    Posts
    18
    Rep Power
    7

    Default

    This bug still shows up in 5.0.11. Our receptionist just picked up on it by doing the following:

    Create a new appointment for any day, check it as "All day event" and to repeat every year. Save it and it shows up on the correct day on the calendar. Open up the series and see that next to the Repeat: button will show appointment recurring on *today's* date instead of the appointment date. Change/add any part of the appointment and save, and the subsequent appointments in the series get moved to *today's* date (e.g. every Jan 14th).

    Ken

  5. #5
    cjstone is offline Intermediate Member
    Join Date
    Jul 2006
    Posts
    23
    Rep Power
    8

    Default

    Looks like this will be fixed in 5.0.12: Roadmap

  6. #6
    kenh248 is offline Intermediate Member
    Join Date
    May 2007
    Location
    Tacoma, WA
    Posts
    18
    Rep Power
    7

    Default

    Sweet. Thanks for the update. Any Zimbra folks here have any hints as to when we can expect 5.0.12?

  7. #7
    tgx's Avatar
    tgx
    tgx is offline Elite Member
    Join Date
    Mar 2006
    Posts
    300
    Rep Power
    9

    Default

    I don't care when it's done, but it needs to be the best that it can be since it is the last in the 5.X series.

  8. #8
    kenh248 is offline Intermediate Member
    Join Date
    May 2007
    Location
    Tacoma, WA
    Posts
    18
    Rep Power
    7

    Default

    I just wanted to add that the bug I listed can be worked-around by editing the event series and fixing the date in the Custom Repeat dialog. Seems to set everything proper in the series.

  9. #9
    Jbrabander's Avatar
    Jbrabander is offline Elite Member
    Join Date
    May 2008
    Location
    Park City, KS
    Posts
    342
    Rep Power
    6

    Default

    Quote Originally Posted by tgx View Post
    I don't care when it's done, but it needs to be the best that it can be since it is the last in the 5.X series.
    Actually, product portal shows a listing for a .13 revision too.

Thread Information

Users Browsing this Thread

There are currently 1 users browsing this thread. (0 members and 1 guests)

Similar Threads

  1. 5.0.6 is out!
    By mmorse in forum Announcements
    Replies: 0
    Last Post: 05-23-2008, 01:16 PM
  2. 5.0.4 is live!
    By mmorse in forum Announcements
    Replies: 0
    Last Post: 03-24-2008, 03:27 PM
  3. 5.0.3/.4 is out!!!
    By mmorse in forum Announcements
    Replies: 0
    Last Post: 03-20-2008, 04:20 PM
  4. serious IMAP download bug (6326)
    By ericding in forum Developers
    Replies: 5
    Last Post: 04-05-2006, 10:34 AM
  5. i18n, bug 5912 and other considerations
    By Kafka in forum I18N/L10N - Translations
    Replies: 9
    Last Post: 02-22-2006, 04:50 PM

Posting Permissions

  • You may not post new threads
  • You may not post replies
  • You may not post attachments
  • You may not edit your posts
  •