Results 1 to 8 of 8

Thread: @ sign not working in Mac OS 10.5

  1. #1
    iway is offline Partner (VAR/HSP)
    Join Date
    May 2008
    Posts
    432
    Rep Power
    6

    Default @ sign not working in Mac OS 10.5

    Hello!

    The @ sign does not work with Mac OS/X 10.5 and Safari in the webmail client (in Zimbra Desktop as well...).

    We use ZCS 5.0.5 on SuSE.

    Any ideas? Does anybody else have this problem?

    Thanks

    Chris

  2. #2
    mmorse's Avatar
    mmorse is offline Moderator
    Join Date
    May 2006
    Location
    USA
    Posts
    6,242
    Rep Power
    20

    Default

    As your email ends in .de I gather that's the German keyboard thing/conflict with @ symbol and marking low priority.

    You can modify the respective /opt/zimbra/mailboxd/webapps/zimbra/WEB-INF/classes/keys ZmKeys_de.properties & ZhKeys_de.properties files to contain:
    compose.LowPriority = Alt+L
    compose.LowPriority.mac = Ctrl+L

    Then: zmmailboxdctl restart & clear your browser cache.

    Bug 28221 - shurtcut "Alt+L" coflicts with "@" char on german mac keyboard

  3. #3
    mmorse's Avatar
    mmorse is offline Moderator
    Join Date
    May 2006
    Location
    USA
    Posts
    6,242
    Rep Power
    20

    Default

    You don't have to pick Ctl+L just find a free combo.

    Should be only a mac issue with never being able to type @ in the address fields etc - to define a shortcut that applies only on a particular platform (Windows, Macintosh, or Linux), add a platform identifier to the action: win mac linux action.sub.platform = key

  4. #4
    iway is offline Partner (VAR/HSP)
    Join Date
    May 2008
    Posts
    432
    Rep Power
    6

    Default

    Thanks!

    That fixed it...

    Could you make that a permanent solution by implementing it in the next releases?

    Chris

  5. #5
    iway is offline Partner (VAR/HSP)
    Join Date
    May 2008
    Posts
    432
    Rep Power
    6

    Default

    Problem: This workaround (changing the keyboard shortcut settings) seems not to work in the Desktop app.

    Any ideas?

  6. #6
    iway is offline Partner (VAR/HSP)
    Join Date
    May 2008
    Posts
    432
    Rep Power
    6

    Angry

    This workaround worked prior to 5.0.9. Since upgrading it does not work any more.

    All Safari users are unable to use the @ sign, making Webmail nearly useless!

  7. #7
    mmorse's Avatar
    mmorse is offline Moderator
    Join Date
    May 2006
    Location
    USA
    Posts
    6,242
    Rep Power
    20

    Default

    Probably due to Bug 28843 - Improve shortcut localizability
    compose.LowPriority.display = Alt+L
    compose.LowPriority.keycode = Alt+76
    The .mac trick should still work - need to configure both .display.mac & .keycode.mac
    Last edited by mmorse; 09-05-2008 at 02:48 PM.

  8. #8
    iway is offline Partner (VAR/HSP)
    Join Date
    May 2008
    Posts
    432
    Rep Power
    6

    Default

    Yeah, the keycode.mac thing fixed it.

    Can you make this permanent, please?

Thread Information

Users Browsing this Thread

There are currently 1 users browsing this thread. (0 members and 1 guests)

Similar Threads

  1. WebDAV mounts in Mac OS X create garbage files
    By dpmchris in forum Administrators
    Replies: 3
    Last Post: 05-08-2008, 06:16 AM
  2. Installing Zimbra on Mac OS 10.5
    By tkramis in forum Installation
    Replies: 0
    Last Post: 04-29-2008, 11:34 AM
  3. Installed on Mac OS X client, host file question
    By McBurtnieks in forum Installation
    Replies: 1
    Last Post: 04-01-2007, 11:09 AM
  4. Mac OS X + Zimbra + Apache 2
    By abetam in forum Installation
    Replies: 1
    Last Post: 10-06-2006, 10:16 PM
  5. Uninstall in Mac OS X?
    By avi4now in forum Installation
    Replies: 10
    Last Post: 01-09-2006, 12:14 PM

Posting Permissions

  • You may not post new threads
  • You may not post replies
  • You may not post attachments
  • You may not edit your posts
  •