The title pretty much says it all. I had the Zimbra DnD Firefox add-on working at one point. However, I've been using FF 3 for a while now and the add-on was showing as not compatible. I never bothered to try editing the xpi or anything like that. But I just saw this post and figured I'd give it a try again. Unfortunately I can't seem to get it working. I've tried it on my main workstation, which is running Linux (Fedora 9). I also tried it on a laptop running FF3 under Windows XP and on a Windows 2000 system still running FF2. I tried undeploying and re-deploying the zimlet on the server. I'm not sure what else to try. What am I missing?

TIA,
John