Page 1 of 2 12 LastLast
Results 1 to 10 of 11

Thread: Anyone know when "Select Addresses" will be woring correctly?

  1. #1
    Mike Scholes is offline Advanced Member
    Join Date
    Dec 2007
    Posts
    238
    Rep Power
    7

    Default Anyone know when "Select Addresses" will be woring correctly?

    Let me start by saying Zimbra 5.0 GA is an outstanding product. I am however trying to move 40+ Outlook users in the company I work for as IT administrator to Zimbra and it's the little niggles that put people off even though the product as a whole is superior.

    When a user wants to send a mail and they click the "To" button the select addresses dialogue box appears. There isn't a consistent way to show all the contacts from the various parts of Zimbra. By default the GAL is displayed, if you have moved away from the GAL and want to re-populate the list you can put "@" in the search box and it works. Now if I move to "Contacts" I am unable to show the entire list. If I switch to "Personal and Shared Contacts" I can type a "*" in the search box and it works but a "@" gets nothing. So I have to tell my users that if you want to show all your contacts do not select "Contacts" but "Personal and Shared Contacts" and use "*" but if you then want to add members from the GAL then select "Global Address List" and choose "@" for the search. It's all a bit messy and will frustrate my users.

    Surely just selecting either "Contacts", "Personal and Shared Contacts" or "Global Address List" should automatically populate the list without having to enter any kind of search. Having to enter a new search for each and every recipient when you just want to add recipients from your personal contacts is very time consuming and will keep the Outlook lovers happy. Please tell me a fix is coming so I can have the last laugh

  2. #2
    pshah is offline Zimbra Employee
    Join Date
    Sep 2005
    Location
    Sunnyvale, CA
    Posts
    269
    Rep Power
    9

    Default

    The search results are pre-populated but with whatever is the default search type (the GAL).

    If you switch to "Contacts", close the contact picker and then re-open it, you should see your personal contact are now pre-populated in the search results pane.

    I think what would make you or your users happy is if the default search type is set to "Contacts" and not GAL, right?

    I dont think there is an existing RFE filed for this so you should create one in bugzilla.
    Bugzilla - Wiki - Downloads - Before posting... Search!

  3. #3
    Mike Scholes is offline Advanced Member
    Join Date
    Dec 2007
    Posts
    238
    Rep Power
    7

    Default

    Thanks for that, I know that closing and reopening the dialogue box does populate the list correctly but this will frustrate the hell out of the Outlook users I am trying to convert. I can't give them any excuse to argue against Zimbra in favour of Outlook. If the user has to pick recipients from the GAL and Contacts is is very difficult.

    The fact that is does not show all the private contacts when asked either by selecting Contacts from the drop down box or searching for any type of wild card is a bug, isn't it? I wouldn't describe showing all the contacts as a "feature". Do you know if this is acknowledged as a problem and if it is going to be fixed.

    Thanks.

  4. #4
    pshah is offline Zimbra Employee
    Join Date
    Sep 2005
    Location
    Sunnyvale, CA
    Posts
    269
    Rep Power
    9

    Default

    AFAIK, there is no plan on "fixing" it the way you described. Seems like there are two things you want:

    1. Set the default search type to be Contacts even if GAL is enabled.
    2. Pre-populate the contacts when user switches search type (not just on initial popup of contact-picker dialog)

    You should file a new RFE to get this on our radar. I'm sure there are others who feel the same way you do.

    Thanks.
    Bugzilla - Wiki - Downloads - Before posting... Search!

  5. #5
    kbigger is offline Active Member
    Join Date
    May 2007
    Location
    Maryland, USA
    Posts
    49
    Rep Power
    8

    Default

    I'd like to know if there is a config setting to select whether the search is prepopulated or not. We have about 9000 users in our external directory and the prepopulated search times out presumably due to the large number of hits that the initial search returns.

  6. #6
    marginalboy is offline Member
    Join Date
    Jan 2008
    Location
    Texas
    Posts
    12
    Rep Power
    7

    Default

    We DEFINITELY would vote for this RFE. If there's one made as a result of this thread, could someone post the number?

    We're seeing lots of folks send email to the first 200 people in our (very large) GAL instead of sending them to all their Contacts. Really not-user-friendly behavior, and in an educational environment, potentially catastrophic privacy consequences exist...

  7. #7
    phoenix is offline Zimbra Consultant & Moderator
    Join Date
    Sep 2005
    Location
    Vannes, France
    Posts
    23,490
    Rep Power
    56

    Default

    Quote Originally Posted by marginalboy View Post
    We DEFINITELY would vote for this RFE. If there's one made as a result of this thread, could someone post the number?
    Search bugzilla and feel free to file an RFE is there isn't one.
    Regards


    Bill


    Acompli: A new adventure for Co-Founder KevinH.

  8. #8
    Mike Scholes is offline Advanced Member
    Join Date
    Dec 2007
    Posts
    238
    Rep Power
    7

    Default

    Surely this is basic functionality, it shouldn't need a feature request. You can get the whole GAL with a dot and shared and personal... with a dot, how much extra work would be required just to search contacts with a dot? It's minimal.

  9. #9
    jholder's Avatar
    jholder is offline Former Zimbran
    Join Date
    Oct 2005
    Location
    Thatcher, AZ
    Posts
    5,606
    Rep Power
    20

    Default

    The Zimbra engineers cannot commit anything without a bug. Get a enhancement filed, and it will be targeted.

    It may be minimal, but when you place that into the context of the other bugs and enhancement requests with votes, it seems that this request isn't that popular.

    I'm wrong, and I know that. Show your voice. Submit the enhancement, and vote.

  10. #10
    marginalboy is offline Member
    Join Date
    Jan 2008
    Location
    Texas
    Posts
    12
    Rep Power
    7

    Default

    I found Bug 7701 in Bugzilla, which sounds very similar to this request. I added a comment and a vote

    Thanks, everyone!

Page 1 of 2 12 LastLast

Thread Information

Users Browsing this Thread

There are currently 1 users browsing this thread. (0 members and 1 guests)

Posting Permissions

  • You may not post new threads
  • You may not post replies
  • You may not post attachments
  • You may not edit your posts
  •