Results 1 to 7 of 7

Thread: Support for CE caractersets in import&export in addressbook

  1. #1
    wildstyle is offline Junior Member
    Join Date
    Dec 2005
    Location
    Ljubljana, Slovenia
    Posts
    8
    Rep Power
    9

    Talking Support for CE caractersets in import&export in addressbook

    Hi,

    I guess my last bug/wish . The spacial characters that our language use (Latin-2), get mixed, when importing / exporting from addressbok. The display of them for instance works great (you use utf-8 on zimbra pages ).

    Thanx for all your help, Zimbra guys, I think you made the best product on the market...

    D.

  2. #2
    KevinH's Avatar
    KevinH is offline Expert Member
    Join Date
    Aug 2005
    Location
    San Mateo, CA
    Posts
    4,789
    Rep Power
    18

    Default

    Can you give a couple examples of what is displayed vs what gets exported.
    Looking for new beta users -> Co-Founder of Acompli. Previously worked at Zimbra (and Yahoo! & VMware) since 2005.

  3. #3
    wildstyle is offline Junior Member
    Join Date
    Dec 2005
    Location
    Ljubljana, Slovenia
    Posts
    8
    Rep Power
    9

    Talking

    Hi,

    I packed the csv files and .jpg screenshots in attached zip file. Firs I exported the contacts, than I imported them back (zimbra_contacts.zip). But it looks like there is a problem with export... I manualy edit the .csv file, and import worked just fine (contacts.zip)... Hope it helps.
    Kind regards

    Domen

    p.s. Another one: When I delete all the contacts, the last contact's content remains in the center frame.
    Attached Files Attached Files

  4. #4
    KevinH's Avatar
    KevinH is offline Expert Member
    Join Date
    Aug 2005
    Location
    San Mateo, CA
    Posts
    4,789
    Rep Power
    18

    Default

    Thanks what did you use to edit the file? I viewed the import file with a text editor and with Excel both show broken characters.
    Looking for new beta users -> Co-Founder of Acompli. Previously worked at Zimbra (and Yahoo! & VMware) since 2005.

  5. #5
    wildstyle is offline Junior Member
    Join Date
    Dec 2005
    Location
    Ljubljana, Slovenia
    Posts
    8
    Rep Power
    9

    Talking

    Oh, sorry, I only edit half of the file The new file in atachment is now ok (it imports as it should...)

    I think it's the best if you import these file and than try to export it back and you should see what happens?

    I (re)edit the file manually with notepad (utf-8 charset...)

    Hope it helps,

    Domen
    Attached Files Attached Files

  6. #6
    schemers is offline Zimbra Employee
    Join Date
    Aug 2005
    Posts
    228
    Rep Power
    9

    Default

    thanks for the excellent bug report, including the sample data. I've filed bug 5120, and also fixed the problem. We weren't passing "UTF-8" to the InputStreamReader constructor when importing contacts.

    I've also modified export as well, to export explicitly in UTF-8.

    thanks again, roland

  7. #7
    wildstyle is offline Junior Member
    Join Date
    Dec 2005
    Location
    Ljubljana, Slovenia
    Posts
    8
    Rep Power
    9

    Default

    I can only say, that you guys are great! Keep on the good work!!!

    D.

Thread Information

Users Browsing this Thread

There are currently 1 users browsing this thread. (0 members and 1 guests)

Posting Permissions

  • You may not post new threads
  • You may not post replies
  • You may not post attachments
  • You may not edit your posts
  •