Install glibc.i686.

The package ld-linux.so.2 is in that package, not in the x86_64 version.