Results 1 to 4 of 4

Thread: Zimbra->SoapRequest(): ERROR: curl_exec - (7) couldn't connect to host

  1. #1
    Kamzata is online now Active Member
    Join Date
    Jun 2014
    Location
    Venezia - Italy
    Posts
    32
    Rep Power
    1

    Default Zimbra->SoapRequest(): ERROR: curl_exec - (7) couldn't connect to host

    Hi,

    after I've installed Z-Push (version 2.1.3-1892) and Zimbra Backend (release 60) on a different server (ubuntu 12.04 on a OpenVZ CT, 192.168.1.50, zimbra.myserver.com) then Zimbra 8.0.7 Server (Debian 7 on a openVZ CT, 192.168.1.51, zpush.myserver.com) I tried to login on http://zpush.myserver.com/Microsoft-Active-Sync (I don't use https on both z-push and Zimbra server) on PC browser and it show me user prompt. After entered user and password this is result:

    Code:
    Z-Push - Open Source ActiveSync
    
    Version 2.1.3-1892
    GET not supported
    
    This is the Z-Push location and can only be accessed by Microsoft ActiveSync-capable devices
    
    
    More information about Z-Push can be found at:
    Z-Push homepage
    Z-Push download page at BerliOS
    Z-Push Bugtracker and Roadmap
    
    All modifications to this sourcecode must be published and returned to the community.
    Please see AGPLv3 License for details.
    But when I try to connect through email Android app (using exchange) it login successfully, ask for security approval and then start syncronization but it show me only the folders without mails inside and then it say "no connection".

    I saw in /var/log/z-push/z-push-error.log and I found this:

    Code:
    29/06/2014 04:22:19 [  443] [ERROR] [user@domain.com] Zimbra->SoapRequest(): ERROR: curl_exec - (7) couldn't connect to host
    Zimbra server can ping Zpush server and it resolve as 192.168.1.50 but reverse lookup show:

    Code:
    root@zimbra:~$ host zpush.myserver.com
    zpush.myserver.com has address 192.168.1.51
    
    root@zimbra:/# host 192.168.1.51
    Host 51.1.168.192.in-addr.arpa. not found: 3(NXDOMAIN)
    What do you think? Is this the problem?

  2. #2
    Kamzata is online now Active Member
    Join Date
    Jun 2014
    Location
    Venezia - Italy
    Posts
    32
    Rep Power
    1

    Default

    Think I've solved. Now it seems to work very well. I had change "Disable URL Override" value in "true" on both /config.php and /backend/zimbra/config.php:

    Code:
    define('ZIMBRA_DISABLE_URL_OVERRIDE', true);
    Last edited by Kamzata; 06-29-2014 at 12:04 PM.

  3. #3
    liverpoolfcfan's Avatar
    liverpoolfcfan is offline Outstanding Member
    Join Date
    Oct 2009
    Location
    Dublin, IRELAND
    Posts
    710
    Rep Power
    6

    Default

    Quote Originally Posted by Kamzata View Post
    Think I've solved. Now it seems to work very well. I had change "Disable URL Override" value in "true" on both /config.php and /backend/zimbra/config.php:

    Code:
    define('ZIMBRA_DISABLE_URL_OVERRIDE', true);
    All settings that begin with ZIMBRA_ (including this one) should only be set in the zimbra backend config.php file.

    If your config change has resolved the problem for you, can I mark you Discussion item on the SourceForge site as SOLVED ?

  4. #4
    Kamzata is online now Active Member
    Join Date
    Jun 2014
    Location
    Venezia - Italy
    Posts
    32
    Rep Power
    1

    Default

    Quote Originally Posted by liverpoolfcfan View Post
    All settings that begin with ZIMBRA_ (including this one) should only be set in the zimbra backend config.php file.

    If your config change has resolved the problem for you, can I mark you Discussion item on the SourceForge site as SOLVED ?
    Yes, you can. Thank you. Right, I removed backend setting from /config.php and I left those in /backend/zimbra/config.php because in log file it say "duplicated entry".

Thread Information

Users Browsing this Thread

There are currently 1 users browsing this thread. (0 members and 1 guests)

Similar Threads

  1. Replies: 0
    Last Post: 04-17-2012, 03:02 AM
  2. Replies: 2
    Last Post: 08-10-2010, 04:12 AM
  3. Replies: 0
    Last Post: 08-09-2010, 08:54 AM
  4. SOAP problem - couldn't connect to host
    By mmb12345 in forum Developers
    Replies: 2
    Last Post: 12-31-2007, 03:20 PM
  5. Replies: 0
    Last Post: 01-01-1970, 12:00 AM

Posting Permissions

  • You may not post new threads
  • You may not post replies
  • You may not post attachments
  • You may not edit your posts
  •