Page 2 of 2 FirstFirst 12
Results 11 to 17 of 17

Thread: Zimbraconnector Funambol V8

  1. #11
    leo_lns is offline New Member
    Join Date
    Nov 2009
    Posts
    4
    Rep Power
    5

    Default

    I don't know. It worked fine for me and I reinstalled it a couple of times.
    If you had any java mismatch version errors, it could be the Java Path, but if you got no error at all, I really can't help you.

    Try to reinstall Funambol and Connector.

  2. #12
    ggaspar is offline New Member
    Join Date
    Mar 2010
    Posts
    4
    Rep Power
    5

    Default

    Leo:
    Hi.
    Did you find any solution.
    I've the same problem.

    Thanks.

  3. #13
    adonis1976 is offline Active Member
    Join Date
    Oct 2009
    Location
    Omaha, NE
    Posts
    28
    Rep Power
    5

    Default

    trying doing it this way.. (thanks to Grant)

    try from sctrach..

  4. #14
    adonis1976 is offline Active Member
    Join Date
    Oct 2009
    Location
    Omaha, NE
    Posts
    28
    Rep Power
    5

    Default

    Sorry.. i'm idiot.. here it is

    Funambol Zimbra Install guide.

    Install Funambol using the Funambol installation guide.
    http://download.forge.objectweb.org/...tion-guide.pdf

    Follow this guide for installing Java and setting your JAVA_HOME environment.
    This is the 64bit guide so if you using 32bit then use the 32Bit Java package
    https://core.forge.funambol.org/wiki...InstallOn64bit

    If you are using Zimbra then you should set your system JAVA_HOME environment to be the Zimbra one.
    At the command prompt type the following, you should probably set this to run at startup as well.

    export JAVA_HOME=/opt/zimbra/java

    You can also add this to the funambol startup file, you should have copied /opt/Funambol/bin/funambol to /etc/init.d/funambol
    by now, so just edit /etc/init.d/funambol and change JAVA_HOME to reflect your zimbra setting.

    # Setting the JAVA_HOME to the JRE in the bundle if not set or if not correctly set
    if [ -z "$JAVA_HOME" ]; then
    export JAVA_HOME=/opt/zimbra/java

    Restart Funambol, if you type "ps ax | grep funambol" you should see the funambol processes with the new Java version. If its still showing Java 1.5
    then you havent set the java home correctly.


    Set the Locale setting according to your system. Im using CentOS so I did it like this
    pico /etc/sysconfig/i18n
    Change this to your Language
    LANG="en_US.UTF-8"

    Mine is now
    LANG="en_ZA.UTF-8

    Then run this to make the change live.
    export LANG="en_ZA.UTF-8"

    Check that your server has the right TimeZone configured. I use GMT+2 or SAST


    Install Funambol Admin tool
    You need to have installed java on your PC already. The Funambol Admin tool comes with its own Java which is 1.5
    You need to tell it to use your own java version which should be 1.6

    Edit C:\Program Files\Funambol\admin\etc\funamboladmin config file and set

    jdkhome="C:\Program Files\Java\jre1.6.0_16"

    Download Zimbra Connector.
    Funambol Zimbra Connector | Get Funambol Zimbra Connector at SourceForge.net

    Follow the Zimbra installation guide for Funambol.
    Open Source Mobile Calendar and Contact Synchronization - Zimbra :: Wiki
    You can use the normal Zimbra Connector that you downloaded above, I didnt use the Zoltan one referred to in the guide.


    Check the TimeZone setting for your server in the Funambol Admin Tool and make sure its set to the same as your server.

    When you add the Zimbra sync sources, the URL that is being requested is to connect from Funambol to Zimbra.
    If you are installing both on the same server then this is a local connection so you can use private IP.
    http://192.168.0.1/service/soap
    By default this is port 80 so dont use 8080. The URI setting which you configure from the Funambol install guide is not the same as this URL.


    On the phone side simply add a new synchronization profile if you phone supports SyncML by default.
    The server setting should be the funambol URI which should be in the format http://yourhostname:8080/funambol/ds
    The server needs to be publicly accessible from the Internet, if you running behind a firewall make sure that you have NAT'd port 8080 to your Funambol server

  5. #15
    ggaspar is offline New Member
    Join Date
    Mar 2010
    Posts
    4
    Rep Power
    5

    Default

    Adonis:
    Thankyou very much !!
    It was the JAVA version.
    It's works just changing in funambol startup file this lines:

    # Setting the JAVA_HOME to the JRE in the bundle if not set or if not correctly set
    if [ -z "$JAVA_HOME" ]; then
    export JAVA_HOME=/opt/zimbra/java

    Thank again.
    Bye.

    Quote Originally Posted by adonis1976 View Post
    Sorry.. i'm idiot.. here it is

    Funambol Zimbra Install guide.

    Install Funambol using the Funambol installation guide.
    http://download.forge.objectweb.org/...tion-guide.pdf

    Follow this guide for installing Java and setting your JAVA_HOME environment.
    This is the 64bit guide so if you using 32bit then use the 32Bit Java package
    https://core.forge.funambol.org/wiki...InstallOn64bit

    If you are using Zimbra then you should set your system JAVA_HOME environment to be the Zimbra one.
    At the command prompt type the following, you should probably set this to run at startup as well.

    export JAVA_HOME=/opt/zimbra/java

    You can also add this to the funambol startup file, you should have copied /opt/Funambol/bin/funambol to /etc/init.d/funambol
    by now, so just edit /etc/init.d/funambol and change JAVA_HOME to reflect your zimbra setting.

    # Setting the JAVA_HOME to the JRE in the bundle if not set or if not correctly set
    if [ -z "$JAVA_HOME" ]; then
    export JAVA_HOME=/opt/zimbra/java

    Restart Funambol, if you type "ps ax | grep funambol" you should see the funambol processes with the new Java version. If its still showing Java 1.5
    then you havent set the java home correctly.


    Set the Locale setting according to your system. Im using CentOS so I did it like this
    pico /etc/sysconfig/i18n
    Change this to your Language
    LANG="en_US.UTF-8"

    Mine is now
    LANG="en_ZA.UTF-8

    Then run this to make the change live.
    export LANG="en_ZA.UTF-8"

    Check that your server has the right TimeZone configured. I use GMT+2 or SAST


    Install Funambol Admin tool
    You need to have installed java on your PC already. The Funambol Admin tool comes with its own Java which is 1.5
    You need to tell it to use your own java version which should be 1.6

    Edit C:\Program Files\Funambol\admin\etc\funamboladmin config file and set

    jdkhome="C:\Program Files\Java\jre1.6.0_16"

    Download Zimbra Connector.
    Funambol Zimbra Connector | Get Funambol Zimbra Connector at SourceForge.net

    Follow the Zimbra installation guide for Funambol.
    Open Source Mobile Calendar and Contact Synchronization - Zimbra :: Wiki
    You can use the normal Zimbra Connector that you downloaded above, I didnt use the Zoltan one referred to in the guide.


    Check the TimeZone setting for your server in the Funambol Admin Tool and make sure its set to the same as your server.

    When you add the Zimbra sync sources, the URL that is being requested is to connect from Funambol to Zimbra.
    If you are installing both on the same server then this is a local connection so you can use private IP.
    http://192.168.0.1/service/soap
    By default this is port 80 so dont use 8080. The URI setting which you configure from the Funambol install guide is not the same as this URL.


    On the phone side simply add a new synchronization profile if you phone supports SyncML by default.
    The server setting should be the funambol URI which should be in the format http://yourhostname:8080/funambol/ds
    The server needs to be publicly accessible from the Internet, if you running behind a firewall make sure that you have NAT'd port 8080 to your Funambol server

  6. #16
    ggaspar is offline New Member
    Join Date
    Mar 2010
    Posts
    4
    Rep Power
    5

    Default

    Thank you very much !!!
    It's works changing the JAVA_HOME.

    Thanks again.

  7. #17
    adonis1976 is offline Active Member
    Join Date
    Oct 2009
    Location
    Omaha, NE
    Posts
    28
    Rep Power
    5

    Default

    Your welcome!! I'm glad that it worked..

Page 2 of 2 FirstFirst 12

Thread Information

Users Browsing this Thread

There are currently 1 users browsing this thread. (0 members and 1 guests)

Posting Permissions

  • You may not post new threads
  • You may not post replies
  • You may not post attachments
  • You may not edit your posts
  •