Page 92 of 105 FirstFirst ... 42829091929394102 ... LastLast
Results 911 to 920 of 1048

Thread: Z-Push Zimbra Backend (Push Email, Contacts, Appointments & Tasks)

  1. #911
    liverpoolfcfan's Avatar
    liverpoolfcfan is offline Outstanding Member
    Join Date
    Oct 2009
    Location
    Dublin, IRELAND
    Posts
    698
    Rep Power
    6

    Default

    Quote Originally Posted by vendors@curveos.com View Post
    but it seems that when the user adds a new calendar it's not being propagated down to the phone. I've done a decent amount of testing and I see the following in the log file. In this excerpt it appears that Zimbra is aware of the new folder, but for some reason it's not being pushed down. Any ideas?
    I have tested adding/removing calendars here, and it works fine. The foldersync is not an immediate change that gets notified to the phone like an incoming email. It will get synced at the next full sync request. Alternatively, if you are the impatient type, you can open the Calendar app, Click on the Calendars button, and then press the refresh button at the bottom left. That will trigger a foldersync to happen. Also, make sure you have checked 'All Exchange' in there or otherwise the calendar will be synching just fine - just not showing appointments in the GUI.

    No idea on scalability.

  2. #912
    sangamc is offline Special Member
    Join Date
    Aug 2009
    Location
    florida
    Posts
    129
    Rep Power
    5

    Default

    Ive been using z-push for a couple of years now and its been working fantastic. HTML email, global address lists, calendars and all

    Recently i've been running into a strange problem that I do not know how to track down. I recently added about 10 more users to my z-push server. It works fine then after several hours it will simply freeze up and I am forced to physically restart the server. Checking the debug.txt reveals normal info until the freeze, checking messages.log also reveals normal info until the freeze.

    SO i did a few things.
    #1 I increased the RAM and Processor to no avail, still freezing
    #2 stopped running debug.txt thinking the file growing by GBs every few hours was the issue, still freezing
    #3 I built a new server with Double RAM and processor. Ran it for a week with only 2 users (everything works fine) The day I moved all the other users to the new one ... Freezing all over again.

    I am starting to suspect one of the users devices is the cause of the freezing, but I am not sure how to trouble shoot. I am comfortable parsing logs and even use a splunk server for advanced analytics, but If someone could help me with what logs to look at or what to look for in the logs, that would be great

    Thanks
    Release 7.2.0_GA_2669.RHEL6_64_20120410002025 CentOS6_64 FOSS edition.

  3. #913
    Yaroze is offline Intermediate Member
    Join Date
    Jul 2012
    Posts
    23
    Rep Power
    2

    Default

    Using Z-Push 1 with backend version 54
    When i create a calendar appointment on my iPhone, more then a year ahead.. it creates it, sends it to the server..
    it shows up in the zimbra webclient.. but on my iPhone there is nothing. Any ideas?

  4. #914
    vendors@curveos.com is offline Junior Member
    Join Date
    Mar 2012
    Posts
    8
    Rep Power
    3

    Default

    Thanks for your reply. Yup, the way that I've been able to get the folders pushed down immediately is by doing a full resync. My mechanism for doing a full resync was crude as it was just for testing. We are actually only syncing calendar folders to the iPhone, not email, contacts, etc. Any recommendations on how to programmatically force a full resync only when a new Calendar folder is detected on Zimbra?

    Thanks again.

    Quote Originally Posted by liverpoolfcfan View Post
    I have tested adding/removing calendars here, and it works fine. The foldersync is not an immediate change that gets notified to the phone like an incoming email. It will get synced at the next full sync request. Alternatively, if you are the impatient type, you can open the Calendar app, Click on the Calendars button, and then press the refresh button at the bottom left. That will trigger a foldersync to happen. Also, make sure you have checked 'All Exchange' in there or otherwise the calendar will be synching just fine - just not showing appointments in the GUI.

    No idea on scalability.

  5. #915
    sangamc is offline Special Member
    Join Date
    Aug 2009
    Location
    florida
    Posts
    129
    Rep Power
    5

    Default

    Digging deeper it looks like RAM fills up with multipl apache processes, then the sawp fills up which eventually leads the server to crash. Not sure this is a z-push issue, but If anyone has any ideas how to trouble shoot, that would help. For now I setup a cron to restart apache every 15 minutes

    Quote Originally Posted by sangamc View Post
    Ive been using z-push for a couple of years now and its been working fantastic. HTML email, global address lists, calendars and all

    Recently i've been running into a strange problem that I do not know how to track down. I recently added about 10 more users to my z-push server. It works fine then after several hours it will simply freeze up and I am forced to physically restart the server. Checking the debug.txt reveals normal info until the freeze, checking messages.log also reveals normal info until the freeze.

    SO i did a few things.
    #1 I increased the RAM and Processor to no avail, still freezing
    #2 stopped running debug.txt thinking the file growing by GBs every few hours was the issue, still freezing
    #3 I built a new server with Double RAM and processor. Ran it for a week with only 2 users (everything works fine) The day I moved all the other users to the new one ... Freezing all over again.

    I am starting to suspect one of the users devices is the cause of the freezing, but I am not sure how to trouble shoot. I am comfortable parsing logs and even use a splunk server for advanced analytics, but If someone could help me with what logs to look at or what to look for in the logs, that would be great

    Thanks
    Release 7.2.0_GA_2669.RHEL6_64_20120410002025 CentOS6_64 FOSS edition.

  6. #916
    liverpoolfcfan's Avatar
    liverpoolfcfan is offline Outstanding Member
    Join Date
    Oct 2009
    Location
    Dublin, IRELAND
    Posts
    698
    Rep Power
    6

    Default

    Quote Originally Posted by Yaroze View Post
    Using Z-Push 1 with backend version 54
    When i create a calendar appointment on my iPhone, more then a year ahead.. it creates it, sends it to the server..
    it shows up in the zimbra webclient.. but on my iPhone there is nothing. Any ideas?
    The code has hard-coded to select appointments up to 366 days in advance. Used to be 199 but I upped it to 366 a while ago.

  7. #917
    cryoaura is offline Starter Member
    Join Date
    Oct 2012
    Posts
    1
    Rep Power
    2

    Default

    Quote Originally Posted by jonallport View Post
    With the impending release of Office 2013 do you/we think that using Outlook with z-push will be feasible?

    Theory:
    Z-Push 2.x enables EAS 14 - check!
    Outlook 2013 will use EAS 14 - check!

    I 'hope' that this means I can use Outlook to connect to ZCS FOSS with contacts and calendar support, even though OL 2013 is an ugly bland-fest in the design department I'd be willing to put up with that for the convenience that it would bring; I could 'fit in' with the corporate footprint but avoid the cost, complexity and overhead of Exchange Server.

    What do we think?

    TIA

    Update:
    So far not so good. Account setup wizard will not complete but EAS WILL work; if I setup the account through the 'mail' control panel I can open Outlook while the wizard is still open and it works fully - mail (send and receive), calendar, contacts - but as soon as I acknowledge the failed setup the account is removed.

    When I get more time I'll try troubleshooting - nothing obvious in the debug info.
    So there's a quick and dirty solution. Once you are at the failed setup window, open task manager and go to the process of that setup, should be rundll, and end it. Now your Outlook will work. I've noticed that Outlook will crash in normal mode with this, but safe mode works just great. All email synchronization works, and calendar. Contact synchronization has some issues. Any contacts you made on your device, do not show in outlook. If you make a new contact in Outlook, it will sync to the device, but add a bunch of HTML for the notes and throw @localhost in email 2 and 3. From this point u can edit the contact on your device or outlook and remove the html notes, they wont come back, however, if you make a change on your device to the contact, the @localhost will get thrown into the email 2 and 3 again. Kind of a backwards way to do things, but it does work 100% showing Outlook 2013 can use the Activesync function just great. Question is, what does Outlook check to make sure it can connect to the server, and how do we emulate that? Also, what is going on with contacts? Seems like base synchronization is there, but something isn't right.

  8. #918
    janc is offline New Member
    Join Date
    Sep 2012
    Posts
    4
    Rep Power
    2

    Default

    Quote Originally Posted by sangamc View Post
    Digging deeper it looks like RAM fills up with multipl apache processes, then the sawp fills up which eventually leads the server to crash. Not sure this is a z-push issue, but If anyone has any ideas how to trouble shoot, that would help. For now I setup a cron to restart apache every 15 minutes
    I tried upgrading to release 54. And approx. 6 hours later my server crashed. So perhaps I'm seeing the same problem as you. After the crash I downgraded back to release 53. Which I have had running for long a long time without any problems.

  9. #919
    sangamc is offline Special Member
    Join Date
    Aug 2009
    Location
    florida
    Posts
    129
    Rep Power
    5

    Default

    I was able to stabilize my server. I think when upgrading to r54 I put the wrong mime.php and mimepart.php files in the wrong folders. I redid the setup and paid close attention to what files went where and the problem seems to have disappeared.
    Release 7.2.0_GA_2669.RHEL6_64_20120410002025 CentOS6_64 FOSS edition.

  10. #920
    Yaroze is offline Intermediate Member
    Join Date
    Jul 2012
    Posts
    23
    Rep Power
    2

    Default

    Quote Originally Posted by liverpoolfcfan View Post
    The code has hard-coded to select appointments up to 366 days in advance. Used to be 199 but I upped it to 366 a while ago.
    I doubled the value, seems to be working Why is there such a low limit anyway?

Page 92 of 105 FirstFirst ... 42829091929394102 ... LastLast

Thread Information

Users Browsing this Thread

There are currently 2 users browsing this thread. (0 members and 2 guests)

Similar Threads

  1. fatal: parameter "smtpd_recipient_restrictions"
    By Robin in forum Administrators
    Replies: 8
    Last Post: 12-22-2010, 05:48 AM
  2. Replies: 12
    Last Post: 02-25-2008, 07:28 PM
  3. /tmp filling
    By Nutz in forum Administrators
    Replies: 8
    Last Post: 02-22-2008, 02:00 AM
  4. Replies: 22
    Last Post: 12-02-2007, 05:05 PM
  5. zmtlsctl give LDAP error
    By sourcehound in forum Administrators
    Replies: 5
    Last Post: 03-11-2007, 03:48 PM

Posting Permissions

  • You may not post new threads
  • You may not post replies
  • You may not post attachments
  • You may not edit your posts
  •