Page 89 of 106 FirstFirst ... 3979878889909199 ... LastLast
Results 881 to 890 of 1054

Thread: Z-Push Zimbra Backend (Push Email, Contacts, Appointments & Tasks)

  1. #881
    liverpoolfcfan's Avatar
    liverpoolfcfan is offline Outstanding Member
    Join Date
    Oct 2009
    Location
    Dublin, IRELAND
    Posts
    712
    Rep Power
    6

    Default

    Quote Originally Posted by karol.k View Post
    I have installed the Latest ZimbraBackend with Z-Push-2 on my Ubuntu 10.04 based Zimbra 8 server. (Not on the same one).

    Push email seems to be working fine, synchronization as well, but when I tried to create a Contact on the phone there seems to be an issue with synchronizing the contact with the Zimbra server. It keeps hanging and creating the same contact multiple times. (I had my test contact created (9000 times ).

    Has anybody experienced a similar problem?
    I have never seen it loop like that - but duplicating the item on the phone is a known issue. I raised it with the z-push team a few weeks ago. It has been confirmed as a bug. See https://jira.zarafa.com/browse/ZP-249

    In your case did you get the contact created multiple times on the phone or the server ?

    If on the server side - then open a tracker ticket under z-push-2 on the sourceforge web site for further help. If on the phone, then watch for a fix for the z-push-2 ticket referenced.

  2. #882
    liverpoolfcfan's Avatar
    liverpoolfcfan is offline Outstanding Member
    Join Date
    Oct 2009
    Location
    Dublin, IRELAND
    Posts
    712
    Rep Power
    6

    Default

    Quote Originally Posted by karol.k View Post
    It keeps hanging and creating the same contact multiple times. (I had my test contact created (9000 times ).

    Has anybody experienced a similar problem?
    I have reproduced this issue and fixed it. It was in code I added when troubleshooting the z-push duplication bug. Fix is checked in to SVN as 53.5.z-push-2. Sorry for the hassle.

    PS: Note this does not address the z-push issue - just stops the additional duplication
    Last edited by liverpoolfcfan; 09-25-2012 at 07:19 AM. Reason: Edit - 53.5.z-push-2

  3. #883
    karol.k is offline Member
    Join Date
    Feb 2010
    Location
    Netherlands
    Posts
    11
    Rep Power
    5

    Default

    Quote Originally Posted by liverpoolfcfan View Post
    I have reproduced this issue and fixed it. It was in code I added when troubleshooting the z-push duplication bug. Fix is checked in to SVN as 53.5.z-push-2. Sorry for the hassle.

    PS: Note this does not address the z-push issue - just stops the additional duplication
    That's great news. Thank you for that.

  4. #884
    karol.k is offline Member
    Join Date
    Feb 2010
    Location
    Netherlands
    Posts
    11
    Rep Power
    5

    Default

    Quote Originally Posted by liverpoolfcfan View Post

    In your case did you get the contact created multiple times on the phone or the server ?
    I have created one Contact on the Android 4.0.4 Phone itself and run the synchronization. The sync was running and running and than when I looked on the server, if the contact is there, its been there 9000 times. So, it created it multiple times on the server - answering your question.

  5. #885
    cbnidk is offline Intermediate Member
    Join Date
    Dec 2009
    Posts
    24
    Rep Power
    5

    Default

    Quote Originally Posted by cbnidk View Post
    Hi

    I have read about smartfolders and I can't see it is easier to set than userfiles, I think I will try to set it up with user files for now
    but if it is easy to add in smartfolder you can go for it, laster on we can choose what we like

    Thanks for the answer

    Claus
    I have now try to setup user files with z-push-2 but I can't get i to work, the only thing I want user files to do for me is to send mail as another email adress
    it is working to sent from an another email adress in zimbra web mail, so it is not in zimbra the error is

    my htc have android 4.0.4

    what can I do to find what is wrong?

    Claus

  6. #886
    liverpoolfcfan's Avatar
    liverpoolfcfan is offline Outstanding Member
    Join Date
    Oct 2009
    Location
    Dublin, IRELAND
    Posts
    712
    Rep Power
    6

    Default

    Quote Originally Posted by cbnidk View Post
    I have read about smartfolders and I can't see it is easier to set than userfiles, I think I will try to set it up with user files for now
    but if it is easy to add in smartfolder you can go for it, laster on we can choose what we like
    The whole point of SmartFolders is that you don't need an admin to create the XML files for you. You can simply add a character to the end of a folder name to stop it and/or it's children from synching. Also the *SyncConfig* directives allow specification of extra configs similar to those in the XML files.

    Quote Originally Posted by cbnidk View Post
    I have now try to setup user files with z-push-2 but I can't get i to work, the only thing I want user files to do for me is to send mail as another email adress
    it is working to sent from an another email adress in zimbra web mail, so it is not in zimbra the error is
    There was a bug in the re-worked SendMail function. It should be fixed properly in the latest check-in from this evening 53.6...

  7. #887
    cbnidk is offline Intermediate Member
    Join Date
    Dec 2009
    Posts
    24
    Rep Power
    5

    Default

    Quote Originally Posted by liverpoolfcfan View Post
    The whole point of SmartFolders is that you don't need an admin to create the XML files for you. You can simply add a character to the end of a folder name to stop it and/or it's children from synching. Also the *SyncConfig* directives allow specification of extra configs similar to those in the XML files.


    There was a bug in the re-worked SendMail function. It should be fixed properly in the latest check-in from this evening 53.6...
    Hi

    I have tested with 53-6, but sendas another email adress is not working. I can sent a debug log if you like?
    this I have done in 2010

    I can see in the log that user files is uses

  8. #888
    amartin is offline Intermediate Member
    Join Date
    Dec 2010
    Posts
    24
    Rep Power
    4

    Default

    Upgrading from Z-Push 1.5.5 and zimbrabackend revision 51 to Z-Push 2.0.3 and the latest svn checkout of zimbrabackend (I am using Smart Folders), do I need to copy over the state directory, or should I leave the new one in the Z-Push 2.xx.xx install empty?

    Also, is the Z-Push-2-compatible version of zimbrabackend in svn almost stable? Is there a timeframe for revision 54?

    Thanks!
    Last edited by amartin; 09-27-2012 at 12:23 PM.

  9. #889
    fviero is offline Project Contributor
    Join Date
    Jun 2007
    Location
    Porto Alegre, RS, Brazil
    Posts
    96
    Rep Power
    8

    Default

    Hey

    Well, Zimbra Z-push is working like a charm so far. Thanks for helping when i first had problems with it. Nevertheless, i´m running into an issue here. I live in Brazil and many of our First and/or last names have accents in it. It goes like this:

    1. If i compose an email on the phone and my name has an accent, when it arrives both in zimbra and at some smartphone, it will show garbled characters

    2. If i compose the message using Zimbra Web Client, i receive it OK on the phone. No garbled characters.

    3. Accents in the body are always OK. The problem is just in the header.

    z-push-2.0.2-1437
    Zimbra backend Release 53
    Zimbra latest 7

    EDIT: Adding some examples

    This header was taken from a message composed and sent via ZWC, characters show ok both on phone and webclient

    From: =?utf-8?Q?F=C3=A1bio?= Viero Interop IT Consulting <xxxxx@xx.xx.xx.br>
    To: =?utf-8?Q?Usu=C3=A1rio_de_Administra=C3=A7=C3=A3o_de_Ser vi=C3=A7os?= <xxxx@xx.xx.xxx.br>

    This one was taken from a message sent from a mobile device, Android 2.3.6

    From: "Fábio Viero Interop IT Consulting" <xxxxx@xx.xx.xxx.br>
    To: Usuário de Administração de Serviços <xxxx@xx.xx.xx.br>

    Characters in the name field appear just like the above exemple bot at the webclient and smartphone

    Correct form is:

    Fábio Viero Interop IT Consulting
    Usuário de Administração de Serviços



    Need more info? Have any clues?

    Thanks!!!!
    Last edited by fviero; 09-27-2012 at 12:38 PM.

  10. #890
    liverpoolfcfan's Avatar
    liverpoolfcfan is offline Outstanding Member
    Join Date
    Oct 2009
    Location
    Dublin, IRELAND
    Posts
    712
    Rep Power
    6

    Default

    For the sender name look at the notes at the top of the file for sendasname. you can set your name to be the correctly encoded name. not sure I can do anything about the To address.

Page 89 of 106 FirstFirst ... 3979878889909199 ... LastLast

Thread Information

Users Browsing this Thread

There are currently 3 users browsing this thread. (1 members and 2 guests)

  1. kosnar

Similar Threads

  1. z-push and zimbra backend problem
    By ben1967 in forum Mobility
    Replies: 9
    Last Post: 11-14-2012, 11:29 PM
  2. z-push and zimbra backend problem
    By ben1967 in forum Administrators
    Replies: 0
    Last Post: 11-11-2012, 02:11 PM
  3. [SOLVED] Z-push Zimbra backend workaround
    By Inchoate in forum Mobility
    Replies: 6
    Last Post: 01-19-2012, 04:22 AM
  4. [SOLVED] Z-push Zimbra backend workaround
    By Inchoate in forum Administrators
    Replies: 0
    Last Post: 10-31-2010, 07:06 AM
  5. Replies: 348
    Last Post: 10-11-2010, 05:39 AM

Posting Permissions

  • You may not post new threads
  • You may not post replies
  • You may not post attachments
  • You may not edit your posts
  •