Page 87 of 105 FirstFirst ... 3777858687888997 ... LastLast
Results 861 to 870 of 1048

Thread: Z-Push Zimbra Backend (Push Email, Contacts, Appointments & Tasks)

  1. #861
    liverpoolfcfan's Avatar
    liverpoolfcfan is offline Outstanding Member
    Join Date
    Oct 2009
    Location
    Dublin, IRELAND
    Posts
    698
    Rep Power
    6

    Default

    Quote Originally Posted by aarat View Post
    Looking for someone who can help me upgrade my current zimbra backend with z-push 2.0. I have release 53 running live on z-push 1.x. How do I migrate. What are the configuration changes in zpush 2.0 for zimbra backend.
    Ironically, the config.php file is just about the only thing that doesn't change much. Everything else changes.

    If you setup a new z-push-2 installation, then download the z-push-2 backend version from the SVN on the sourceforge site, and copy the BACKEND_PROVIDER and all the ZIMBRA_ settings from your z-push 1.5 config.php over to the new config.php you will be ready to start. Follow the instructions in the zimbra backend INSTALL file for setting up the backend folder.

    Note that there are still some stability issues with z-push-2, and still some unfinished work on porting the backend over to z-push-2 - but it is working well for the most part with most phones.

  2. #862
    johnroberts is offline New Member
    Join Date
    Aug 2012
    Posts
    3
    Rep Power
    2

    Default

    If you setup a new z-push-2 installation, then download the z-push-2 backend version from the SVN on the sourceforge site, and copy the BACKEND_PROVIDER and all the ZIMBRA_ settings from your z-push 1.5 config.php over to the new config.php you will be ready to start. Follow the instructions in the zimbra backend INSTALL file for setting up the backend folder.
    Dumb question as not a developer, but please could you specify the exact 'svn' command to download that version of the z-push-2 backend?

    Thanks in advance!

  3. #863
    aarat is offline Active Member
    Join Date
    Aug 2011
    Posts
    32
    Rep Power
    3

    Default

    Trying to integrate zimbra backend with zpush 2 and I am getting below logs and also nothing happens when we open http://server/Microsoft-Server-ActiveSync



    File Zimbra.log
    14/08/2012 22:42:11 [23287] [user@domain.com] [DEBUG] -------- Start
    14/08/2012 22:42:11 [23287] [user@domain.com] [ INFO] Version='2.0.1-1375' method='POST' from='1.38.26.126' cmd='Sync' getUser='user@domain.com' devId='androidc378561389' devType='Android'
    14/08/2012 22:42:11 [23287] [user@domain.com] [DEBUG] Used timezone 'Asia/Calcutta'
    14/08/2012 22:42:11 [23287] [user@domain.com] [DEBUG] Including backend file: '/usr/share/z-push/backend/zimbra.php'
    14/08/2012 22:42:11 [23287] [user@domain.com] [ WARN] /usr/share/z-push/backend/diffbackend.php:50 include_once(proto.php) [<a href='function.include-once'>function.include-once</a>]: failed to open stream: No such file or directory (2)
    14/08/2012 22:42:11 [23287] [user@domain.com] [ WARN] /usr/share/z-push/backend/diffbackend.php:50 include_once() [<a href='function.include'>function.include</a>]: Failed opening 'proto.php' for inclusion (include_path='.:/usr/share/pear:/usr/share/php') (2)
    14/08/2012 22:42:11 [23287] [user@domain.com] [ WARN] /usr/share/z-push/backend/backend.php:65 Constant BACKEND_DISCARD_DATA already defined (8)
    File error_log in httpd logs
    [Tue Aug 14 22:44:02 2012] [error] [client 1.38.26.53] PHP Fatal error: Cannot redeclare class Backend in /usr/share/z-push/backend/backend.php on line 90
    Not sure what can be the issue.. Please help
    Zimbra Version 8.0.1_G.A._5438 (build 20121105164416) running on ubuntu 10.04 x64

  4. #864
    liverpoolfcfan's Avatar
    liverpoolfcfan is offline Outstanding Member
    Join Date
    Oct 2009
    Location
    Dublin, IRELAND
    Posts
    698
    Rep Power
    6

    Default

    Please open a Tracker->Support Request ticket on the sourceforge site for help to avoid unnecessarily expanding this already very long thread.

    But the obvious thing is that
    include_once(proto.php)
    is from z-push 1.5.x as that file no longer exists in z-push-2. You cannot mix files from z-push 1.5 and z-push 2 - you need to start from a completely clean install folder.

  5. #865
    le_gache's Avatar
    le_gache is offline Member
    Join Date
    Jun 2010
    Location
    France - Brittany - Auray
    Posts
    10
    Rep Power
    4

    Default

    Hello,

    z-push 2.0.2 with zimbra 7.2.0 is working fine. But the very IMPORTANT thing is NOT to download the zimbra backend from the main page but from the SVN page :
    SourceForge.net Repository - [zimbrabackend] Index of /zimbra-backend/branches/z-push-2

    You have to click on "Download GNU tarball".
    And then, everythnig is working fine.

    Every of the issues I had with z-push 2 came from my install of zimbra backend 53 for z-push 1.5 like aarat and perhaps many other people.

    Hoping this will help.
    The more you fail... The more you succeed...
    -----------------------------------------------------------------------------
    ZCS 8.0.3 OSE CentOS 6.4 64 bits on Hyper-V
    Z-Push 2.0.7 - Zimbra Backend 55 CentOS 6.4 64 bits on Hyper-V

  6. #866
    fviero is offline Project Contributor
    Join Date
    Jun 2007
    Location
    Porto Alegre, RS, Brazil
    Posts
    96
    Rep Power
    7

    Default

    Hi there

    Using Zimbra 7.2.0 and Z-push latest and Zimbra Z-push SVN version as above. Very helpfull thread!!

    Im getting an "incorrect user password error" when trying to connect to z-push though:

    13/09/2012 21:45:06 [31312] [interop] [INFO] Version='2.0.2-1437' method='GET' from='172.17.229.234' cmd='' getUser='interop' devId='' devType=''
    13/09/2012 21:45:06 [31312] [interop] [INFO] AuthenticationRequiredException: Access denied. Username or password incorrect - code: 0
    13/09/2012 21:45:06 [31312] [interop] [INFO] User-agent: 'Mozilla/5.0 (Windows NT 6.1) AppleWebKit/537.1 (KHTML, like Gecko) Chrome/21.0.1180.83 Safari/537.1

    When i access z-push via browser, i do get the login window (the log above is from a test using the browser).

    Zimbra is setup to authenticate with Active Directory but its also using authentication fallback (if AD fails or if i need to add an email user only).

    Any clues?

    Thanks!!!

  7. #867
    stave08 is offline Starter Member
    Join Date
    Jun 2009
    Posts
    1
    Rep Power
    5

    Default access denied fix

    just had the same issue, turning on the z-push debug helped solve it:
    define('LOGLEVEL', LOGLEVEL_DEBUG);

    i was missing missing php curl



    Quote Originally Posted by fviero View Post
    Hi there

    Using Zimbra 7.2.0 and Z-push latest and Zimbra Z-push SVN version as above. Very helpfull thread!!

    Im getting an "incorrect user password error" when trying to connect to z-push though:

    13/09/2012 21:45:06 [31312] [interop] [INFO] Version='2.0.2-1437' method='GET' from='172.17.229.234' cmd='' getUser='interop' devId='' devType=''
    13/09/2012 21:45:06 [31312] [interop] [INFO] AuthenticationRequiredException: Access denied. Username or password incorrect - code: 0
    13/09/2012 21:45:06 [31312] [interop] [INFO] User-agent: 'Mozilla/5.0 (Windows NT 6.1) AppleWebKit/537.1 (KHTML, like Gecko) Chrome/21.0.1180.83 Safari/537.1

    When i access z-push via browser, i do get the login window (the log above is from a test using the browser).

    Zimbra is setup to authenticate with Active Directory but its also using authentication fallback (if AD fails or if i need to add an email user only).

    Any clues?

    Thanks!!!

  8. #868
    fviero is offline Project Contributor
    Join Date
    Jun 2007
    Location
    Porto Alegre, RS, Brazil
    Posts
    96
    Rep Power
    7

    Default

    Quote Originally Posted by stave08 View Post
    just had the same issue, turning on the z-push debug helped solve it:
    define('LOGLEVEL', LOGLEVEL_DEBUG);

    i was missing missing php curl
    On spot...that was the problem.

    Sync is working ok. I had to disable provisioning too.

    Thanks for the help, all of you.

  9. #869
    Sajuuk is offline Member
    Join Date
    Nov 2010
    Posts
    14
    Rep Power
    4

    Default Z-Push Zimbra Backend compatibility with Zimbra 8

    Has someone tried to use Z-Push Zimbra Backend with Zimbra 8?

  10. #870
    liverpoolfcfan's Avatar
    liverpoolfcfan is offline Outstanding Member
    Join Date
    Oct 2009
    Location
    Dublin, IRELAND
    Posts
    698
    Rep Power
    6

    Default

    Quote Originally Posted by Sajuuk View Post
    Has someone tried to use Z-Push Zimbra Backend with Zimbra 8?
    Not as yet. I have built a release 8 test box but haven't had the time to set up a test as yet. Maybe next week ...

Page 87 of 105 FirstFirst ... 3777858687888997 ... LastLast

Thread Information

Users Browsing this Thread

There are currently 2 users browsing this thread. (0 members and 2 guests)

Similar Threads

  1. fatal: parameter "smtpd_recipient_restrictions"
    By Robin in forum Administrators
    Replies: 8
    Last Post: 12-22-2010, 05:48 AM
  2. Replies: 12
    Last Post: 02-25-2008, 07:28 PM
  3. /tmp filling
    By Nutz in forum Administrators
    Replies: 8
    Last Post: 02-22-2008, 02:00 AM
  4. Replies: 22
    Last Post: 12-02-2007, 05:05 PM
  5. zmtlsctl give LDAP error
    By sourcehound in forum Administrators
    Replies: 5
    Last Post: 03-11-2007, 03:48 PM

Posting Permissions

  • You may not post new threads
  • You may not post replies
  • You may not post attachments
  • You may not edit your posts
  •