Page 79 of 106 FirstFirst ... 2969777879808189 ... LastLast
Results 781 to 790 of 1052

Thread: Z-Push Zimbra Backend (Push Email, Contacts, Appointments & Tasks)

  1. #781
    liverpoolfcfan's Avatar
    liverpoolfcfan is offline Outstanding Member
    Join Date
    Oct 2009
    Location
    Dublin, IRELAND
    Posts
    710
    Rep Power
    6

    Default

    Quote Originally Posted by gtr33m View Post
    I recently updated to 51.7.as12.1 primarily to allow html emails.
    ......

    Is there a way to fix the problem using remote provisioning, or something I can do on the server to fix the problem? If it's a matter of combing through the state folder and deleting some files, this is easier than the other option.
    I have never tried to update a device without recreating the profile - as the data stored at the backend is so different. And, if you have a lot of devices - switching over all in one go could put huge stress on the z-push/zimbra combination as all devices will start full resync at the same time. Much better to have two instances running side-by-side (on different hostnames/ip addresses obviously as you have only one possibility for an alias /Microsoft-Server-ActiveSync) then to switch people over a few at a time.

    It is also a great was to get rid of all the stale files left after device re-syncs, profile recreations, etc.

    As regards the actual data in the state folder - z-push 1.5.n uses one file named for the DeviceID as the key to identify the synched folders for the device. zpush as12.1 instead used a folder named for the DeviceID to store all files related to the device. If you have not created a parallel install with as12.1 having it's own state folder - then as12.1 will be unable to create it's device folders as there will already be device files in the directory that have the name as12.1 wishes to use for a folder name.

    If you want to be a guinea-pig - try deleting the 1.5 device file, and see if the new folder gets created and populated correctly. and report back how it goes.

    Note: you can see the device ID in the debug.txt file in the START Setup line

    02/06/12 12:40:10 [19948] [myUSer] START Setup { userid = myUser; devid = Appl000000QCEA4S; protocolversion = 2.5; useragent = Apple-iPhone3C1/901.405 }

    That will give you the DeviceID to search for for each user.

    Good luck.

  2. #782
    liverpoolfcfan's Avatar
    liverpoolfcfan is offline Outstanding Member
    Join Date
    Oct 2009
    Location
    Dublin, IRELAND
    Posts
    710
    Rep Power
    6

    Default Z-Push Zimbra Backend Release 52 uploaded to SourceForge

    Release 52 of the z-push zimbra backend has just been uploaded to SourceForge (https://sourceforge.net/projects/zimbrabackend/)

    Code:
    ==============  Z-Push Zimbra Backend - Release Notes - Release 52  ==============
    
    THESE RELEASE NOTES ARE FOR RELEASE 52 CHANGES 
    
    PLEASE READ THESE RELEASE NOTES COMPLETELY BEFORE IMPLEMENTING RELEASE 52
    NOTE THAT THE RELEASE NOTES FOR 49-51 ARE ALSO CONTAINED BELOW AND SHOULD 
    ALSO BE READ FULLY WHEN UPGRADING FROM A RELEASE 48 OR EARLIER.
    THIS IS EXPECIALLY CRITICAL IF YOU ARE TURNING ON ANY OF THE NEW FEATURES
    AND ARE UPGRADING AN EXISTING INSTALLATION FROM RELEASE 48 OR EARLIER. 
    
    
    Changes Made To Revision 52:
     - Fixed length encoding in GlobalObjID that caused duplicated meetings, and
       broke meeting updates - Fix can't update bad meeting IDs already on device  
     - Fix to use client generated UID for new appointments created on the phone
       to avoid duplication of the appointment in the calendar
     - Fix to strip Email Name from email address on contact sync - android issue
     - Changed handling of virtual folders for Apple devices as they have a non-
       standard ability to display multiple Calendars and Multiple folders of 
       contacts natively. This change will allow all Calendar and Contact folders
       to be synced to Apple devices. I have tested WM 6.5, Samsung android 2.3.3
       and Nokia, and none of them can support this functionality. If anyone knows
       other devices that have this native capability, let me know and I can add 
       exceptions to the code for them as well. To turn off this feature two new
       switches have been defined for config.php - ZIMBRA_DISABLE_MULTI_CALENDARS
       and ZIMBRA_DISABLE_MULTI_CONTACT_GROUPS - see below for details
     - Fixed Plain Text attachments getting appended to plain text body
     - Fixed Attachments/Images for MIME formatted messages  
     - Added HTML/MIME formatted message support for iPhone using z-push 1.5.x - 
       Setting the ZIMBRA_HTML flag to true should now send MIME to the device when
       requested by the device (mimesupport 2 requested).
     - Fixed S/MIME Support. S/MIME messages now sent to device when mimesupport 1
       received from device. 
     - Changed meetingstatus to 1 (Is a meeting) from 0 for appointment sync
     - Added new optional config.php setting ZIMBRA_MB_DETECT_ORDER to allow 
       overriding of the default list of charsets. See notes below.
     - Change to GetHTMLAttachmentsRecursive to allow for content-type header that
       has no primary/secondary type included 
     - Added 86400 second offset to message $cutoffdate as zimbra search works 
       from midnight and just using $cutoffdate turned into a date string was 
       dropping all emails from 3rd day back. Now seach returns today, and all of
       previous 3 days/7 days/14 days etc.
     - Changed $revision to $GLOBALS['revision'] 
     - Added optional configuration ZIMBRA_DETECT_RUSSIAN to allow support of the 
       Russian language. Requires include file a.charset.php
     - Fix for Modify Appointment function ConvertItemIdToInvID to use 
       GetAppointmentRequest instead of SearchRequest which was sometimes unable
       to find all appointments
     - Fix to only send InstanceType for meeting Request - not for Notification
     - Fix for GetAttachmentData and ItemOperationsGetAttachmentData to check if the 
       attachment is in a Shared Mailbox and handle $attname differently.
     - Fix for GetAttachmentData to not output a content-type header, as request.php
       is already sending a generic application/octet-stream content type header. 
       Also added output Content-Length header, and use echo instead of print
     - Fix added to GetMpBodyRecursive for handling inline images from iOS5
     - Replaced GetBodyRecursive with GetAllBodyRecursive to streamline processing
     - Uncomment addHTMLImage call in getHTMLAttachmentsRecursive
     - Fix added to SendMail to handle attachments on SmartForward requests
     - Fix added to StatMessage to detect Shared Contacts
     - Fix added to GetMessage to search for the folderid if not supplied
     - Added handling of new *SyncConfig* directive "sendasname" to override the
       name retrieved from zimbra (see below for details)
     - Removed hard limit of 1MB from Fetch function
     - Added instructions for selected user debugging with ZIMBRA_DEBUG flag
     - Added function ItemOperationsEmptyFolderContent for as12.1 branch to 
       enable 'Empty server trash' command from the device 
     - Added function ResolveRecipients for as12.1 branch
     - Updated Search function to allow for a subset of search parameters being 
       sent over from the device for as12.1 branch
    
    In addition - for z-push-2 alpha - the following additional changes have been made
     - First port of backend to z-push-2 architecture
     - Added _deviceAgent, and changed code to work with _deviceAgent instead of 
       $GLOBALS['useragent'] for z-push-2
     - Moved Search functions into a separate class for z-push-2
     - Added function GetGALSearchResults for z-push-2

  3. #783
    aarat is offline Active Member
    Join Date
    Aug 2011
    Posts
    32
    Rep Power
    3

    Default

    Ipxx devices are not able to sync with z-push. When investigated we found this logs on debug.txt

    START GetMessage { fid = f2; id = 161502; truncsize = 512; bodypreference = ; mimesupport = 0 }
    02/22/12 10:32:39 [12588] [<email>] /var/www/html/z-push/backend/zimbra.php:3793 Undefined variable: compPeakRealMemory (8)
    02/22/12 10:32:39 [12588] [<email>] MEMORY - REAL Now (5,737,040) Peak [] - ALLOCATED Now (5,737,040) Peak [] - GetMessage START
    Ipxx devices getting this error

    Can not get mail

    The connection to server failed.
    PS : this only happens with mails in inbox. When we are going to other folders we are able to see mails.
    Zimbra Version 8.0.1_G.A._5438 (build 20121105164416) running on ubuntu 10.04 x64

  4. #784
    bofh is offline Elite Member
    Join Date
    May 2010
    Posts
    272
    Rep Power
    5

    Default

    Btw:: just for the Record.

    I read bevore that you should not change versions on all phones same time if you got many users because they have to sync at the same time all the data again

    am i dissagree here -
    first switching one by one with many phones - thats really horrible

    Second what load? i mean as long your webserver is something better than a 286 8mhz you should be fine
    calculate

    even very big phonebooks never ever reach 200k - so lets say we got 200k phonebook, 200k calendar, 200k tasklist, 200k mails

    lets say 1 meg each user - if you got lets say 1000 user you would have to sync 1 gig same time - thats nothing
    with a normal not even very fast webserver the sync will be over within seconds (depending on the phones bandwith)

    of course in reality data would be much smaller and also not all phones sync the same time - if you do it in the night only those turned on with running network will


    so i dont think that would be an issue
    but manually remove the old exchange and replace with the new excahnge - man that is



    @liverpool - so it is possible to upgrade without reconfigure the phones and without double sync of any data?

  5. #785
    gtr33m is offline Loyal Member
    Join Date
    May 2008
    Location
    Melbourne, Australia
    Posts
    96
    Rep Power
    7

    Default

    I'm happy to be the guinea pig here. I'll give it a go tomorrow and report the results. If it works, It should be fairly easy to script something to accomplish it.

    Mark
    Mark Hawkins

    Medalist

  6. #786
    liverpoolfcfan's Avatar
    liverpoolfcfan is offline Outstanding Member
    Join Date
    Oct 2009
    Location
    Dublin, IRELAND
    Posts
    710
    Rep Power
    6

    Default

    Quote Originally Posted by aarat View Post
    Ipxx devices are not able to sync with z-push. When investigated we found this logs on debug.txt

    Ipxx devices getting this error

    PS : this only happens with mails in inbox. When we are going to other folders we are able to see mails.
    I have no idea what version of the backend you are talking about so it is hard to start helping you.

    In any case, please open a Tracker-Support Request incident on the sourceforge web page as it is a better mechanism for support. Thanks.

    Go here SourceForge.net: Z-Push Zimbra Backend - Support then click on "Support Requests" - then on that page, Click on "Add new"

  7. #787
    aarat is offline Active Member
    Join Date
    Aug 2011
    Posts
    32
    Rep Power
    3

    Default

    Quote Originally Posted by liverpoolfcfan View Post
    I have no idea what version of the backend you are talking about so it is hard to start helping you.

    In any case, please open a Tracker-Support Request incident on the sourceforge web page as it is a better mechanism for support. Thanks.

    Go here SourceForge.net: Z-Push Zimbra Backend - Support then click on "Support Requests" - then on that page, Click on "Add new"
    I have opened support ticket..

    Below is the details for backend version.

    File : zimbra.php
    * Revision : 51 (12-Sep-2011)
    Zimbra Version 8.0.1_G.A._5438 (build 20121105164416) running on ubuntu 10.04 x64

  8. #788
    glennbtn is offline Loyal Member
    Join Date
    Dec 2009
    Location
    Worthing. UK
    Posts
    95
    Rep Power
    5

    Default

    I have an issue since implementing the latest svn last week.

    I had html email working fine on iphones & ipads but the attachments did not work. Installed the lasted thursday or friday last week. This fixed the issue with the forwarding attachments but has now stopped the html email working again.

    Any ideas anyone?

  9. #789
    liverpoolfcfan's Avatar
    liverpoolfcfan is offline Outstanding Member
    Join Date
    Oct 2009
    Location
    Dublin, IRELAND
    Posts
    710
    Rep Power
    6

    Default

    General comment for reporting issues

    Please use exact version numbers - not "latest SVN" as that will obviously keep changing. Every version (including SVN check-ins) version stamps your log files and has the version at the top of the zimbra.php file.

    And if possible please post Support Requests on the Tracket on the SourceForge web site, rather than here, as it is easier to manage replies back and forward in threads there.

    Quote Originally Posted by glennbtn View Post
    I had html email working fine on iphones & ipads but the attachments did not work. Installed the lasted thursday or friday last week. This fixed the issue with the forwarding attachments but has now stopped the html email working again.
    What version did you come from ?

    Can you install release 52 and verify you still have the problem.

    Check your config file to make sure you have ZIMBRA_HTML defined and set to true - enforcement of thhis flag only came in 51.1 I think.

    I have tested all along with an iOS5 iPhone and HTML is working fine here.

    I even cleared the account from the device 2 days ago when Release 52 was put out and recreated it from scratch. Everything is as I would expect.

  10. #790
    mangue is offline Junior Member
    Join Date
    May 2010
    Location
    France
    Posts
    6
    Rep Power
    5

    Default

    I upgraded my previous installation to z-push 1.5.7 et backend 52. I set the HTML flag to TRUE. Mails are not displayed using HTML on Windows Phone 7.5, iOS 3, iOS4 and iOS5. I tried to remove a profil then create it from scratch. The issue is the same: HTML tag are sent to the device but displayed as text message.
    Any idea? Thank you for your help.

Page 79 of 106 FirstFirst ... 2969777879808189 ... LastLast

Thread Information

Users Browsing this Thread

There are currently 1 users browsing this thread. (0 members and 1 guests)

Similar Threads

  1. z-push and zimbra backend problem
    By ben1967 in forum Mobility
    Replies: 9
    Last Post: 11-14-2012, 11:29 PM
  2. z-push and zimbra backend problem
    By ben1967 in forum Administrators
    Replies: 0
    Last Post: 11-11-2012, 02:11 PM
  3. [SOLVED] Z-push Zimbra backend workaround
    By Inchoate in forum Mobility
    Replies: 6
    Last Post: 01-19-2012, 04:22 AM
  4. [SOLVED] Z-push Zimbra backend workaround
    By Inchoate in forum Administrators
    Replies: 0
    Last Post: 10-31-2010, 07:06 AM
  5. Replies: 348
    Last Post: 10-11-2010, 05:39 AM

Posting Permissions

  • You may not post new threads
  • You may not post replies
  • You may not post attachments
  • You may not edit your posts
  •