Page 71 of 105 FirstFirst ... 2161697071727381 ... LastLast
Results 701 to 710 of 1048

Thread: Z-Push Zimbra Backend (Push Email, Contacts, Appointments & Tasks)

  1. #701
    liverpoolfcfan's Avatar
    liverpoolfcfan is online now Outstanding Member
    Join Date
    Oct 2009
    Location
    Dublin, IRELAND
    Posts
    698
    Rep Power
    6

    Default

    Quote Originally Posted by drdre View Post
    Liver i hate to bother you more..

    All my folders except 1 will sync. I have started over the process.., and set my sync for 2 weeks... All boxes but my sent items sync, even thou i have "Keep copies of sent items in sent folder" and i have my sent folder to sync..

    any ideas y ? There are no errors in the log nor the access folder..

    again i do apologize for bugging you.,
    Are you sure you have actually selected "sync" for that folder ?

    The "Sent Items" folder already has a little picture on it's icon prior to requesting for it to be synced (an envelope with a blue arrow). When you select sync it turns into a green sync icon.

    EDIT: Actually there is one other possibility. The function GetFolder matches up special folders by their name. If you have somehow changed the name of the sent folder to be something other than "Sent" or "sent" then it would not get matched.
    Code:
            } else if (strtolower($this->_folders[$index]->name) == 'sent' && $this->_folders[$index]->external == 0) {
                $folder->parentid = '0';
                $folder->displayname = 'Sent';
                $folder->type = SYNC_FOLDER_TYPE_SENTMAIL;
    Last edited by liverpoolfcfan; 11-29-2011 at 10:06 AM.

  2. #702
    carlsan is offline Intermediate Member
    Join Date
    Mar 2010
    Posts
    20
    Rep Power
    5

    Default Problems sending attachments with iphone

    Sorry, but it seems as I have problems sending attachments with my iphone (ios5.0.1 and version 51 of zimbra.php). I thought the problem could be similar to this one:
    SourceForge.net: Z-Push Zimbra Backend: Detail: 3430530 - Conformation of my Troubles.

    So I tried some other versions like 51.4 but it doesn't help.

    I uncomment
    Code:
    //debugLog( 'RFC822: '. $rfc822 );
    as you described and I get the following:

    12/01/11 22:48:08 [25561] [me] START SendMail { rfc822 = (excluded); forward = ; reply = ; parent = }
    12/01/11 22:48:08 [25561] [me] RFC822: Subject: Test1
    From: me@me.de
    Content-Type: multipart/mixed;
    boundary=Apple-Mail-A2BE6456-B781-448D-A6D0-8067A049D594
    Message-Id: <B8BDF308-F73B-4466-B1C7-D73D863C7D57@me.de>
    Date: Thu, 1 Dec 2011 22:47:57 +0100
    To: me@me.de
    Content-Transfer-Encoding: 7bit
    Mime-Version: 1.0 (1.0)


    --Apple-Mail-A2BE6456-B781-448D-A6D0-8067A049D594
    Content-Transfer-Encoding: 7bit
    Content-Type: text/plain;
    charset=us-ascii




    --Apple-Mail-A2BE6456-B781-448D-A6D0-8067A049D594
    Content-Disposition: inline;
    filename=Foto.JPG
    Content-Type: image/jpeg;
    name=Foto.JPG
    Content-Transfer-Encoding: base64

    /9j/4Q/+RXhpZgAATU0AKgAAAAgACgEPAAIAAAAGAAAAhgEQAAIAAAAJA AAAjAESAAMAAAABAAYA
    AAEaAAUAAAABAAAAlgEbAAUAAAABAAAAngEoAAMAAAABAAIA
    [...]
    Is there anything I can try next? Thanks a lot!

  3. #703
    liverpoolfcfan's Avatar
    liverpoolfcfan is online now Outstanding Member
    Join Date
    Oct 2009
    Location
    Dublin, IRELAND
    Posts
    698
    Rep Power
    6

    Default

    Quote Originally Posted by carlsan View Post
    Sorry, but it seems as I have problems sending attachments with my iphone (ios5.0.1 and version 51 of zimbra.php).
    I have managed to reproduce this issue. I will take a look at it.

  4. #704
    drdre is offline Elite Member
    Join Date
    Aug 2007
    Location
    Trinidad
    Posts
    410
    Rep Power
    7

    Default

    Liver.. how can i set it up so i can sync the "Sent Items".. and all other possible wording for Sent ?
    With Jah Jah
    Anything is Possible

    FOSS 8.0.3

  5. #705
    liverpoolfcfan's Avatar
    liverpoolfcfan is online now Outstanding Member
    Join Date
    Oct 2009
    Location
    Dublin, IRELAND
    Posts
    698
    Rep Power
    6

    Default

    Quote Originally Posted by drdre View Post
    Liver.. how can i set it up so i can sync the "Sent Items".. and all other possible wording for Sent ?
    I don't think zimbra allows you to rename your sent folder - so why would you want to change it ?

    Each phone can have a different name on the "Sent" folder in it's mail client. But, that does not matter. As long as zimbra identifies the folder that it is using as the "sent" folder - the phone should sync it's folder with that.

    Can you explain exactly what customizations you have made, if any, that would necessitate a change.

  6. #706
    drdre is offline Elite Member
    Join Date
    Aug 2007
    Location
    Trinidad
    Posts
    410
    Rep Power
    7

    Default

    i havent made any changes what so ever as yet..

    just that it doesnt sync my sent folder at all.. with my windows mobile phone.
    With Jah Jah
    Anything is Possible

    FOSS 8.0.3

  7. #707
    carlsan is offline Intermediate Member
    Join Date
    Mar 2010
    Posts
    20
    Rep Power
    5

    Default

    Quote Originally Posted by drdre View Post
    just that it doesnt sync my sent folder at all.. with my windows mobile phone.
    Hey drdre,

    let me suspect you have multiple sent folders, e.g. folders named like 2008, 2009, 2010,... and within each folder you have a sent folder (exactly spelled like this "sent").
    That is exactly what I had and it was not possible to sync the real sent folder (the one with the symbol).
    Solution: I renamed all sent folders in my archive folders :-)

    It is only a presumption!

  8. #708
    jimorin is offline Intermediate Member
    Join Date
    Jun 2011
    Posts
    15
    Rep Power
    3

    Default

    Hello all,

    I'm trying z-push with zimbra backend on a test server.

    Test server is Centos 5.7 with apache and php

    I downloaded z-push version 1.5.5-790 and zimbra backend 51

    z-push is extracted to /var/www/html/z-push
    zimbra backend is extracted to /var/www/html/z-push/backend

    I set the following permissions for z-push and the zimbra backend
    Code:
    chown -R root:apache /var/www/html/z-push
    chmod 777 /var/www/html/z-push/state
    I added the configuration to /etc/httpd/conf/httpd.conf
    Code:
    Alias /Microsoft-Server-ActiveSync /var/www/html/z-push/index.php
    php_flag magic_quotes_gpc off
    php_flag register_globals off
    php_flag magic_quotes_runtime off
    php_flag short_open_tag on
    I added the config to /var/www/html/z-push/config.php
    PHP Code:
    define('PROVISIONING'false);
    $BACKEND_PROVIDER "BackendZimbra";

    define('ZIMBRA_DEBUG',true);
    define('ZIMBRA_URL''http://mysserveraddress.com');
    define('ZIMBRA_USER_DIR''zimbra');
    define('ZIMBRA_SYNC_CONTACT_PICTURES'true);
    define('ZIMBRA_VIRTUAL_CONTACTS',true);
    define('ZIMBRA_VIRTUAL_APPOINTMENTS',true);
    define('ZIMBRA_VIRTUAL_TASKS',true);
    define('ZIMBRA_IGNORE_EMAILED_CONTACTS',true);
    define('ZIMBRA_HTML',false); 
    and put in comment in config.php all the lines for the others backend


    I don't have a valid cert on the test server but I'm not using ssl.

    I had to add z_RTF.php from the as12 branch to clear an error in debug.txt


    When I test it in firefox, the browser ask for a valid user name and password.
    I enter a valid user name and password and I get the message "GET not supported" as expected.

    So I set the config in an iPhone.
    Mail don't sync and most of the time I get an authentification failed error.
    In contacts i get the message "The search failed".


    I don't have errors in apache error_log and in the access_log I see the following:
    HTML Code:
    10.200.30.231 - USER [09/Dec/2011:14:13:14 -0500] "OPTIONS /Microsoft-Server-ActiveSync HTTP/1.1" 200 224033 "-" "Apple-iPhone3C1/807.4"
    10.200.30.231 - USER [09/Dec/2011:14:13:15 -0500] "POST /Microsoft-Server-ActiveSync?User=USER&DeviceId=Appl69114TLLA4S&DeviceType=iPhone&Cmd=FolderSync HTTP/1.1" 200 224132 "-" "Apple-iPhone3C1/807.4"
    The only thing so far i can see that look like an error is in the debug.txt file.
    HTML Code:
    12/09/11 13:32:28 [4192] [USER] /var/www/html/z-push/backend/zimbra.php:609 Undefined index: soap:Envelope (8)
    12/09/11 13:32:28 [4192] [USER] /var/www/html/z-push/backend/zimbra.php:611 Undefined index: soap:Envelope (8)
    12/09/11 13:32:28 [4192] [USER] /var/www/html/z-push/backend/zimbra.php:635 Undefined index: soap:Envelope (8)
    12/09/11 13:32:28 [4192] [USER] /var/www/html/z-push/backend/zimbra.php:651 Undefined index: soap:Envelope (8)
    12/09/11 13:32:28 [4192] [USER] /var/www/html/z-push/backend/zimbra.php:654 Undefined index: soap:Envelope (8)
    12/09/11 13:32:28 [4192] [USER] /var/www/html/z-push/backend/zimbra.php:672 Undefined index: soap:Envelope (8)

    Any tips?

  9. #709
    undertoe is offline Loyal Member
    Join Date
    Jun 2006
    Posts
    86
    Rep Power
    8

    Default

    Two things verify that you have the state directory chmod to writable by your webserver and see if it created a file for your apple device.

    Secondly your iphone settings don;t have ssl enabled for the exchange settings do they?
    otel consulting, inc.
    www.otelconsulting.com | facebook | twitter

  10. #710
    liverpoolfcfan's Avatar
    liverpoolfcfan is online now Outstanding Member
    Join Date
    Oct 2009
    Location
    Dublin, IRELAND
    Posts
    698
    Rep Power
    6

    Default

    Also, make sure you have php-curl and php-mbstring installed. As far as I recall CentOS doesn't install them by default.

    yum install php-curl
    yum install php-mbstring

Page 71 of 105 FirstFirst ... 2161697071727381 ... LastLast

Thread Information

Users Browsing this Thread

There are currently 2 users browsing this thread. (0 members and 2 guests)

Similar Threads

  1. fatal: parameter "smtpd_recipient_restrictions"
    By Robin in forum Administrators
    Replies: 8
    Last Post: 12-22-2010, 05:48 AM
  2. Replies: 12
    Last Post: 02-25-2008, 07:28 PM
  3. /tmp filling
    By Nutz in forum Administrators
    Replies: 8
    Last Post: 02-22-2008, 02:00 AM
  4. Replies: 22
    Last Post: 12-02-2007, 05:05 PM
  5. zmtlsctl give LDAP error
    By sourcehound in forum Administrators
    Replies: 5
    Last Post: 03-11-2007, 03:48 PM

Posting Permissions

  • You may not post new threads
  • You may not post replies
  • You may not post attachments
  • You may not edit your posts
  •