Page 64 of 106 FirstFirst ... 1454626364656674 ... LastLast
Results 631 to 640 of 1054

Thread: Z-Push Zimbra Backend (Push Email, Contacts, Appointments & Tasks)

  1. #631
    Stuart's Avatar
    Stuart is offline Member
    Join Date
    Mar 2007
    Posts
    14
    Rep Power
    8

    Default

    if you haven't got a commercial certificate for the webserver you have to select "Accept all certificates" when defining the connection on the phone.

  2. #632
    aarat is offline Active Member
    Join Date
    Aug 2011
    Posts
    32
    Rep Power
    3

    Default

    I am not using ssl to connect. Also It stucks on invalid user name and password

    I can see below error in debug.txt
    /var/www/html/z-push/backend/zimbra.php:446 include_once(z_RTF.php) [<a href='function.include-once'>function.include-once</a>]: failed to open stream: No such file or directory (2)
    /var/www/html/z-push/backend/zimbra.php:446 include_once() [<a href='function.include'>function.include</a>]: Failed opening 'z_RTF.php' for inclusion (include_path='/var/www/html/z-push/include/:/var/www/html/z-push/:.:/usr/share/pear:/usr/share/php:/usr/share/php/:/usr/share/php5/:/usr/share/pear/') (2)
    when opened from web browser on my laptop

  3. #633
    liverpoolfcfan's Avatar
    liverpoolfcfan is offline Outstanding Member
    Join Date
    Oct 2009
    Location
    Dublin, IRELAND
    Posts
    712
    Rep Power
    6

    Default

    Quote Originally Posted by aarat View Post
    No,

    I am not getting the authentication prompt in my computer's browser.

    Here are the logs

    23/09/2011 15:22:31 [ 2985] [ INFO] Version='z-push-2.0alpha2-777' method='GET' from='<IP>' cmd='' getUser='' devId='' devType=''
    The zimbra backend will not work with the new z-push-2 branch at this time.

    I have begun looking at the port - but it will take some time.

    Please use a Z-Push Release 1.5.x version (or the Z-Push SVN as12.1 branch with the zimbra as12.1 branch)

  4. #634
    aarat is offline Active Member
    Join Date
    Aug 2011
    Posts
    32
    Rep Power
    3

    Default

    Quote Originally Posted by liverpoolfcfan View Post
    The zimbra backend will not work with the new z-push-2 branch at this time.

    I have begun looking at the port - but it will take some time.

    Please use a Z-Push Release 1.5.x version (or the Z-Push SVN as12.1 branch with the zimbra as12.1 branch)

    I reverted back to 1.5.5 the issue is with android,windows mobile and iphone only. They are giving invalid authentication error.

    When opened from my laptop I am getting these text in debug.txt

    /var/www/html/z-push/backend/zimbra.php:446 include_once(z_RTF.php) [<a href='function.include-once'>function.include-once</a>]: failed to open stream: No such file or directory (2)
    /var/www/html/z-push/backend/zimbra.php:446 include_once() [<a href='function.include'>function.include</a>]: Failed opening 'z_RTF.php' for inclusion (include_path='/var/www/html/z-push/include/:/var/www/html/z-push/:.:/usr/share/pear:/usr/share/php:/usr/share/php/:/usr/share/php5/:/usr/share/pear/') (2)


  5. #635
    liverpoolfcfan's Avatar
    liverpoolfcfan is offline Outstanding Member
    Join Date
    Oct 2009
    Location
    Dublin, IRELAND
    Posts
    712
    Rep Power
    6

    Default

    For the authorization, have you added the 4 php directives to your php.ini or .htaccess file?

    As regards the missing include file, please read the configuration notes at the top of the zimbra.php file

  6. #636
    aarat is offline Active Member
    Join Date
    Aug 2011
    Posts
    32
    Rep Power
    3

    Default Error

    Quote Originally Posted by liverpoolfcfan View Post
    For the authorization, have you added the 4 php directives to your php.ini or .htaccess file?

    As regards the missing include file, please read the configuration notes at the top of the zimbra.php file
    Issue is resolved I mistyped z-rtf file. (rtf instead of RTF).

    Still I am not able to login with windows mobile and Android. When connected with android I can see soap requests coming in but still I am not able to add account.

    however with windows mobile 6.5 I am not getting soap requests too..

    Logs and screenshot attached herewith
    Attached Images Attached Images
    Attached Files Attached Files

  7. #637
    liverpoolfcfan's Avatar
    liverpoolfcfan is offline Outstanding Member
    Join Date
    Oct 2009
    Location
    Dublin, IRELAND
    Posts
    712
    Rep Power
    6

    Default

    Quote Originally Posted by aarat View Post
    Issue is resolved I mistyped z-rtf file. (rtf instead of RTF).

    Still I am not able to login with windows mobile and Android. When connected with android I can see soap requests coming in but still I am not able to add account.

    however with windows mobile 6.5 I am not getting soap requests too..

    Logs and screenshot attached herewith
    Do you have a commercial SSL certificate ? If you do not, Android and Apple will allow you to continue, but Windows Mobile and Nokia will not do so - unless you pre-install the self-signed certificate on your Windows Mobile device in the Trusted Root Certificate store.

    Can you please specify what zimbra version you are using, what web server you are using for z-push and what operating system, and if it is on the same server as zimbra or a different one.

  8. #638
    aarat is offline Active Member
    Join Date
    Aug 2011
    Posts
    32
    Rep Power
    3

    Default

    I don't have a commercial certificate. Also I am not using ssl to connect.

    Zimbra Version: Release 7.1.2_GA_3268.UBUNTU10_64 UBUNTU10_64 FOSS edition.

    Zimbra and Webserver are running on two different physical server.

    Server version: Apache/2.2.3
    Server built: Aug 31 2011 20:22:40

    Webserver is running on:
    centos 5 (Linux version 2.6.18-274.el5 (mockbuild@builder10.centos.org) (gcc version 4.1.2 20080704 (Red Hat 4.1.2-50)) #1 SMP Fri Jul 22 04:49:12 EDT 2011)

  9. #639
    liverpoolfcfan's Avatar
    liverpoolfcfan is offline Outstanding Member
    Join Date
    Oct 2009
    Location
    Dublin, IRELAND
    Posts
    712
    Rep Power
    6

    Default

    Quote Originally Posted by aarat View Post
    I don't have a commercial certificate. Also I am not using ssl to connect.
    OK. That explains why you cannot connect with Windows Mobile. Windows Mobile will only connect over SSL (and only on port 443).

    For the android phone - are you getting any errors in your web server log files ? (/var/log/httpd/ folder usually)

    Look for a PM from me.

  10. #640
    liverpoolfcfan's Avatar
    liverpoolfcfan is offline Outstanding Member
    Join Date
    Oct 2009
    Location
    Dublin, IRELAND
    Posts
    712
    Rep Power
    6

    Default

    Quote Originally Posted by aarat View Post
    When connected with android I can see soap requests coming in but still I am not able to add account.
    The problem was identified as an incorrect Alias directive.

    Alias was configured as
    Code:
    Alias  /Microsoft-Server-ActiveSync    /....../z-push/
    which would allow the browser page to work - but it would never allow anything beyond that to work.

    Alias was corrected to
    Code:
    Alias  /Microsoft-Server-ActiveSync    /....../z-push/index.php
    index.php has to be on the end of the alias directive for the backend processing to work.

Page 64 of 106 FirstFirst ... 1454626364656674 ... LastLast

Thread Information

Users Browsing this Thread

There are currently 2 users browsing this thread. (0 members and 2 guests)

Similar Threads

  1. z-push and zimbra backend problem
    By ben1967 in forum Mobility
    Replies: 9
    Last Post: 11-14-2012, 11:29 PM
  2. z-push and zimbra backend problem
    By ben1967 in forum Administrators
    Replies: 0
    Last Post: 11-11-2012, 02:11 PM
  3. [SOLVED] Z-push Zimbra backend workaround
    By Inchoate in forum Mobility
    Replies: 6
    Last Post: 01-19-2012, 04:22 AM
  4. [SOLVED] Z-push Zimbra backend workaround
    By Inchoate in forum Administrators
    Replies: 0
    Last Post: 10-31-2010, 07:06 AM
  5. Replies: 348
    Last Post: 10-11-2010, 05:39 AM

Posting Permissions

  • You may not post new threads
  • You may not post replies
  • You may not post attachments
  • You may not edit your posts
  •