Page 63 of 106 FirstFirst ... 1353616263646573 ... LastLast
Results 621 to 630 of 1052

Thread: Z-Push Zimbra Backend (Push Email, Contacts, Appointments & Tasks)

  1. #621
    aarat is offline Active Member
    Join Date
    Aug 2011
    Posts
    32
    Rep Power
    3

    Default Setup Instructions

    Hello,

    I am new to zimbra... Is there anything like setup instructions step by step to configure zimbra backend??

  2. #622
    tja
    tja is offline Member
    Join Date
    Mar 2007
    Posts
    10
    Rep Power
    8

    Default

    Quote Originally Posted by bofh View Post
    regarding android sync we discovered a LOOOT of glitches there today
    we where able to test with
    2.2.1 / 2.2.2 /2.3.4 / 2.3.3 / 3.0 / 3.1
    devices where phones and tablets (most samsung devices and one acer)

    turns out that every dam firmware behaves differently
    even we got now some very strange errors on tablet (while phones wokred very fine)
    the error was only for email sync
    something like "security error - and he cant connect to the server" so no new mails where synced while contacts and calendar running fine

    even worse on the most actual android version you can jsut sync calendar and or contacts without mail - mail is always in
    which is a problem on tablets -

    theres absolute no sufficent mail application for tablets except built in but that one always syncs then - so the option no mailsync BUT imap isnt one

    alternative is forget active sync - use caldav and cardav and imap - which is a way better idea for many reasons - most important you can determine which shared calendar you wanna use

    downside - no real caldav client yet for bidirectional sync
    so situation is kinda messy

    just to be clear this ISNT THE FAULT of z-push or zimbra backend or Zimbra

    you will have those issues with
    zimbra netwokr edition
    zimbra foss with zpush or funambol
    exchange no matter which version

    this is a problem of the active sync implementation of android reported hundred of times on different systems all over the web

    and it looks its different on phones and tablets even on the same android version different cause of manufacturers modifed roms
    just my 2c into the pot:
    ive been using zpush and the backend for some time now with a couple of devices and different firmwares.

    my finding is that especially the original samsung roms (2.1/2.2/2.3.x on the SGS and 2.2/2.3.x on the P1000 tab) made much trouble (faulty contact and no calendar syncing, forced pings every 30 seconds).

    i had no problem with z-push/zimbra backend using
    • cyanogenmod 7.x on the SGS
    • cyanogenmod 7.x on the ZTE Blade
    • the original google fw on the nexus-s (hw made by samsung, fw plain vanilla google)
    • the original acer fw on the A500 (3.1.x) and the A100 (3.2.x)

    my guess is that samsung (and maybe HTC, LG ... too) used or is using a private activesync implementation, possibly because pre 2.1 (IIRC) there was no official activeSync in the google code. maybe they stayed at that private implementation even till 2.3.x - the problems with my P1000 seems to suggest that.
    sure cyano with the original google codebase has no such problems.

    my hope (backed by the non-faulty acer honeycomb tablets) is that the companies will stop using private sh*t and will use the google activeSync implementation in the future (icecream sandwich anyone) so that at least any bugs could be worked around in a common fashion.

    for problematic old devices i suggest trying and migrating to cyanogen or similar if possible, even if you have to do a planned roll out.

    sure z-push and the zimbra backend is not to blame here, maybe its time for some device/fw db, dunno if z-push already has something.

    goin cal/carddav is no option for me as the requirements (additional apps+config overhead) is multiplying error sources - and activeSync can work fine as seen on at least some devices.

    conclusion:
    after some fiddeling im quiet happy with z-push/zimbra backend and i want to thank for all the efforts of liverpool and the z-push makers.

    wbr,tja...

  3. #623
    aarat is offline Active Member
    Join Date
    Aug 2011
    Posts
    32
    Rep Power
    3

    Default Android Desire HD Authentication failed

    Quote Originally Posted by aarat View Post
    Hello,

    I am new to zimbra... Is there anything like setup instructions step by step to configure zimbra backend??

    Somehow I have manged to run the z-push and configured the Zimbra Backend.

    Trying to use desire hd and getting Authentication failed error. Below are the logs

    Nothing reflected on z-push logs.

    Error Logs:
    Apache Access Logs:

    [23/Sep/2011:12:57:12 +0530] "OPTIONS /Microsoft-Server-ActiveSync?User=sysadmin.it&DeviceId=3568120472131 27&DeviceType=htcace HTTP/1.1" 301 411 "-" "Android-EAS/4.0.2116123015.76346"
    [23/Sep/2011:12:59:30 +0530] "OPTIONS /Microsoft-Server-ActiveSync?User=sysadmin.it&DeviceId=HTCb2f0c2c6d3 28ee8f42220f7d377ba&DeviceType=htcmarvel HTTP/1.1" 301 431 "-" "Android-EAS/3.1.2114233164.44544"
    Please help

  4. #624
    Stuart's Avatar
    Stuart is offline Member
    Join Date
    Mar 2007
    Posts
    14
    Rep Power
    8

    Default

    If your using provisioning check there is no warning in the status bar on the handset, my phone would background the security accept screen (the second one) and would show up authentication error until the warning had been accepted...is there anything else in the Apache error log?

  5. #625
    aarat is offline Active Member
    Join Date
    Aug 2011
    Posts
    32
    Rep Power
    3

    Default

    No. I am not using provisioning check. Also I tried with iphone and a windows mobile too. For android i am getting apache logs for iphone and windows mobile i am not getting any logs in apache access logs too....

  6. #626
    Stuart's Avatar
    Stuart is offline Member
    Join Date
    Mar 2007
    Posts
    14
    Rep Power
    8

    Default

    What happens when you open up the URL https://<your server>/Microsoft-Server-ActiveSync in your browser? Do you get the Authentication window? Can you authenticate there?

  7. #627
    aarat is offline Active Member
    Join Date
    Aug 2011
    Posts
    32
    Rep Power
    3

    Default

    No,

    I am not getting the authentication prompt in my computer's browser.

    Here are the logs

    Z-push.log

    23/09/2011 15:22:31 [ 2985] [ INFO] Version='z-push-2.0alpha2-777' method='GET' from='<IP>' cmd='' getUser='' devId='' devType=''
    23/09/2011 15:22:31 [ 2985] [DEBUG] Used timezone 'Asia/Calcutta'
    23/09/2011 15:22:31 [ 2985] [DEBUG] Including backend file: '/var/www/html/z-push/backend/zimbra.php'
    23/09/2011 15:22:31 [ 2985] [ WARN] /var/www/html/z-push/backend/zimbra.php:441 include_once(diffbackend.php) [<a href='function.include-once'>function.include-once</a>]: failed to open stream: No such file or directory (2)
    23/09/2011 15:22:31 [ 2985] [ WARN] /var/www/html/z-push/backend/zimbra.php:441 include_once() [<a href='function.include'>function.include</a>]: Failed opening 'diffbackend.php' for inclusion (include_path='.:/usr/share/pear:/usr/share/php') (2)
    23/09/2011 15:22:31 [ 2985] [ WARN] /var/www/html/z-push/backend/zimbra.php:442 include_once(mimeDecode.php) [<a href='function.include-once'>function.include-once</a>]: failed to open stream: No such file or directory (2)
    23/09/2011 15:22:31 [ 2985] [ WARN] /var/www/html/z-push/backend/zimbra.php:442 include_once() [<a href='function.include'>function.include</a>]: Failed opening 'mimeDecode.php' for inclusion (include_path='.:/usr/share/pear:/usr/share/php') (2)
    23/09/2011 15:22:31 [ 2985] [ WARN] /var/www/html/z-push/backend/zimbra.php:443 require_once(z_RFC822.php) [<a href='function.require-once'>function.require-once</a>]: failed to open stream: No such file or directory (2)


    Apache Access Logs

    [23/Sep/2011:15:22:31 +0530] "GET /Microsoft-Server-ActiveSync/ HTTP/1.1" 200 - "-" "Mozilla/4.0 (compatible; MSIE 7.0; Windows NT 6.1; Trident/4.0; SLCC2; .NET CLR 2.0.50727; .NET CLR 3.5.30729; .NET CLR 3.0.30729; Media Center PC 6.0)"




  8. #628
    aarat is offline Active Member
    Join Date
    Aug 2011
    Posts
    32
    Rep Power
    3

    Default

    Downgraded the version of z-push and now i am able to open the url from browser but same issue with android,iphone and windows mobile.

  9. #629
    Stuart's Avatar
    Stuart is offline Member
    Join Date
    Mar 2007
    Posts
    14
    Rep Power
    8

    Default

    Z-push.log

    23/09/2011 15:22:31 [ 2985] [ INFO] Version='z-push-2.0alpha2-777' method='GET' from='<IP>' cmd='' getUser='' devId='' devType=''
    23/09/2011 15:22:31 [ 2985] [DEBUG] Used timezone 'Asia/Calcutta'
    23/09/2011 15:22:31 [ 2985] [DEBUG] Including backend file: '/var/www/html/z-push/backend/zimbra.php'
    23/09/2011 15:22:31 [ 2985] [ WARN] /var/www/html/z-push/backend/zimbra.php:441 include_once(diffbackend.php) [<a href='function.include-once'>function.include-once</a>]: failed to open stream: No such file or directory (2)
    23/09/2011 15:22:31 [ 2985] [ WARN] /var/www/html/z-push/backend/zimbra.php:441 include_once() [<a href='function.include'>function.include</a>]: Failed opening 'diffbackend.php' for inclusion (include_path='.:/usr/share/pear:/usr/share/php') (2)
    23/09/2011 15:22:31 [ 2985] [ WARN] /var/www/html/z-push/backend/zimbra.php:442 include_once(mimeDecode.php) [<a href='function.include-once'>function.include-once</a>]: failed to open stream: No such file or directory (2)
    23/09/2011 15:22:31 [ 2985] [ WARN] /var/www/html/z-push/backend/zimbra.php:442 include_once() [<a href='function.include'>function.include</a>]: Failed opening 'mimeDecode.php' for inclusion (include_path='.:/usr/share/pear:/usr/share/php') (2)
    23/09/2011 15:22:31 [ 2985] [ WARN] /var/www/html/z-push/backend/zimbra.php:443 require_once(z_RFC822.php) [<a href='function.require-once'>function.require-once</a>]: failed to open stream: No such file or directory (2)
    looks like its not finding your includes directory which is usually /var/www/html/z-push/include check config.php for the include paths...or the diffbackend.php which is in /var/ww/html/z-push/backend. Perhaps its a permissions thing, check all files are readable by your apache server user.

  10. #630
    aarat is offline Active Member
    Join Date
    Aug 2011
    Posts
    32
    Rep Power
    3

    Default

    Quote Originally Posted by Stuart View Post
    looks like its not finding your includes directory which is usually /var/www/html/z-push/include check config.php for the include paths...or the diffbackend.php which is in /var/ww/html/z-push/backend. Perhaps its a permissions thing, check all files are readable by your apache server user.

    This issue is resolved by downgrading to z-push 1.5.5. Also I can see the debug.txt listing folders and proper soap requests.. Now the only issue is Mobile devices are not able to connect via active sync though I am able to open the webpage from browser.

Page 63 of 106 FirstFirst ... 1353616263646573 ... LastLast

Thread Information

Users Browsing this Thread

There are currently 1 users browsing this thread. (0 members and 1 guests)

Similar Threads

  1. z-push and zimbra backend problem
    By ben1967 in forum Mobility
    Replies: 9
    Last Post: 11-14-2012, 11:29 PM
  2. z-push and zimbra backend problem
    By ben1967 in forum Administrators
    Replies: 0
    Last Post: 11-11-2012, 02:11 PM
  3. [SOLVED] Z-push Zimbra backend workaround
    By Inchoate in forum Mobility
    Replies: 6
    Last Post: 01-19-2012, 04:22 AM
  4. [SOLVED] Z-push Zimbra backend workaround
    By Inchoate in forum Administrators
    Replies: 0
    Last Post: 10-31-2010, 07:06 AM
  5. Replies: 348
    Last Post: 10-11-2010, 05:39 AM

Posting Permissions

  • You may not post new threads
  • You may not post replies
  • You may not post attachments
  • You may not edit your posts
  •