Page 43 of 106 FirstFirst ... 3341424344455393 ... LastLast
Results 421 to 430 of 1052

Thread: Z-Push Zimbra Backend (Push Email, Contacts, Appointments & Tasks)

  1. #421
    marshall is offline Member
    Join Date
    Dec 2008
    Posts
    13
    Rep Power
    6

    Default

    Thanks for the quick reply!

    The machine in question is running gentoo with zimbra running inside a ubuntu chroot. I have php installed with soap support but I suspect there's some other missing dependencies I need to install or additional features I need to enable when installing php.

    I'm not familiar with php or soap so any pointers on how to go about verifying that stuff is working properly would be very appreciated.

  2. #422
    eleith is offline Active Member
    Join Date
    Jul 2008
    Posts
    44
    Rep Power
    7

    Default

    i've been running z-push (1.5RC) and zimbra backend (48) for a few days now and i've run into a few problems.

    1) debug.txt fills up very very quickly, even when ZIMBRA_DEBUG is false. is there another debug variable i'm missing?

    2) if i turn off messaging in the user xml, i still see entire messages passing through z-push as they appear in the debug.txt (is that normal?) it doesn't end up on the device, but i had expected it to not even make it through z-push...

    3) syncing eventually stops. i have to restart php (fcgi) and delete the very large debug.txt (this might have to do with my need to restart the processes)

    i'm going to keep fighting this and dig into the details this week, but just wanted to document my symptoms in case (liverpool) has any quick comments or suggestions.

  3. #423
    liverpoolfcfan's Avatar
    liverpoolfcfan is offline Outstanding Member
    Join Date
    Oct 2009
    Location
    Dublin, IRELAND
    Posts
    710
    Rep Power
    6

    Default

    Quote Originally Posted by marshall View Post
    Thanks for the quick reply!

    The machine in question is running gentoo with zimbra running inside a ubuntu chroot. I have php installed with soap support but I suspect there's some other missing dependencies I need to install or additional features I need to enable when installing php.

    I'm not familiar with php or soap so any pointers on how to go about verifying that stuff is working properly would be very appreciated.
    I don't see gentoo listed on the supported platforms page. Is it a clone of a different distribution ?

    I also have no experience with setting up a chroot environment. Perhaps someone else can chime in here.

    One obvious dependency you might be missing (from the text at the top of zimbra.php)
    Code:
    * PHP.ini File  :   === Replace ===
    *                   max_execution_time = 120      (Maximum execution time of each script, in seconds)
    *                   memory_limit = 128M           (Maximum amount of memory a script may consume)
    *
    * Dependencies  :   php-curl
    Another which ought to be added to the dependencies section is mentioned in the Release 47 changes
    Code:
     - Fix in GetBodyRecursive to use mb_detect_encoding() to identify the original 
       encoding of an email - prior to converting it to UTF-8 for the phone. To use
       mb_detect_encoding, the PHP extension package php-mbstring must be installed
    Start with those two, and see if they fix it.

  4. #424
    liverpoolfcfan's Avatar
    liverpoolfcfan is offline Outstanding Member
    Join Date
    Oct 2009
    Location
    Dublin, IRELAND
    Posts
    710
    Rep Power
    6

    Default

    Quote Originally Posted by eleith View Post
    i've been running z-push (1.5RC) and zimbra backend (48) for a few days now and i've run into a few problems.

    1) debug.txt fills up very very quickly, even when ZIMBRA_DEBUG is false. is there another debug variable i'm missing?
    There is a z-push debug flag that controls the logging from z-push.
    wbxml_debug in the file wbxml.php

    When true, it will log all data updates traveling between the phone and server

    2) if i turn off messaging in the user xml, i still see entire messages passing through z-push as they appear in the debug.txt (is that normal?) it doesn't end up on the device, but i had expected it to not even make it through z-push...
    Are you sure it is emails, and not notes attached to appointments ?

    3) syncing eventually stops. i have to restart php (fcgi) and delete the very large debug.txt (this might have to do with my need to restart the processes)
    I have no experience of setting up fcgi - but you could try turning off debug completely to see if that gets rid of the problem. Just rename debug.txt to debug.off

    Look for a PM from me. Send me a copy of your XML file and a sample log file so I can see what is actually generating the log messages.

  5. #425
    marshall is offline Member
    Join Date
    Dec 2008
    Posts
    13
    Rep Power
    6

    Default

    Thanks for the advice, I'll look into those two dependencies. Hopefully that will resolve this problem.

    Thanks again.

  6. #426
    marshall is offline Member
    Join Date
    Dec 2008
    Posts
    13
    Rep Power
    6

    Default

    So I wasn't ever able to figure this out.... I'm hoping someone can help point me in the right direction. As I previously stated, I'm running zimbra inside an ubuntu chroot running on top of Gentoo. I realize that's not remotely a standard configuration, but just pretend it's two machines where the gentoo machine is proxying the connection to the ubuntu machine running zimbra.

    With this setup, zimbra works perfectly. I installed z-push and set it to use the default imap backend and it works perfectly as well. Changing it to the zimbra backend doesn't work.

    Specifically, while trying to login (either from my desktop navigating to my webserver/Microsoft-Server-ActiveSync) or from my iphone results in the same output in debug.txt:

    Code:
    </Trace></Error></soap:Detail></soap:Fault></soap:Body></soap:Envelope>
    01/19/11 21:40:24 [24235] ERROR: service.PARSE_ERROR: <soap:Envelope xmlns:soap="http://www.w3.org/2003/05/soap-envelope"><soap:Body><soap:Fault><soap:Code><soap:Value>soap:Sender</soap:Value></soap:Code><soap:Reason><soap:Text>parse error: Error on line 8 of document  : The reference to entity "td" must end with the ';' delimiter. Nested exception: The reference to entity "td" must end with the ';' delimiter.</soap:Text></soap:Reason><soap:Detail><Error xmlns="urn:zimbra"><Code>service.PARSE_ERROR</Code><Trace>com.zimbra.common.service.ServiceException: parse error: Error on line 8 of document  : The reference to entity "td" must end with the ';' delimiter. Nested exception: The reference to entity "td" must end with the ';' delimiter.
    ExceptionId:btpool0-81://yourmailserver.com:8889/service/soap:1295498424611:9f5a5038cfd9fa17
    Code:service.PARSE_ERROR
            at com.zimbra.common.service.ServiceException.PARSE_ERROR(ServiceException.java:266)
            at com.zimbra.soap.SoapEngine.dispatch(SoapEngine.java:153)
            at com.zimbra.soap.SoapServlet.doWork(SoapServlet.java:291)
            at com.zimbra.soap.SoapServlet.doPost(SoapServlet.java:212)
            at javax.servlet.http.HttpServlet.service(HttpServlet.java:727)
            at com.zimbra.cs.servlet.ZimbraServlet.service(ZimbraServlet.java:181)
            at javax.servlet.http.HttpServlet.service(HttpServlet.java:820)
            at org.mortbay.jetty.servlet.ServletHolder.handle(ServletHolder.java:511)
            at org.mortbay.jetty.servlet.ServletHandler$CachedChain.doFilter(ServletHandler.java:1166)
            at com.zimbra.cs.servlet.SetHeaderFilter.doFilter(SetHeaderFilter.java:79)
            at org.mortbay.jetty.servlet.ServletHandler$CachedChain.doFilter(ServletHandler.java:1157)
            at org.mortbay.servlet.UserAgentFilter.doFilter(UserAgentFilter.java:81)
            at org.mortbay.servlet.GzipFilter.doFilter(GzipFilter.java:155)
            at org.mortbay.jetty.servlet.ServletHandler$CachedChain.doFilter(ServletHandler.java:1157)
            at org.mortbay.jetty.servlet.ServletHandler.handle(ServletHandler.java:388)
            at org.mortbay.jetty.security.SecurityHandler.handle(SecurityHandler.java:216)
            at org.mortbay.jetty.servlet.SessionHandler.handle(SessionHandler.java:182)
            at org.mortbay.jetty.handler.ContextHandler.handle(ContextHandler.java:765)
            at org.mortbay.jetty.webapp.WebAppContext.handle(WebAppContext.java:418)
            at org.mortbay.jetty.handler.ContextHandlerCollection.handle(ContextHandlerCollection.java:230)
            at org.mortbay.jetty.handler.HandlerCollection.handle(HandlerCollection.java:114)
            at org.mortbay.jetty.handler.HandlerWrapper.handle(HandlerWrapper.java:152)
            at org.mortbay.jetty.handler.rewrite.RewriteHandler.handle(RewriteHandler.java:230)
            at org.mortbay.jetty.handler.HandlerWrapper.handle(HandlerWrapper.java:152)
            at org.mortbay.jetty.handler.DebugHandler.handle(DebugHandler.java:77)
            at org.mortbay.jetty.handler.HandlerWrapper.handle(HandlerWrapper.java:152)
            at org.mortbay.jetty.Server.handle(Server.java:326)
            at org.mortbay.jetty.HttpConnection.handleRequest(HttpConnection.java:543)
            at org.mortbay.jetty.HttpConnection$RequestHandler.content(HttpConnection.java:939)
            at org.mortbay.jetty.HttpParser.parseNext(HttpParser.java:755)
            at org.mortbay.jetty.HttpParser.parseAvailable(HttpParser.java:218)
            at org.mortbay.jetty.HttpConnection.handle(HttpConnection.java:405)
            at org.mortbay.io.nio.SelectChannelEndPoint.run(SelectChannelEndPoint.java:413)
            at org.mortbay.thread.BoundedThreadPool$PoolThread.run(BoundedThreadPool.java:451)
    Caused by: org.dom4j.DocumentException: Error on line 8 of document  : The reference to entity "td" must end with the ';' delimiter. Nested exception: The reference to entity "td" must end with the ';' delimiter.
            at org.dom4j.io.SAXReader.read(SAXReader.java:350)
            at org.dom4j.io.SAXReader.read(SAXReader.java:264)
            at com.zimbra.common.soap.Element.parseXML(Element.java:415)
            at com.zimbra.common.soap.Element.parseXML(Element.java:413)
            at com.zimbra.soap.SoapEngine.dispatch(SoapEngine.java:147)
            ... 32 more
    </Trace></Error></soap:Detail></soap:Fault></soap:Body></soap:Envelope>
    01/19/11 21:40:24 [24235] END Logon { connected = false }
    01/19/11 21:40:24 [24235] Access denied: backend logon failed.
    01/19/11 21:40:24 [24235] end
    01/19/11 21:40:24 [24235] --------
    Is it possible there are some sort of XML or soap dependencies that need to be installed on the ubuntu machine for this to work right? There are scant details on required dependencies to get this installed right.

    Any help is greatly appreciated.
    Last edited by marshall; 01-25-2011 at 04:47 PM.

  7. #427
    slav is offline Starter Member
    Join Date
    Jan 2011
    Posts
    1
    Rep Power
    4

    Default Attachments not received on iphone 4

    Config:
    z-push 1.5
    zimbra backend 48
    Release 6.0.10_GA_2692.UBUNTU10_64 UBUNTU10_64 FOSS edition.


    Problem:
    Attachment is not received on the phone; however it is visible in the web client or using imap. Everything else (contacts, mail sync, etc.) is working perfect.

  8. #428
    liverpoolfcfan's Avatar
    liverpoolfcfan is offline Outstanding Member
    Join Date
    Oct 2009
    Location
    Dublin, IRELAND
    Posts
    710
    Rep Power
    6

    Default

    Quote Originally Posted by marshall View Post
    So I wasn't ever able to figure this out.... I'm hoping someone can help point me in the right direction. As I previously stated, I'm running zimbra inside an ubuntu chroot running on top of Gentoo. I realize that's not remotely a standard configuration, but just pretend it's two machines where the gentoo machine is proxying the connection to the ubuntu machine running zimbra.

    With this setup, zimbra works perfectly. I installed z-push and set it to use the default imap backend and it works perfectly as well. Changing it to the zimbra backend doesn't work.

    Specifically, while trying to login (either from my desktop navigating to my webserver/Microsoft-Server-ActiveSync) or from my iphone results in the same output in debug.txt:

    Is it possible there are some sort of XML or soap dependencies that need to be installed on the ubuntu machine for this to work right? There are scant details on required dependencies to get this installed right.

    Any help is greatly appreciated.
    The only dependency beyond PHP itself is

    php-curl

    as documented in the notes at the top of the zimbra.php file
    Code:
    * PHP.ini File  :   === Replace ===
    *                   max_execution_time = 120      (Maximum execution time of each script, in seconds)
    *                   memory_limit = 128M           (Maximum amount of memory a script may consume)
    *
    * Dependencies  :   php-curl
    How have you set up your proxy on the gentoo machine ?

    Is it doing SSL connections ?

    z-push is installed on gentoo -right ?

    Are you using http mode authentication on zimbra - or https ?

  9. #429
    Join Date
    Dec 2010
    Location
    Brazil
    Posts
    14
    Rep Power
    4

    Default

    The emails in html are incorrectly, they show with html tags.
    Attachments are not displayed.
    The phone is a Nokie E71, z-push 1.4.3 backend 486 and 47.
    Release 6.0.7_GA_2473.RHEL5_20100616214455 CentOS5 FOSS edition.

  10. #430
    liverpoolfcfan's Avatar
    liverpoolfcfan is offline Outstanding Member
    Join Date
    Oct 2009
    Location
    Dublin, IRELAND
    Posts
    710
    Rep Power
    6

    Default

    Quote Originally Posted by Felipe Nolasco View Post
    The emails in html are incorrectly, they show with html tags.
    Attachments are not displayed.
    The phone is a Nokie E71, z-push 1.4.3 backend 486 and 47.
    Release 6.0.7_GA_2473.RHEL5_20100616214455 CentOS5 FOSS edition.
    That is known limitation.

    At this time z-push does not formally support HTML emails.

    There are a couple of experimental/development branches that support the later versions of ActiveSync - but none has formally been released or targeted for release. Once it is clear which one will be used, HTML support will be added.
    Last edited by liverpoolfcfan; 01-24-2011 at 03:32 PM.

Page 43 of 106 FirstFirst ... 3341424344455393 ... LastLast

Thread Information

Users Browsing this Thread

There are currently 2 users browsing this thread. (0 members and 2 guests)

Similar Threads

  1. z-push and zimbra backend problem
    By ben1967 in forum Mobility
    Replies: 9
    Last Post: 11-14-2012, 11:29 PM
  2. z-push and zimbra backend problem
    By ben1967 in forum Administrators
    Replies: 0
    Last Post: 11-11-2012, 02:11 PM
  3. [SOLVED] Z-push Zimbra backend workaround
    By Inchoate in forum Mobility
    Replies: 6
    Last Post: 01-19-2012, 04:22 AM
  4. [SOLVED] Z-push Zimbra backend workaround
    By Inchoate in forum Administrators
    Replies: 0
    Last Post: 10-31-2010, 07:06 AM
  5. Replies: 348
    Last Post: 10-11-2010, 05:39 AM

Posting Permissions

  • You may not post new threads
  • You may not post replies
  • You may not post attachments
  • You may not edit your posts
  •