Page 17 of 22 FirstFirst ... 71516171819 ... LastLast
Results 161 to 170 of 211

Thread: Full Server Backup and Restore of “open source version”

  1. #161
    czaveri's Avatar
    czaveri is offline Former Zimbran
    Join Date
    Feb 2006
    Location
    Pune, India
    Posts
    294
    Rep Power
    9

    Default

    Quote Originally Posted by jpcaldwell View Post
    Gave that a try, but it still wants to login as root
    That's probably because we are trying to use "File::Rsync" and not "rsync". File::Rsync uses the options from "man rsync". I could not find option to change the user.

    Workaround may be to run this script as a local user with the same username as the one on remote system and then setup password-less and passphrase-less login.
    Regards,

    Chintan Zaveri
    (Yet another ZIMBRAN!)

    "Dhundhne par Bhagwan bhi ..."

  2. #162
    ghstridr is offline Intermediate Member
    Join Date
    Apr 2007
    Posts
    18
    Rep Power
    8

    Default

    Quote Originally Posted by rmvg View Post
    thanks for the tips bobby mabey u can tell me how to get output of the script to a file somewhere.

    I am using putty on a wireless connection and it keeps dieing on me so i cannot tell weather the script completed or not. I tried script /var/tmp/zimbra1 but it dies as soon as the putty term does!!!
    Try using the 'screen' program. It will start a virtual terminal that you can disconnect from and come back to later, it's great for use when you are on a wireless or modem connection.

  3. #163
    mmorse's Avatar
    mmorse is offline Moderator
    Join Date
    May 2006
    Location
    USA
    Posts
    6,242
    Rep Power
    21

    Default

    Quote Originally Posted by czaveri View Post
    Workaround may be to run this script as a local user with the same username as the one on remote system and then setup password-less and passphrase-less login.
    And remember to give them root permissions/super-user/whatever it's called on your system so they can copy the files owned by root.root

  4. #164
    gfdos.sys is offline Senior Member
    Join Date
    Sep 2005
    Location
    Buffalo, NY
    Posts
    65
    Rep Power
    9

    Default Restoring Backed up Zimbra to new/different hardware

    Discussion of how to restore backed up Zimbra info from one PC on another has its own thread with smiles to all the employees/moderators that yell at people for tagging onto old posts with new/different problems, or cross posting.
    Everyone who has helped on this thread, please smile back by coming to the new thread and helping me!

  5. #165
    Tenshi is offline Junior Member
    Join Date
    Apr 2007
    Posts
    8
    Rep Power
    8

    Default

    I'm having difficulties with the zimbraColdBackup script, but unless it's just the fact that it is monday morning... can't seem to figure what is the problem...

    When it restarts the services, it will fail on logger (mysqld process already exists) and snmp... that's the minor stuff...

    The bigger is that it will report:
    Code:
    Rsync Zimbra: Successfully created /Backups/06-11-2007-Monday-10-09-1181570940
    Starting Zimbra: Some Problem Occurred. Please check.
    Zimbra was off-line for: 70 seconds
    The backup took: 70 seconds
    However, no such file will actually be in the directory... Any insight would be appreciated...

  6. #166
    hallm is offline Junior Member
    Join Date
    Aug 2007
    Posts
    9
    Rep Power
    7

    Default Mailer error on ZimbraColdBackup script

    I'm getting the following error at the end of the script when it tries to send the confirmation email. Any ideas? That line is the defalt for the script. I have Ubuntu dapper install (Not Lamp) with Zimbra Open Source. It does appear to finish the actual backup.

    No mailer type specified (and no default available), thus can not find executable program. at ./zimbraColdBackup.pl line 452

  7. #167
    czaveri's Avatar
    czaveri is offline Former Zimbran
    Join Date
    Feb 2006
    Location
    Pune, India
    Posts
    294
    Rep Power
    9

    Default

    Quote Originally Posted by hallm View Post
    I'm getting the following error at the end of the script when it tries to send the confirmation email. Any ideas? That line is the defalt for the script. I have Ubuntu dapper install (Not Lamp) with Zimbra Open Source. It does appear to finish the actual backup.

    No mailer type specified (and no default available), thus can not find executable program. at ./zimbraColdBackup.pl line 452
    I am not sure if this would help, but worth a try. Create a symbolic link from the sendmail binary in /opt/zimbra.

    like:
    ln -s /opt/zimbra/postfix-2.2.9/sbin/sendmail /usr/sbin/sendmail

    This script has worked on SuSE, RHEL, CentOS, and so on. Never tried on Debian-based systems.

    Regards,

    Chintan Zaveri
    (Yet another ZIMBRAN!)

    "Dhundhne par Bhagwan bhi ..."

  8. #168
    hallm is offline Junior Member
    Join Date
    Aug 2007
    Posts
    9
    Rep Power
    7

    Default

    I made the change. I'll let you know if I get an email tonight.

  9. #169
    dwmtractor's Avatar
    dwmtractor is offline Moderator
    Join Date
    Jul 2007
    Location
    San Jose, CA
    Posts
    1,027
    Rep Power
    10

    Exclamation Vote on FOSS hot backups

    Anybody still monitoring this thread should check out this thread from Zimbra and cast your vote for FOSS hot backups.

    Vote: Hot Backups for FOSS?

    Dan

  10. #170
    SGIA's Avatar
    SGIA is offline Member
    Join Date
    Sep 2008
    Location
    Germany
    Posts
    13
    Rep Power
    6

    Default Backup for User Accounts

    Hi, I was able to facilitate an automated hot backup for individual users.

    I am new to Zimbra and as my page says, not a guru by any means, but if you don't have too many huge mailboxes then this works quite fine:

    User:SGIA - Zimbra :: Wiki

    You will still need to account for a full system backup for server configuration for disaster recovery, however this must not be as often as user data.

    SG

Page 17 of 22 FirstFirst ... 71516171819 ... LastLast

LinkBacks (?)

  1. 11-14-2007, 01:09 AM
  2. 08-13-2007, 04:01 AM
  3. 07-31-2007, 09:37 AM
  4. 06-08-2007, 10:09 AM
  5. 05-31-2007, 01:44 PM

Thread Information

Users Browsing this Thread

There are currently 1 users browsing this thread. (0 members and 1 guests)

Similar Threads

  1. mailbox backup & restore on open source version
    By Artturi in forum Administrators
    Replies: 3
    Last Post: 07-30-2010, 04:26 PM
  2. Restore single account failed from full backup
    By fmodola in forum Administrators
    Replies: 4
    Last Post: 06-20-2007, 05:27 AM
  3. 3 testing: LDAP: 389 Failed when restore zimbra
    By victorLeong in forum Administrators
    Replies: 15
    Last Post: 05-24-2007, 06:45 AM
  4. copying only last full backup to store offsite
    By riccadus in forum Administrators
    Replies: 0
    Last Post: 01-11-2007, 01:29 AM
  5. Zimbra Full Backup and Restore???
    By jgao in forum Administrators
    Replies: 3
    Last Post: 01-19-2006, 01:34 PM

Posting Permissions

  • You may not post new threads
  • You may not post replies
  • You may not post attachments
  • You may not edit your posts
  •