This morning I attempted to migrate my 32-bit installation (FOSS 6.0.6 on CentOS 4) to a 64-bit VM running CentOS 5). As a basis for my migration I used this wiki page. I know it says it is for the Network Edition, but my understanding from reading the document and info I found here in the forums leads me to believe it should work for the OS edition as well. Unfortunately it did not work for me.

Everything seemed to go OK, but the Zimbra "mailbox" process would not stay up and running. I believe the problem stemmed either from me incorrectly copying configuration info from the old server to the new and/or something to do with self-signed certificates.

The configuration info in the localconfig.xml that I'm not sure of is the "mailboxd_keystore_base_password". According to the documentation I should copy the value for this "key" over from the old to the new. However, this key did not exist at all on the new server. All the other values that I copied over existed, and I overwrote them with the data from the old server, but for this key I actually created the entire XML "stanza". Should I not have done that?

Beyond, or in addition to that, I guess I needed to do something with the self-signed certificates that we use. The wiki talks about commercial certificates, but does not mention self-signed certificates. Did I need to move those over from the old server or just re-create new ones?

I did try to re-create the self-signed certificates using info from this wiki page. However, when I tried to deploy the certificate I got the following:
Code:
** Saving server config key zimbraSSLCertificate...failed.
** Saving server config key zimbraSSLPrivateKey...failed.
** Installing mta certificate and key...done.
** Installing slapd certificate and key...done.
** Installing proxy certificate and key...done.
** Creating pkcs12 file /opt/zimbra/ssl/zimbra/jetty.pkcs12...done.
** Creating keystore file /opt/zimbra/mailboxd/etc/keystore...failed.

Exception in thread "main" java.io.IOException: Keystore was tampered with, or p
assword was incorrect
	at sun.security.provider.JavaKeyStore.engineLoad(JavaKeyStore.java:771)
	at sun.security.provider.JavaKeyStore$JKS.engineLoad(JavaKeyStore.java:3
8)
	at java.security.KeyStore.load(KeyStore.java:1185)
	at com.zimbra.cert.MyPKCS12Import.main(MyPKCS12Import.java:98)
Caused by: java.security.UnrecoverableKeyException: Password verification failed

	at sun.security.provider.JavaKeyStore.engineLoad(JavaKeyStore.java:769)
	... 3 more

** Installing CA to /opt/zimbra/conf/ca...done.
So, obviously it is not liking something with a password from somewhere. Could this be because of the extra value I added in localconfig.xml file?

I did try a few other things to fix this, but I fear at this point I am just making things worse. I have rolled back to my old server and everything is up and running, but would like to solve this issue in the very near future.

Any help would be most greatly appreciated.

Thanks,
John